summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2016-04-01 16:33:16 -0400
committerMichael Sterrett <mr_bones_@gentoo.org>2016-04-01 16:33:16 -0400
commit54a57f8640779fe7f36e296c6b424c3b658cbb81 (patch)
tree9fc5af9fe28b9d977673f7ea24c551edd5af0d6b /games-rpg
parentgames-strategy/wargus-data: wargus is needed for wartool (bug #578340) (diff)
downloadgentoo-54a57f8640779fe7f36e296c6b424c3b658cbb81.tar.gz
gentoo-54a57f8640779fe7f36e296c6b424c3b658cbb81.tar.bz2
gentoo-54a57f8640779fe7f36e296c6b424c3b658cbb81.zip
games-rpg/manaplus: version bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/manaplus/Manifest1
-rw-r--r--games-rpg/manaplus/manaplus-1.6.3.26.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/games-rpg/manaplus/Manifest b/games-rpg/manaplus/Manifest
index b2dbe70fc74a..43750591a0c1 100644
--- a/games-rpg/manaplus/Manifest
+++ b/games-rpg/manaplus/Manifest
@@ -1,2 +1,3 @@
DIST manaplus-1.5.11.21.tar.xz 9556540 SHA256 57b6e0d8a730f56060062aa0d6e6baafc100860aa2cc4ba5120d21772410aae6 SHA512 145479b9b6912064356f842910c2a5bbb16bacc7372b898d98f237514722bbac4c6f3fe49ee30942b6e38820cfe9d3508ba5ac64b858a6003e27569327729d7d WHIRLPOOL 628009c082219c63f42892881060dff3784ae419d3d6dab95357272774d0d0545a97cf0d7190157e3338ac38e7f821fe9e3a893f24ee10be71ec6ac83c097722
DIST manaplus-1.6.2.27.tar.xz 9642388 SHA256 1f8b3209b5e71250f0ccf643c5e26e7770258d903986e48066a4233a4b9d8d4e SHA512 ba03f8f317ad0ab7f4039ee3d032134aee9fbb4584ffa5b63ee18935ac0e59647a4373c9a52a1b69b2117de22f73907a647f8c07209ae968d6b170ddfdbada8b WHIRLPOOL 08ce25c664fc3c26af7af78ec83d900cab75b7330ff02e736a92850a2b03d52fe4726b76938548a56ce5d72823d2198e62129df76dced03befe0754f6145a404
+DIST manaplus-1.6.3.26.tar.xz 9721160 SHA256 87aee4fdaec09337fe711ee85e515470374ea9387e45622caa712a6414f5b253 SHA512 f84718c40799c619a2a320e5589dffa05f52ebd7e4710c640947f4083c59146bb2b7c10a429f68f9963086f1a07c92b8a049c0a0092659108cf52c767d834566 WHIRLPOOL 4887d9699378e3fad95f48268234c1279bbfed66138cdbd9875227e9ebc8c598ac6aa530230537cfc79d1d100216f4b3049e5c4b55ae34545ea09c5fdec284dc
diff --git a/games-rpg/manaplus/manaplus-1.6.3.26.ebuild b/games-rpg/manaplus/manaplus-1.6.3.26.ebuild
new file mode 100644
index 000000000000..193b66eeb7f0
--- /dev/null
+++ b/games-rpg/manaplus/manaplus-1.6.3.26.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit games
+
+DESCRIPTION="OpenSource 2D MMORPG client for Evol Online and The Mana World"
+HOMEPAGE="http://manaplus.evolonline.org"
+SRC_URI="http://download.evolonline.org/manaplus/download/${PV}/manaplus-${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls opengl"
+
+RDEPEND="
+ >=dev-games/physfs-1.0.0
+ dev-libs/libxml2
+ media-libs/libpng:0=
+ media-libs/libsdl2[X,opengl?,video]
+ media-libs/sdl2-gfx
+ media-libs/sdl2-image[png]
+ media-libs/sdl2-mixer[vorbis]
+ media-libs/sdl2-net
+ media-libs/sdl2-ttf
+ net-misc/curl
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-misc/xdg-utils
+ x11-apps/xmessage
+ media-fonts/dejavu
+ media-fonts/wqy-microhei
+ media-fonts/liberation-fonts
+ media-fonts/mplus-outline-fonts
+ nls? ( virtual/libintl )
+ opengl? ( virtual/opengl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_configure() {
+ CONFIG_SHELL=/bin/bash \
+ egamesconf \
+ --with-sdl2 \
+ --without-internalsdlgfx \
+ --localedir=/usr/share/locale \
+ --prefix="/usr" \
+ --bindir="${GAMES_BINDIR}" \
+ $(use_with opengl) \
+ $(use_enable nls)
+}
+
+src_install() {
+ default
+ dosym /usr/share/fonts/dejavu/DejaVuSans-Bold.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavusans-bold.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSans.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavusans.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSansMono-Bold.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavusansmono-bold.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSansMono.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavusansmono.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSerifCondensed-Bold.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavuserifcondensed-bold.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSerifCondensed.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavuserifcondensed.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationMono-Bold.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/liberationsansmono-bold.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationMono-Regular.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/liberationsansmono.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationSans-Bold.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/liberationsans-bold.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationSans-Regular.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/liberationsans.ttf
+ dosym /usr/share/fonts/mplus-outline-fonts/mplus-1p-bold.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/mplus-1p-bold.ttf
+ dosym /usr/share/fonts/mplus-outline-fonts/mplus-1p-regular.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/mplus-1p-regular.ttf
+ dosym /usr/share/fonts/wqy-microhei/wqy-microhei.ttc "${GAMES_DATADIR}"/${PN}/data/fonts/wqy-microhei.ttf
+
+ prepgamesdirs
+}