summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2017-01-28 01:02:27 +0100
committerMichael Weber <xmw@gentoo.org>2017-01-28 01:02:27 +0100
commit5a523ff90c15898ff2ed1778701414a86e2fbd14 (patch)
tree205df4c775e29bcd025a76fa226841c788a3c811 /games-simulation/crrcsim/crrcsim-0.9.13.ebuild
parentdev-libs/libcss: Fix deps (bug 607006). (diff)
downloadgentoo-5a523ff90c15898ff2ed1778701414a86e2fbd14.tar.gz
gentoo-5a523ff90c15898ff2ed1778701414a86e2fbd14.tar.bz2
gentoo-5a523ff90c15898ff2ed1778701414a86e2fbd14.zip
games-simulation/crrcsim: Version bump (bug 601238, thanks Grant Edwards).
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'games-simulation/crrcsim/crrcsim-0.9.13.ebuild')
-rw-r--r--games-simulation/crrcsim/crrcsim-0.9.13.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/games-simulation/crrcsim/crrcsim-0.9.13.ebuild b/games-simulation/crrcsim/crrcsim-0.9.13.ebuild
new file mode 100644
index 000000000000..579b6a8c0f98
--- /dev/null
+++ b/games-simulation/crrcsim/crrcsim-0.9.13.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+WANT_AUTOMAKE="1.10"
+inherit autotools eutils gnome2-utils
+
+DESCRIPTION="model-airplane flight simulation program"
+HOMEPAGE="https://sourceforge.net/projects/crrcsim/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="portaudio"
+
+RDEPEND="media-libs/libsdl[X,sound,joystick,opengl,video]
+ media-libs/plib
+ sci-mathematics/cgal
+ portaudio? ( media-libs/portaudio )"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-buildsystem.patch )
+
+src_prepare() {
+ default
+
+ if has_version "sci-mathematics/cgal[gmp(+)]" ; then
+ eapply "${FILESDIR}"/${PN}-cgal_gmp.patch
+ fi
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --datadir="/usr/share" \
+ --datarootdir="${EPREFIX%/}/usr/share" \
+ --docdir="${EPREFIX%/}/usr/share/doc/${PF}" \
+ $(use_with portaudio)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS HISTORY NEWS README
+ doicon -s 32 packages/icons/${PN}.png
+ make_desktop_entry ${PN}
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}