summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2019-11-20 23:22:42 +0000
committerJames Le Cuirot <chewi@gentoo.org>2019-11-20 23:24:37 +0000
commitb2f2bb83e10cb87b31e31d1e3e866b9f9c885fa4 (patch)
tree0f1c10d071af31112ba19f4f0eb97a8ecab8551d /games-simulation/micropolis
parentmedia-libs/vulkan-layers: Install support headers (diff)
downloadgentoo-b2f2bb83e10cb87b31e31d1e3e866b9f9c885fa4.tar.gz
gentoo-b2f2bb83e10cb87b31e31d1e3e866b9f9c885fa4.tar.bz2
gentoo-b2f2bb83e10cb87b31e31d1e3e866b9f9c885fa4.zip
games-simulation/micropolis: 1.0_p20180313 bump using GitLab tarball
We were downloading a large patch but this was being modified in place so I found the originating git repository. Closes: https://bugs.gentoo.org/700594 Package-Manager: Portage-2.3.79, Repoman-2.3.17 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-simulation/micropolis')
-rw-r--r--games-simulation/micropolis/Manifest1
-rw-r--r--games-simulation/micropolis/metadata.xml15
-rw-r--r--games-simulation/micropolis/micropolis-1.0_p20180313.ebuild51
3 files changed, 62 insertions, 5 deletions
diff --git a/games-simulation/micropolis/Manifest b/games-simulation/micropolis/Manifest
index 246ae600ea6b..13bae919aaa3 100644
--- a/games-simulation/micropolis/Manifest
+++ b/games-simulation/micropolis/Manifest
@@ -1,2 +1,3 @@
DIST micropolis-activity-source.tgz 7676438 BLAKE2B 9415cf2f1980fe5a1f412561c9a53dca86d388f9fb529801af1e6071b3c92bc03daaff84c1ac1f964578d5805a4f2a9f60cfa0c56c0a1032bc0eed686207e538 SHA512 fe65966c43d044e01a63a3cfe3cad48466eb1e5ec8b13c03abb52d582395a8ab527332d4d04454a4f32e85b65e55d72fe5e4d53a3f37b422d90e9208f00d9976
+DIST micropolis-cc31822e4ebe54c0109623ac0c5cdf0e3acad755.tar.bz2 6725746 BLAKE2B a916389a1ccf63e1a13b5b6ea533939fdb14d814480c9e528c8b1bb89cbefbbad9ad067821c1de199f337692e226d35b3219354dc32612486d013cc20f21c5bc SHA512 1b5f644f6d7d7cb78965d0e0edcfcc0bdab7a103dd5dc3ce97a0048da9fa29d8757063d6681febab3d03182433cfe8a7bf1b8145a21e067a4c754af3b5af8e00
DIST micropolis_git.patch 83549 BLAKE2B 13cd94f3018ffd23dcbe5c1baf0b948cac7fb9b2f858d42f259003f2697060b156b900fcc8611e560a8b46e0e68fb6ff78d376bfc937cf12b55655067fb13f6d SHA512 9d1801478a27184c48d327094cad8238f7972c2cf3624c7c196375f2dd20c3374575b393d44cb2fb99613e19d66c4cc4fb27ae52df9fddf4e42adb42523bdc17
diff --git a/games-simulation/micropolis/metadata.xml b/games-simulation/micropolis/metadata.xml
index eac64a74f324..4f01ecb15136 100644
--- a/games-simulation/micropolis/metadata.xml
+++ b/games-simulation/micropolis/metadata.xml
@@ -1,9 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="person"><email>hanno@gentoo.org</email></maintainer>
-<maintainer type="project">
-<email>games@gentoo.org</email>
-<name>Gentoo Games Project</name>
-</maintainer>
+ <maintainer type="person">
+ <email>hanno@gentoo.org</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="gitlab">stargo/micropolis</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/games-simulation/micropolis/micropolis-1.0_p20180313.ebuild b/games-simulation/micropolis/micropolis-1.0_p20180313.ebuild
new file mode 100644
index 000000000000..c1c8bfccecec
--- /dev/null
+++ b/games-simulation/micropolis/micropolis-1.0_p20180313.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop eutils toolchain-funcs
+
+COMMIT="cc31822e4ebe54c0109623ac0c5cdf0e3acad755"
+DESCRIPTION="Free version of the well-known city building simulation"
+HOMEPAGE="https://www.donhopkins.com/home/micropolis/"
+SRC_URI="https://gitlab.com/stargo/micropolis/-/archive/${COMMIT}/micropolis-${COMMIT}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ x11-libs/libX11
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/bison"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_prepare() {
+ default
+
+ sed -i -e "s:-O3:${CFLAGS}:" \
+ src/tclx/config.mk src/{sim,tcl,tk}/makefile || die
+ sed -i -e "s:XLDFLAGS=:&${LDFLAGS}:" \
+ src/tclx/config.mk || die
+}
+
+src_compile() {
+ emake -C src LDFLAGS="${LDFLAGS}" CC="$(tc-getCC)"
+}
+
+src_install() {
+ local dir=/usr/share/${PN}
+
+ exeinto "${dir}/res"
+ doexe src/sim/sim
+ insinto "${dir}"
+ doins -r activity cities images manual res
+
+ make_wrapper micropolis res/sim "${dir}"
+ doicon Micropolis.png
+ make_desktop_entry micropolis "Micropolis" Micropolis
+}