summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-strategy/boswars
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-strategy/boswars')
-rw-r--r--games-strategy/boswars/Manifest3
-rw-r--r--games-strategy/boswars/boswars-2.7-r1.ebuild67
-rw-r--r--games-strategy/boswars/files/boswars-2.7-gentoo.patch12
-rw-r--r--games-strategy/boswars/files/boswars-2.7-scons-blows.patch27
-rw-r--r--games-strategy/boswars/metadata.xml10
5 files changed, 119 insertions, 0 deletions
diff --git a/games-strategy/boswars/Manifest b/games-strategy/boswars/Manifest
new file mode 100644
index 000000000000..14a34621a4fc
--- /dev/null
+++ b/games-strategy/boswars/Manifest
@@ -0,0 +1,3 @@
+DIST bos.png 620 SHA256 fe1d24bc722093bd3882ecab15c15f61b6b0edee263bfd58af662825e76d8b0a SHA512 6a15a5c82f9cff3462d498620a1dd1c7a2a460119689078157e61b27e7e5243a8ac2da7f01c1848d614167a3a748ca1f3e03c1f218479ede3a1c2c0ae85b3cc3 WHIRLPOOL 4688e15b35a4c6e6888b867f16e646e520bf00cbb04d586b08567b2177fe9e82d0a2e1c31060c18ac2149df727f8a781f4394936c77a0d0b6ef846051ff760e7
+DIST boswars-2.7-fixed-images-for-libpng-1.6.tar.xz 552956 SHA256 87f3ee7f4045c3acfacd884348a2b376e710b42aa0f40acbc212732d0bee9a24 SHA512 794addf06cfd5c5bb0ad0988a90337a3a6332789de7bc942807602c84c4fafe4c4b12da63ae210ca220a1be6dcd9677fa9ddb1ae62a7d26a7748af35b07303dc WHIRLPOOL d6bc11f8db099cd91976590a25e63eed51c2cd724eb64d2e859556dcf3ef22a66451b114542a0e0bcc819c517b4c5fdb3e294680a9e11dbe990650815ac37507
+DIST boswars-2.7-src.tar.gz 77280735 SHA256 dc3718f531e9ea413cf37e1333b62a4c5e69f1405502d9c59b9e424635135e3e SHA512 2573c61684e83f356a80292adcf780cc001a4be2a31abba20e6f93ed6deaa38b8eca87f29935a4fe0edc9b4e0fdc3f78ddd709b8132aaaa048ffbcd6c498ec80 WHIRLPOOL f8e0156fbf2d868eb4066bab0592a9fc5c1fce055aba81c056da1d10da4112913f50312fc1526a0ff62159a84b9463907c92b8ae54445fab20dc5879bf961322
diff --git a/games-strategy/boswars/boswars-2.7-r1.ebuild b/games-strategy/boswars/boswars-2.7-r1.ebuild
new file mode 100644
index 000000000000..2938aaec01b3
--- /dev/null
+++ b/games-strategy/boswars/boswars-2.7-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils scons-utils games
+
+DESCRIPTION="Futuristic real-time strategy game"
+HOMEPAGE="http://www.boswars.org/"
+SRC_URI="http://www.boswars.org/dist/releases/${P}-src.tar.gz
+ http://dev.gentoo.org/~hasufell/distfiles/${P}-fixed-images-for-libpng-1.6.tar.xz
+ mirror://gentoo/bos.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="dev-lang/lua
+ media-libs/libsdl[opengl,sound,video]
+ media-libs/libpng:0
+ media-libs/libvorbis
+ media-libs/libtheora
+ media-libs/libogg
+ virtual/opengl
+ x11-libs/libX11"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${P}-src
+
+src_unpack() {
+ default
+ # bug 475764
+ cp -dRp ${P}-fixed-images-for-libpng-1.6/* ${P}-src/ \
+ || die "copying fixed images failed!"
+}
+
+src_prepare() {
+ rm -f doc/{README-SDL.txt,guichan-copyright.txt}
+ epatch \
+ "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-scons-blows.patch
+ sed -i \
+ -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ engine/include/stratagus.h \
+ || die
+ sed -i \
+ -e "/-O2/s:-O2.*math:${CXXFLAGS} -Wall:" \
+ SConstruct \
+ || die
+}
+
+src_compile() {
+ escons || die
+}
+
+src_install() {
+ newgamesbin build/${PN}-release ${PN}
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r campaigns graphics intro languages maps patches scripts sounds units
+ newicon "${DISTDIR}"/bos.png ${PN}.png
+ make_desktop_entry ${PN} "Bos Wars"
+ # COPYRIGHT.txt is referenced by the html
+ dodoc CHANGELOG COPYRIGHT.txt README.txt
+ dohtml -r doc/*
+ prepgamesdirs
+}
diff --git a/games-strategy/boswars/files/boswars-2.7-gentoo.patch b/games-strategy/boswars/files/boswars-2.7-gentoo.patch
new file mode 100644
index 000000000000..9459c77d89bc
--- /dev/null
+++ b/games-strategy/boswars/files/boswars-2.7-gentoo.patch
@@ -0,0 +1,12 @@
+diff -ru boswars-2.6.1-src.orig/engine/include/stratagus.h boswars-2.6.1-src/engine/include/stratagus.h
+--- boswars-2.6.1-src.orig/engine/include/stratagus.h 2010-04-11 08:12:18.000000000 -0400
++++ boswars-2.6.1-src/engine/include/stratagus.h 2010-05-22 02:33:50.021377764 -0400
+@@ -133,7 +133,7 @@
+ -- General
+ ----------------------------------------------------------------------------*/
+ #ifndef STRATAGUS_LIB_PATH
+-#define STRATAGUS_LIB_PATH "." /// Where to find the data files
++#define STRATAGUS_LIB_PATH "@GENTOO_DATADIR@" /// Where to find the data files
+ #endif
+
+ #ifndef STRATAGUS_HOME_PATH
diff --git a/games-strategy/boswars/files/boswars-2.7-scons-blows.patch b/games-strategy/boswars/files/boswars-2.7-scons-blows.patch
new file mode 100644
index 000000000000..0a7029df4971
--- /dev/null
+++ b/games-strategy/boswars/files/boswars-2.7-scons-blows.patch
@@ -0,0 +1,27 @@
+--- SConstruct.orig 2010-11-19 21:09:45.724976603 -0500
++++ SConstruct 2010-11-19 21:11:05.723197985 -0500
+@@ -22,6 +22,7 @@
+ ##
+
+ import os
++import SCons.Util
+ import sys
+ import glob
+ from stat import *
+@@ -50,6 +51,16 @@
+
+ opts = DefineOptions("build_options.py", ARGUMENTS)
+ env = Environment(ENV = {'PATH':os.environ['PATH']}) # for an unknown reason Environment(options=opts) doesnt work well
++if os.environ.has_key('CC'):
++ env['CC'] = os.environ['CC']
++if os.environ.has_key('CFLAGS'):
++ env['CCFLAGS'] += SCons.Util.CLVar(os.environ['CFLAGS'])
++if os.environ.has_key('CXX'):
++ env['CXX'] = os.environ['CXX']
++if os.environ.has_key('CXXFLAGS'):
++ env['CXXFLAGS'] += SCons.Util.CLVar(os.environ['CXXFLAGS'])
++if os.environ.has_key('LDFLAGS'):
++ env['LINKFLAGS'] += SCons.Util.CLVar(os.environ['LDFLAGS'])
+ opts.Update(env) # Needed as Environment(options=opts) doesnt seem to work
+ Help(opts.GenerateHelpText(env))
+ mingw = env.Clone()
diff --git a/games-strategy/boswars/metadata.xml b/games-strategy/boswars/metadata.xml
new file mode 100644
index 000000000000..84108ff3546c
--- /dev/null
+++ b/games-strategy/boswars/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription lang="en">
+Bos Wars is a futuristic real-time strategy game. It is possible to play against
+human opponents over LAN, internet, or against the computer.
+Bos Wars aims to create a completely original and fun open source RTS game.
+</longdescription>
+</pkgmetadata>