summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-04-23 11:35:03 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-04-23 12:05:20 +0200
commit5e99d2ca2d2cf1c7ae9933c00a01158ed548f8f6 (patch)
tree6b23551ecbafa21302ffb85487b3011d9e02409b /games-strategy/freeorion/freeorion-9999.ebuild
parentmail-filter/rspamd: remove unused patches (diff)
downloadgentoo-5e99d2ca2d2cf1c7ae9933c00a01158ed548f8f6.tar.gz
gentoo-5e99d2ca2d2cf1c7ae9933c00a01158ed548f8f6.tar.bz2
gentoo-5e99d2ca2d2cf1c7ae9933c00a01158ed548f8f6.zip
games-strategy/freeorion: Bumped live ebuild to EAPI-7
Package-Manager: Portage-2.3.64, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'games-strategy/freeorion/freeorion-9999.ebuild')
-rw-r--r--games-strategy/freeorion/freeorion-9999.ebuild22
1 files changed, 13 insertions, 9 deletions
diff --git a/games-strategy/freeorion/freeorion-9999.ebuild b/games-strategy/freeorion/freeorion-9999.ebuild
index 8d750687b353..578e570e2ffd 100644
--- a/games-strategy/freeorion/freeorion-9999.ebuild
+++ b/games-strategy/freeorion/freeorion-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python2_7 )
-inherit cmake-utils python-single-r1 gnome2-utils
+inherit cmake-utils python-single-r1 xdg
DESCRIPTION="A free turn-based space empire and galactic conquest game"
HOMEPAGE="http://www.freeorion.org"
@@ -40,7 +40,8 @@ RDEPEND="
!dev-games/gigi"
# Use bundled gigi as of freeorion-0.4.3
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
${PYTHON_DEPS}
virtual/pkgconfig"
@@ -57,12 +58,11 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
- -DCMAKE_BUILD_TYPEE=Release
- -DRELEASE_COMPILE_FLAGS=""
+ -DCMAKE_BUILD_TYPE=Release
-DCMAKE_SKIP_RPATH=ON
)
- append-cppflags -DBOOST_OPTIONAL_CONFIG_USE_OLD_IMPLEMENTATION_OF_OPTIONAL
+ #append-cppflags -DBOOST_OPTIONAL_CONFIG_USE_OLD_IMPLEMENTATION_OF_OPTIONAL
cmake-utils_src_configure
}
@@ -74,10 +74,14 @@ src_install() {
newenvd "${FILESDIR}/${PN}.envd" 99${PN}
}
+pkg_preinst() {
+ xdg_pkg_preinst
+}
+
pkg_postinst() {
- gnome2_icon_cache_update
+ xdg_pkg_postinst
}
pkg_postrm() {
- gnome2_icon_cache_update
+ xdg_pkg_postrm
}