summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-05-01 14:42:04 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-08 18:59:31 +0200
commitb83f541321d7953d9dd934597560ef62eb44c7de (patch)
treead4dc631301379b51be24d4c464293402502fce5 /games-strategy/freeorion
parentdev-python/pyilmbase: Fix configure w/ >=boost-1.70 (diff)
downloadgentoo-b83f541321d7953d9dd934597560ef62eb44c7de.tar.gz
gentoo-b83f541321d7953d9dd934597560ef62eb44c7de.tar.bz2
gentoo-b83f541321d7953d9dd934597560ef62eb44c7de.zip
games-strategy/freeorion: 0.4.8_p20190501 snapshot bump, EAPI-7 bump
The amount of patching required to fix build with boost-1.70 but stay compatible with <boost-1.66 was too much to do 0.4.8. Closes: https://bugs.gentoo.org/652446 Closes: https://bugs.gentoo.org/664900 Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'games-strategy/freeorion')
-rw-r--r--games-strategy/freeorion/Manifest1
-rw-r--r--games-strategy/freeorion/freeorion-0.4.8_p20190501.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/games-strategy/freeorion/Manifest b/games-strategy/freeorion/Manifest
index ee95a9473b37..e8a787a99287 100644
--- a/games-strategy/freeorion/Manifest
+++ b/games-strategy/freeorion/Manifest
@@ -1 +1,2 @@
DIST freeorion-0.4.7.1.tar.gz 105942075 BLAKE2B f75940ac79e329fd7e03e85b1cd712ff6dcf06583ad8feff43f8b2d6e28a53c9029724d1450d26d2367bafd1d04858e3659b8e47986df96657d91526f594eb5e SHA512 9c8d0437ee827a1104a541e1123ce6b5d229bd6253bfe275028805a4c34de882ca3a9d5361e3f64098f935d0926a656a64fe468690c8d195e05de86cd1b2699d
+DIST freeorion-0.4.8_p20190501.tar.gz 106506540 BLAKE2B 5442eeeaff486a5525b4282c7ef72001a935c4429fea89a720f94a033a2c29e56855605376efe22d13194ae3f49105fe26f37554d2c8d560bfb76dc69d738128 SHA512 d378c0e9b63118261bf5ac1c99190929ff0cd52b3a270e43fe2be80cc7993457bcc7b70083ff493a6b96b250e1988e40470bef410af5ce3d49644ccf934974d3
diff --git a/games-strategy/freeorion/freeorion-0.4.8_p20190501.ebuild b/games-strategy/freeorion/freeorion-0.4.8_p20190501.ebuild
new file mode 100644
index 000000000000..de4fdff7f15b
--- /dev/null
+++ b/games-strategy/freeorion/freeorion-0.4.8_p20190501.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+inherit cmake-utils python-single-r1 xdg
+
+DESCRIPTION="A free turn-based space empire and galactic conquest game"
+HOMEPAGE="https://www.freeorion.org"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/freeorion/freeorion.git"
+else
+ KEYWORDS="~amd64"
+ if [[ ${PV} = *_p* ]]; then
+ COMMIT="2a49c05796f1c92b96ce9b2aeaf0124fc8be7a77"
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT}"
+ else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${PV/_/-}"
+ fi
+fi
+
+LICENSE="GPL-2 LGPL-2.1 CC-BY-SA-3.0"
+SLOT="0"
+IUSE="dedicated"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND="
+ >=dev-libs/boost-1.58:=[python,threads,${PYTHON_USEDEP}]
+ !dedicated? (
+ media-libs/freealut
+ >=media-libs/freetype-2.5.5
+ media-libs/glew:=
+ >=media-libs/libogg-1.1.3
+ media-libs/libpng:0=
+ media-libs/libsdl2[X,opengl,video]
+ >=media-libs/libvorbis-1.1.2
+ media-libs/openal
+ sci-physics/bullet
+ virtual/opengl
+ )
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+"
+
+pkg_setup() {
+ # build system is using FindPythonLibs.cmake which needs python:2
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ sed -e "s/-O3//" -i CMakeLists.txt || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_BUILD_TYPE=Release
+ -DCMAKE_SKIP_RPATH=ON
+ -DBUILD_HEADLESS="$(usex dedicated)"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ newenvd "${FILESDIR}/${PN}.envd" 99${PN}
+}