summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-strategy/majesty-demo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-strategy/majesty-demo')
-rw-r--r--games-strategy/majesty-demo/Manifest1
-rw-r--r--games-strategy/majesty-demo/majesty-demo-1.0.0.ebuild44
-rw-r--r--games-strategy/majesty-demo/metadata.xml5
3 files changed, 50 insertions, 0 deletions
diff --git a/games-strategy/majesty-demo/Manifest b/games-strategy/majesty-demo/Manifest
new file mode 100644
index 000000000000..637137ca3c9e
--- /dev/null
+++ b/games-strategy/majesty-demo/Manifest
@@ -0,0 +1 @@
+DIST majesty_demo.run 36582366 SHA256 453b2bfa0a2473810945c717563cc459fc2b2cdd713155272872b1d8ef695de9 SHA512 0573b29fa2635aeb0aa6ebaaa55c924322b3805e120f49fde51409cc6f101d7ae41d72ed0d086ffeac4d591ba75ee8bc190c46a3b71adb6b36d867df16be2c79 WHIRLPOOL 952027eb333098c156dd5e314a7694d40e6f9e57d0d3e97ad6edc9e2d2bdca31518e9354e074e3e27cebd607ce1b134df567926fde68679a6af083784e1896fb
diff --git a/games-strategy/majesty-demo/majesty-demo-1.0.0.ebuild b/games-strategy/majesty-demo/majesty-demo-1.0.0.ebuild
new file mode 100644
index 000000000000..a68e45797681
--- /dev/null
+++ b/games-strategy/majesty-demo/majesty-demo-1.0.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils unpacker games
+
+DESCRIPTION="Control your own kingdom in this simulation"
+HOMEPAGE="http://www.linuxgamepublishing.com/info.php?id=8&"
+SRC_URI="http://ftp2.za.freebsd.org/pub/FreeBSD/ports/distfiles/majesty_demo.run"
+
+LICENSE="MAJESTY-DEMO"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+RESTRICT="bindist strip"
+
+RDEPEND="sys-libs/glibc
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ x11-libs/libXau[abi_x86_32(-)]
+ x11-libs/libXdmcp[abi_x86_32(-)]"
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+QA_PREBUILT="${dir:1}/maj_demo"
+
+src_install() {
+ dodoc README*
+ insinto "${dir}"
+ exeinto "${dir}"
+ doins -r data quests
+ doins majesty.{bmp,xpm} majestysite.url
+ newicon majesty.xpm majesty-demo.xpm
+ # only installing the static version for now
+ if use x86 || use amd64; then
+ doexe bin/Linux/x86/maj_demo
+ fi
+ games_make_wrapper maj_demo ./maj_demo "${dir}" "${dir}"
+ prepgamesdirs
+ make_desktop_entry maj_demo "Majesty (Demo)"
+}
diff --git a/games-strategy/majesty-demo/metadata.xml b/games-strategy/majesty-demo/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-strategy/majesty-demo/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>