summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOursDesCavernes <totocoq@yahoo.fr>2018-03-19 00:40:19 +0100
committerJames Le Cuirot <chewi@gentoo.org>2018-03-26 22:25:00 +0100
commit88b69511505b96a18155ff7652ab5f22f6380167 (patch)
treef589790385bb4faa50f914d293857515f21cd1ab /games-strategy/maxr
parentsys-auth/fingerprint-gui: bump to 1.09 with Qt5 (diff)
downloadgentoo-88b69511505b96a18155ff7652ab5f22f6380167.tar.gz
gentoo-88b69511505b96a18155ff7652ab5f22f6380167.tar.bz2
gentoo-88b69511505b96a18155ff7652ab5f22f6380167.zip
games-strategy/maxr: Bump verion 0.2.9
Closes: https://bugs.gentoo.org/614498 Closes: https://bugs.gentoo.org/599386 Package-Manager: Portage-2.3.24, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/7502
Diffstat (limited to 'games-strategy/maxr')
-rw-r--r--games-strategy/maxr/Manifest1
-rw-r--r--games-strategy/maxr/maxr-0.2.9.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/games-strategy/maxr/Manifest b/games-strategy/maxr/Manifest
index 4c8ff43408e3..19b5872fa688 100644
--- a/games-strategy/maxr/Manifest
+++ b/games-strategy/maxr/Manifest
@@ -1 +1,2 @@
DIST maxr-0.2.8.tar.gz 14738324 BLAKE2B 1e0e224cf823e3f9632a28124e9a78c46d6d417894c2df8137a3876b0143c35fb5cf63d2668f947da3e65d3317863fa686c3c7b28a31f38d8bd39ae7739124fb SHA512 22fec9ca773ea68f2639f3cb034ed271a926f99b9b17547bbbdf12a3b47ee445ab311b0766b0656c71b88a258165590431e189e695ef1a86e0fb3b799d1eaa80
+DIST maxr-0.2.9.tar.gz 14847180 BLAKE2B eac99b06f84a2559a6ba601396a43b98014ccea2339bd5f7b8327d000d5a5ddf032c2a1fd1c0bec9e3be16e95e170acf93bc99438400d92eb637c2fa68ebcfed SHA512 8c92d85edf152b1730a8b9e1047d41687cfac816ea854e1ec0b5068a650d399cd3cfc4c47593a2eb83604fd649a05ba649763251104fd70d49bb1cb33d4f58fc
diff --git a/games-strategy/maxr/maxr-0.2.9.ebuild b/games-strategy/maxr/maxr-0.2.9.ebuild
new file mode 100644
index 000000000000..1835decca361
--- /dev/null
+++ b/games-strategy/maxr/maxr-0.2.9.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils desktop
+
+DESCRIPTION="Mechanized Assault and Exploration Reloaded"
+HOMEPAGE="http://www.maxr.org/"
+SRC_URI="http://www.maxr.org/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2 FDL-1.2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dedicated"
+
+RDEPEND="media-libs/libsdl2[video]
+ media-libs/sdl2-mixer[vorbis]
+ media-libs/sdl2-net"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ -DMAXR_BUILD_DEDICATED_SERVER="$(usex dedicated)"
+ "-DCMAKE_BUILD_TYPE=Release")
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ doicon data/maxr.png
+ make_desktop_entry maxr "Mechanized Assault and Exploration Reloaded"
+ cmake-utils_src_install
+}