summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-strategy/naev
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-strategy/naev')
-rw-r--r--games-strategy/naev/Manifest2
-rw-r--r--games-strategy/naev/metadata.xml14
-rw-r--r--games-strategy/naev/naev-0.6.0.ebuild81
3 files changed, 97 insertions, 0 deletions
diff --git a/games-strategy/naev/Manifest b/games-strategy/naev/Manifest
new file mode 100644
index 000000000000..4ec87502aa55
--- /dev/null
+++ b/games-strategy/naev/Manifest
@@ -0,0 +1,2 @@
+DIST naev-0.6.0.tar.bz2 1054649 SHA256 0f0b498c7642e36dfaa15f284e13b9aa2d20e4aa01ed812fb7854583e7161cac SHA512 263c404a9ec4d4dafdf2ea9afc1ea58679792916b9143b7646918210b9f5f4656fe315e0b83c7983646206d03329b3314430acc8a5cbea3da830d183702cde4b WHIRLPOOL 53a425ddd13b791c1b3469e6ed16a897609391e821056dc55e8b7484d5c394fee6956fe5c6e8be503c8bd1c6f382ad103200a2acefbfe5c17035851b3d0e1778
+DIST ndata-0.6.0.zip 302646395 SHA256 07ccb9f50652bceb8064fa1e48cd9df2b4ce0e3c52b60f27398cdfc3186ac52b SHA512 dc55a49132543477ad42d17224ceacc146b68ebc1f37e4325b1ffe61c64571ec47e012194103f59d664b64eb021c19741e184aca00d800d39efcdc3646146974 WHIRLPOOL 7a002a3de45bb121afad52e75c08e1a15a16ca5613ed3190f73335de93862389aa6376b0601744c756bfe76e77be048d877a9200c2046f4868e390ce5973e2b4
diff --git a/games-strategy/naev/metadata.xml b/games-strategy/naev/metadata.xml
new file mode 100644
index 000000000000..da0a81aa42b8
--- /dev/null
+++ b/games-strategy/naev/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <use>
+ <flag name="mixer">
+ Enables <pkg>media-libs/sdl-mixer</pkg> sound backend in addition to
+ <pkg>media-libs/openal</pkg> one.
+ </flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">naev</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-strategy/naev/naev-0.6.0.ebuild b/games-strategy/naev/naev-0.6.0.ebuild
new file mode 100644
index 000000000000..ee69405728f4
--- /dev/null
+++ b/games-strategy/naev/naev-0.6.0.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit flag-o-matic gnome2-utils games
+
+DESCRIPTION="A 2D space trading and combat game, in a similar vein to Escape Velocity"
+HOMEPAGE="http://blog.naev.org/"
+SRC_URI="mirror://sourceforge/naev/${P}.tar.bz2
+ mirror://sourceforge/naev/ndata-${PV}.zip"
+
+LICENSE="GPL-2 GPL-3 public-domain CC-BY-3.0 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug +mixer +openal"
+
+RDEPEND="media-libs/libsdl2[X,sound,video]
+ dev-libs/libzip
+ dev-libs/libxml2
+ >=media-libs/freetype-2
+ >=media-libs/libvorbis-1.2.1
+ >=media-libs/libpng-1.2:0
+ virtual/glu
+ virtual/opengl
+ dev-lang/lua:0
+ mixer? ( media-libs/sdl2-mixer )
+ openal? ( media-libs/openal )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+}
+
+src_configure() {
+ egamesconf \
+ --docdir=/usr/share/doc/${PF} \
+ --enable-lua=shared \
+ $(use_enable debug) \
+ $(use_with openal) \
+ $(use_with mixer sdlmixer)
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ appicondir=/usr/share/pixmaps \
+ Graphicsdir=/usr/share/applications \
+ install
+
+ insinto "${GAMES_DATADIR}"/${PN}
+ newins "${DISTDIR}"/ndata-${PV}.zip ndata
+
+ local res
+ for res in 16 32 64 128; do
+ newicon -s ${res} extras/logos/logo${res}.png naev.png
+ done
+
+ rm -f "${D}"/usr/share/doc/${PF}/LICENSE
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}