summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-strategy/smac
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-strategy/smac')
-rw-r--r--games-strategy/smac/Manifest2
-rw-r--r--games-strategy/smac/metadata.xml5
-rw-r--r--games-strategy/smac/smac-6.0a.ebuild103
3 files changed, 110 insertions, 0 deletions
diff --git a/games-strategy/smac/Manifest b/games-strategy/smac/Manifest
new file mode 100644
index 000000000000..1f98b7e20bf0
--- /dev/null
+++ b/games-strategy/smac/Manifest
@@ -0,0 +1,2 @@
+DIST smac-6.0a-x86.run 6801730 SHA256 69b845728f55caef038c6392f148beae47156933f5bff0ce7d9c49162f1d0ee7 SHA512 b71dd1ee46d37d66131cf6fc15c6a406719989021c8dbb6e74cded18c5520ee9ba4bbdfc5bdfc0ddfa67fa2e846365636be41d87a6440473e8ae5ebf542b7744 WHIRLPOOL 24ac3d1f79a38407b0d21287055a0ab37888ce06f424e95a4be98a78ddd003301b6a00d8ba967da802a78ae025a4f4f00ad7565745fc679997b88bca9b46aa8f
+DIST smac-install-ppc.run 18528928 SHA256 ad90f6fa4fa3bfe39f5474016ea6a0c738687fc038995bcd7675294c0438477c SHA512 99fc6edca2c9e64bfc0cab644cbd061c3842359c16e5e6537a2aa2df4cd2a1a6a39169a2b9540199b08f7aee28f4e2cfad814499fdd55b5edf7ab9b19c12d793 WHIRLPOOL df1068532845e5c7be68cf84122a7b90ba3fcd5e89442cff76143eccb35012861980a0cb4bc79948f73b0e2821aa3a8e0673cc2bde7065a2f4d4e895ba4a0ab1
diff --git a/games-strategy/smac/metadata.xml b/games-strategy/smac/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-strategy/smac/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-strategy/smac/smac-6.0a.ebuild b/games-strategy/smac/smac-6.0a.ebuild
new file mode 100644
index 000000000000..189d90180867
--- /dev/null
+++ b/games-strategy/smac/smac-6.0a.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils unpacker cdrom games
+
+DESCRIPTION="Linux port of the popular strategy game from Firaxis"
+HOMEPAGE="http://www.lokigames.com/products/smac/"
+SRC_URI="x86? ( mirror://lokigames/${PN}/${P}-x86.run )
+ amd64? ( mirror://lokigames/${PN}/${P}-x86.run )
+ ppc? ( http://mirrors.dotsrc.org/lokigames/installers/${PN}/${PN}-install-ppc.run )"
+
+LICENSE="LOKI-EULA"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+videos"
+RESTRICT="strip"
+
+DEPEND="games-util/loki_patch"
+RDEPEND="sys-libs/glibc
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ !ppc? ( sys-libs/lib-compat-loki )
+ media-libs/libsdl[sound,video]
+ media-libs/sdl-ttf
+ media-libs/sdl-mixer
+ media-libs/smpeg
+ media-libs/freetype
+ sys-libs/zlib"
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+
+src_unpack() {
+ cdrom_get_cds Alien_Crossfire_Manual.pdf
+ mkdir -p "${S}"/a
+ cd "${S}"/a
+ use x86 || use amd64 && unpack_makeself ${P}-x86.run
+ use ppc && unpack_makeself ${PN}-install-ppc.run
+}
+
+src_install() {
+ einfo "Copying files... this may take a while..."
+ exeinto "${dir}"
+ doexe "${CDROM_ROOT}"/bin/x86/{smac,smacx,smacpack}
+
+ insinto "${dir}"
+ doins ${CDROM_ROOT}/{{Alien_Crossfire,Alpha_Centauri}_Manual.pdf,QuickStart.txt,README,icon.{bmp,xpm}}
+
+ cd "${Ddir}"
+ tar xzf "${CDROM_ROOT}"/data.tar.gz || die
+ insinto "${dir}"/data
+ doins "${CDROM_ROOT}"/data/*.{pcx,cvr,flc,gif}
+ doins -r "${CDROM_ROOT}"/data/{facs,fx,projs,techs,voices}
+
+ if use videos ; then
+ doins -r "${CDROM_ROOT}"/data/movies
+ fi
+
+ cd "${S}"/a
+ if use ppc ; then
+ cd ${P}-ppc
+ fi
+ loki_patch --verify patch.dat
+ loki_patch patch.dat "${Ddir}" >& /dev/null || die
+
+ # now, since these files are coming off a cd, the times/sizes/md5sums wont
+ # be different ... that means portage will try to unmerge some files (!)
+ # we run touch on ${D} so as to make sure portage doesnt do any such thing
+ find "${Ddir}" -exec touch '{}' +
+
+ newicon "${CDROM_ROOT}"/icon.xpm smac.xpm
+
+ games_make_wrapper ${PN}pack ./${PN}pack "${dir}" "${dir}"
+ games_make_wrapper ${PN} ./${PN} "${dir}" "${dir}"
+ games_make_wrapper ${PN}x ./${PN}x "${dir}" "${dir}"
+ make_desktop_entry smacpack "Sid Meier's SMAC Planetary Pack" smacpack
+ make_desktop_entry smac "Sid Meier's Alpha Centauri" smac
+ make_desktop_entry smacx "Sid Meier's Alpha Centauri - Alien Crossfire" smac
+ prepgamesdirs
+
+ if use x86 || use amd64 ; then
+ einfo "Linking libs provided by 'sys-libs/lib-compat-loki' to '${dir}'."
+ dosym /lib/loki_ld-linux.so.2 "${dir}"/ld-linux.so.2 && \
+ dosym /usr/lib/loki_libc.so.6 "${dir}"/libc.so.6 && \
+ dosym /usr/lib/loki_libnss_files.so.2 "${dir}"/libnss_files.so.2
+ fi
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "To start Sid Meyer's SMAC Planetary Pack run:"
+ elog " smac"
+ elog "To play Sid Meyer's Alpha Centauri run:"
+ elog " smac"
+ elog "To play Alien Crossfire run:"
+ elog " smacx"
+ elog "Be sure to enable CONFIG_UID16 in your kernel config or"
+ elog "the game will error." # bug 340303
+}