summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-strategy/triplea/triplea-1.8.0.5.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-strategy/triplea/triplea-1.8.0.5.ebuild')
-rw-r--r--games-strategy/triplea/triplea-1.8.0.5.ebuild92
1 files changed, 92 insertions, 0 deletions
diff --git a/games-strategy/triplea/triplea-1.8.0.5.ebuild b/games-strategy/triplea/triplea-1.8.0.5.ebuild
new file mode 100644
index 000000000000..fd9662b393dc
--- /dev/null
+++ b/games-strategy/triplea/triplea-1.8.0.5.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils java-pkg-2 java-ant-2 versionator games
+
+MY_PV=$(replace_all_version_separators _)
+DESCRIPTION="An open source clone of the popular Axis and Allies boardgame"
+HOMEPAGE="http://triplea.sourceforge.net/"
+SRC_URI="mirror://sourceforge/triplea/${PN}_${MY_PV}_source_code_only.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+RESTRICT="test" # Needs X11 maybe use virtualx.eclass
+
+RDEPEND="dev-java/commons-httpclient:3
+ dev-java/apple-java-extensions-bin
+ dev-java/commons-logging
+ dev-java/commons-codec
+ =dev-java/junit-3.8*"
+DEPEND="${RDEPEND}
+ >=virtual/jdk-1.6
+ app-arch/unzip"
+RDEPEND="${RDEPEND}
+ >=virtual/jre-1.6"
+
+S=${WORKDIR}/${PN}_${MY_PV}
+
+pkg_setup() {
+ games_pkg_setup
+ java-pkg-2_pkg_setup
+}
+
+src_prepare() {
+ sed -i \
+ -e '/userHome.*triplea/s:"triplea":".triplea":g' \
+ src/games/strategy/engine/framework/GameRunner2.java || die
+
+ rm -r old/ lib/derby*.jar || die
+ java-pkg_jar-from apple-java-extensions-bin AppleJavaExtensions.jar \
+ lib/AppleJavaExtensions.jar
+ java-pkg_jar-from commons-httpclient-3 commons-httpclient.jar \
+ lib/commons-httpclient-3.0.1.jar
+ java-pkg_jar-from commons-logging commons-logging.jar \
+ lib/commons-logging-1.1.jar
+ java-pkg_jar-from commons-codec commons-codec.jar \
+ lib/commons-codec-1.3.jar
+ # installs the test files
+ java-pkg_jar-from --into lib junit
+
+ # lots of other jars from some other java packages...
+ # either missing from portage or none stable is ages.
+ #java-pkg_ensure-no-bundled-jars
+}
+
+src_compile() {
+ eant || die
+ echo "triplea.saveGamesInHomeDir=true" > data/triplea.properties
+ # The only target creating this is zip which does unjar etc
+ cd classes || die
+ jar cf ../bin/triplea.jar * || die
+ rm -r * || die
+}
+
+src_test() {
+ ANT_TASKS="ant-junit" eant test
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r assets bin data dice_servers maps
+
+ java-pkg_regjar "${D}/${GAMES_DATADIR}"/${PN}/bin/*.jar
+ java-pkg_dolauncher ${PN} -into "${GAMES_PREFIX}" \
+ --java_args "-Xmx256m" --main \
+ games.strategy.engine.framework.GameRunner
+ java-pkg_dolauncher ${PN}-server -into "${GAMES_PREFIX}" \
+ --java_args "-server -Xmx64m -Dtriplea.lobby.port=3303 -Dtriplea.lobby.console=true" \
+ --main games.strategy.engine.lobby.server.LobbyServer
+
+ newicon icons/triplea_icon.png ${PN}.png
+ newicon icons/triplea_icon.png ${PN}-server.png
+ make_desktop_entry ${PN} TripleA
+ make_desktop_entry ${PN}-server TripleA-server
+
+ dodoc changelog.txt TripleA_RuleBook.pdf
+ dohtml -r doc/* readme.html
+ prepgamesdirs
+}