summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-strategy/wargus-data
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-strategy/wargus-data')
-rw-r--r--games-strategy/wargus-data/metadata.xml5
-rw-r--r--games-strategy/wargus-data/wargus-data-0.ebuild45
2 files changed, 50 insertions, 0 deletions
diff --git a/games-strategy/wargus-data/metadata.xml b/games-strategy/wargus-data/metadata.xml
new file mode 100644
index 000000000000..cad5a2aa1773
--- /dev/null
+++ b/games-strategy/wargus-data/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+</pkgmetadata>
diff --git a/games-strategy/wargus-data/wargus-data-0.ebuild b/games-strategy/wargus-data/wargus-data-0.ebuild
new file mode 100644
index 000000000000..cc06c763c9f3
--- /dev/null
+++ b/games-strategy/wargus-data/wargus-data-0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit cdrom games
+
+DESCRIPTION="Warcraft II data for wargus (needs DOS CD)"
+HOMEPAGE="http://wargus.sourceforge.net/"
+SRC_URI=""
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="${RDEPEND}
+ media-sound/cdparanoia
+ media-sound/timidity++
+ media-video/ffmpeg2theora"
+# wrt bug #419331
+RESTRICT="userpriv"
+
+S=${WORKDIR}
+
+src_prepare() {
+ export CDROM_NAME="WARCRAFT2"
+ cdrom_get_cds data/rezdat.war
+}
+
+src_compile() {
+ # cdparanoia needs write acces to the cdrom device
+ # this fixes sandbox violation wrt #418051
+ local save_sandbox_write=${SANDBOX_WRITE}
+ addwrite /dev
+ "${GAMES_BINDIR}"/wartool -m -v -r "${CDROM_ROOT}"/data "${S}"/ || die
+ SANDBOX_WRITE=${save_sandbox_write}
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}"/stratagus/wargus
+ doins -r *
+ prepgamesdirs
+}