summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-strategy/wargus
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-strategy/wargus')
-rw-r--r--games-strategy/wargus/Manifest1
-rw-r--r--games-strategy/wargus/metadata.xml8
-rw-r--r--games-strategy/wargus/wargus-2.2.7.ebuild62
3 files changed, 71 insertions, 0 deletions
diff --git a/games-strategy/wargus/Manifest b/games-strategy/wargus/Manifest
new file mode 100644
index 000000000000..9c0175c5700a
--- /dev/null
+++ b/games-strategy/wargus/Manifest
@@ -0,0 +1 @@
+DIST wargus_2.2.7.orig.tar.gz 3655476 SHA256 f688663458e035725f5cd18535a7a1eaecd66eaf55b032fe2ac21ed48b239908 SHA512 a419e70c53db6f3919255ef98ea717a0802e0854095b019bd9c6eef66d6602f75c1849a53ef654b5d66191a824725e3eff23f1f01767eab861e6ddfaf2414bbb WHIRLPOOL d440ac1f279912b13f37fd618f31b1bb2ac53f143789dbe56835343e9486a6ec2aeca71874c4ae2bd9c707706cdf33efbec8df8993d102b0276da0aa53e04cc3
diff --git a/games-strategy/wargus/metadata.xml b/games-strategy/wargus/metadata.xml
new file mode 100644
index 000000000000..5218dcb6ae62
--- /dev/null
+++ b/games-strategy/wargus/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="launchpad">wargus</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-strategy/wargus/wargus-2.2.7.ebuild b/games-strategy/wargus/wargus-2.2.7.ebuild
new file mode 100644
index 000000000000..440d4d438705
--- /dev/null
+++ b/games-strategy/wargus/wargus-2.2.7.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils cmake-utils gnome2-utils games
+
+DESCRIPTION="Warcraft II for the Stratagus game engine"
+HOMEPAGE="http://wargus.sourceforge.net/"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="=games-engines/stratagus-${PV}*[theora]
+ media-libs/freetype
+ media-libs/libpng:0
+ sys-libs/zlib
+ x11-libs/gtk+:2
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+PDEPEND="games-strategy/wargus-data"
+
+S=${WORKDIR}/${PN}_${PV}.orig
+
+src_configure() {
+ local mycmakeargs=(
+ -DGAMEDIR="${GAMES_BINDIR}"
+ -DBINDIR="${GAMES_BINDIR}"
+ -DSTRATAGUS="${GAMES_BINDIR}"/stratagus
+ -DICONDIR=/usr/share/icons/hicolor/64x64/apps
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ elog "Enabling OpenGL in-game seems to cause segfaults/crashes."
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}