summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-strategy/wesnoth/wesnoth-1.12.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-strategy/wesnoth/wesnoth-1.12.2.ebuild')
-rw-r--r--games-strategy/wesnoth/wesnoth-1.12.2.ebuild118
1 files changed, 118 insertions, 0 deletions
diff --git a/games-strategy/wesnoth/wesnoth-1.12.2.ebuild b/games-strategy/wesnoth/wesnoth-1.12.2.ebuild
new file mode 100644
index 000000000000..1c325fd2591c
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-1.12.2.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils eutils multilib toolchain-funcs flag-o-matic games
+
+DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org/"
+SRC_URI="mirror://sourceforge/wesnoth/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86 ~x86-fbsd"
+IUSE="dbus dedicated doc fribidi nls server"
+
+RDEPEND=">=media-libs/libsdl-1.2.7:0[joystick,video,X]
+ media-libs/sdl-net
+ !dedicated? (
+ >=media-libs/sdl-ttf-2.0.8
+ >=media-libs/sdl-mixer-1.2[vorbis]
+ >=media-libs/sdl-image-1.2[jpeg,png]
+ fribidi? ( dev-libs/fribidi )
+ dbus? ( sys-apps/dbus )
+ sys-libs/zlib
+ x11-libs/pango
+ dev-lang/lua:0
+ media-libs/fontconfig
+ )
+ >=dev-libs/boost-1.48[nls,threads]
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+src_prepare() {
+ if use dedicated || use server ; then
+ sed \
+ -e "s:GAMES_BINDIR:${GAMES_BINDIR}:" \
+ -e "s:GAMES_STATEDIR:${GAMES_STATEDIR}:" \
+ -e "s/GAMES_USER_DED/${GAMES_USER_DED}/" \
+ -e "s/GAMES_GROUP/${GAMES_GROUP}/" "${FILESDIR}"/wesnothd.rc \
+ > "${T}"/wesnothd || die
+ fi
+ if ! use doc ; then
+ sed -i \
+ -e '/manual/d' \
+ doc/CMakeLists.txt || die
+ fi
+ # bug #472994
+ mv icons/wesnoth-icon-Mac.png icons/wesnoth-icon.png || die
+ mv icons/map-editor-icon-Mac.png icons/wesnoth_editor-icon.png || die
+
+ # respect LINGUAS (bug #483316)
+ if [[ ${LINGUAS+set} ]] ; then
+ local langs
+ for lang in $(cat po/LINGUAS)
+ do
+ has $lang $LINGUAS && langs+="$lang "
+ done
+ echo "$langs" > po/LINGUAS || die
+ fi
+}
+
+src_configure() {
+ filter-flags -ftracer -fomit-frame-pointer
+ if [[ $(gcc-major-version) -eq 3 ]] ; then
+ filter-flags -fstack-protector
+ append-flags -fno-stack-protector
+ fi
+ # Work around eclass
+ append-flags -UNDEBUG
+ if use dedicated || use server ; then
+ mycmakeargs=(
+ "-DENABLE_CAMPAIGN_SERVER=TRUE"
+ "-DENABLE_SERVER=TRUE"
+ "-DSERVER_UID=${GAMES_USER_DED}"
+ "-DSERVER_GID=${GAMES_GROUP}"
+ "-DFIFO_DIR=${GAMES_STATEDIR}/run/wesnothd"
+ )
+ else
+ mycmakeargs=(
+ $(cmake-utils_use_enable fribidi FRIBIDI)
+ "-DENABLE_CAMPAIGN_SERVER=FALSE"
+ "-DENABLE_SERVER=FALSE"
+ )
+ fi
+ mycmakeargs+=(
+ $(cmake-utils_use_enable !dedicated GAME)
+ $(cmake-utils_use_enable !dedicated ENABLE_DESKTOP_ENTRY)
+ $(cmake-utils_use_enable nls NLS)
+ $(cmake-utils_use_enable dbus NOTIFICATIONS)
+ "-DCMAKE_VERBOSE_MAKEFILE=TRUE"
+ "-DENABLE_STRICT_COMPILATION=FALSE"
+ "-DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX}"
+ "-DDATAROOTDIR=${GAMES_DATADIR}"
+ "-DBINDIR=${GAMES_BINDIR}"
+ "-DICONDIR=/usr/share/pixmaps"
+ "-DDESKTOPDIR=/usr/share/applications"
+ "-DLOCALEDIR=/usr/share/locale"
+ "-DMANDIR=/usr/share/man"
+ "-DDOCDIR=/usr/share/doc/${PF}"
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ DOCS="README changelog players_changelog" cmake-utils_src_install
+ if use dedicated || use server; then
+ keepdir "${GAMES_STATEDIR}/run/wesnothd"
+ doinitd "${T}"/wesnothd || die
+ fi
+ prepgamesdirs
+}