summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatija Skala <mskala@gmx.com>2018-05-17 08:02:28 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-05-31 13:15:29 +0200
commit4e4ea8746ff0c79b77dc4326dcd67db3db7eed64 (patch)
treee1ec5bbbf33c0155d349b9e517b2b858782f0663 /games-strategy/wesnoth
parentapp-emulation/reg: Initial version (diff)
downloadgentoo-4e4ea8746ff0c79b77dc4326dcd67db3db7eed64.tar.gz
gentoo-4e4ea8746ff0c79b77dc4326dcd67db3db7eed64.tar.bz2
gentoo-4e4ea8746ff0c79b77dc4326dcd67db3db7eed64.zip
games-strategy/wesnoth: new wesnothd.rc file for 1.14
Bug: https://bugs.gentoo.org/654440 Closes: https://github.com/gentoo/gentoo/pull/8440
Diffstat (limited to 'games-strategy/wesnoth')
-rw-r--r--games-strategy/wesnoth/files/wesnothd.rc-r123
-rw-r--r--games-strategy/wesnoth/wesnoth-1.14.1-r1.ebuild (renamed from games-strategy/wesnoth/wesnoth-1.14.1.ebuild)4
2 files changed, 25 insertions, 2 deletions
diff --git a/games-strategy/wesnoth/files/wesnothd.rc-r1 b/games-strategy/wesnoth/files/wesnothd.rc-r1
new file mode 100644
index 000000000000..c1a0d9d20167
--- /dev/null
+++ b/games-strategy/wesnoth/files/wesnothd.rc-r1
@@ -0,0 +1,23 @@
+#!/sbin/openrc-run
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ use net
+}
+
+start() {
+ checkpath -q -d -m 0750 -o wesnoth:wesnoth /run/wesnothd
+ ebegin "Starting wesnothd"
+ start-stop-daemon --start --quiet -b -m \
+ --pidfile /run/wesnothd/wesnothd.pid \
+ -c wesnoth:wesnoth \
+ --exec /usr/bin/wesnothd
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping wesnothd"
+ start-stop-daemon --stop --quiet --pidfile /run/wesnothd/wesnothd.pid
+ eend $?
+}
diff --git a/games-strategy/wesnoth/wesnoth-1.14.1.ebuild b/games-strategy/wesnoth/wesnoth-1.14.1-r1.ebuild
index 7372ade39d66..5a1f6c5af2e9 100644
--- a/games-strategy/wesnoth/wesnoth-1.14.1.ebuild
+++ b/games-strategy/wesnoth/wesnoth-1.14.1-r1.ebuild
@@ -108,7 +108,7 @@ src_configure() {
src_install() {
DOCS="README.md changelog.md players_changelog.md" cmake-utils_src_install
if use dedicated || use server; then
- keepdir "/run/wesnothd"
- newinitd "${FILESDIR}"/wesnothd.rc wesnothd
+ rmdir "${ED%/}/run/wesnothd" || die
+ newinitd "${FILESDIR}"/wesnothd.rc-r1 wesnothd
fi
}