summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-12 02:37:05 +0100
committerSam James <sam@gentoo.org>2021-04-12 03:30:44 +0100
commit0ddf4150c7ac9d37f014a3521e12bf7f9f6494d6 (patch)
tree24a7b15d032c73cc13c6a17b4c3ac7fdb2e702a0 /games-strategy
parentgames-sports/trigger: eutils->desktop (diff)
downloadgentoo-0ddf4150c7ac9d37f014a3521e12bf7f9f6494d6.tar.gz
gentoo-0ddf4150c7ac9d37f014a3521e12bf7f9f6494d6.tar.bz2
gentoo-0ddf4150c7ac9d37f014a3521e12bf7f9f6494d6.zip
games-strategy/spaz: eutils->wrapper
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/spaz/spaz-1.605-r1.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/games-strategy/spaz/spaz-1.605-r1.ebuild b/games-strategy/spaz/spaz-1.605-r1.ebuild
index 98f1843747b1..3f312216a859 100644
--- a/games-strategy/spaz/spaz-1.605-r1.ebuild
+++ b/games-strategy/spaz/spaz-1.605-r1.ebuild
@@ -1,26 +1,26 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit desktop eutils unpacker
+
+inherit desktop unpacker wrapper
DESCRIPTION="Space Pirates and Zombies"
HOMEPAGE="http://minmax-games.com/SpacePiratesAndZombies/"
SRC_URI="${PN}-linux-humblebundle-09182012-bin"
+S="${WORKDIR}"/data
+
LICENSE="LOKI-EULA"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
IUSE="alsa pulseaudio"
RESTRICT="bindist fetch strip"
-DEPEND=""
-BDEPEND="app-arch/unzip"
RDEPEND="
>=media-libs/openal-1.15.1[alsa?,pulseaudio?,abi_x86_32(-)]
>=media-libs/libsdl-1.2.15-r4[abi_x86_32(-)]
"
-
-S="${WORKDIR}"/data
+BDEPEND="app-arch/unzip"
QA_PREBUILT="opt/spaz/SPAZ"
@@ -29,10 +29,10 @@ src_unpack() {
}
src_install() {
- local dir="/opt/${PN}"
+ local dir=/opt/${PN}
- insinto "${dir}"
- exeinto "${dir}"
+ insinto ${dir}
+ exeinto ${dir}
doexe SPAZ
doins -r common game mods
doins audio.so