summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2016-05-17 23:37:36 -0400
committerMichael Sterrett <mr_bones_@gentoo.org>2016-05-17 23:37:36 -0400
commit49bbbd5f445c6e1174b79b071abd989b77e15e91 (patch)
treea3a592481c34919996a6a3ad8c3f76fe42ffca77 /games-strategy
parentwww-plugins/chrome-binary-plugins: automated update (diff)
downloadgentoo-49bbbd5f445c6e1174b79b071abd989b77e15e91.tar.gz
gentoo-49bbbd5f445c6e1174b79b071abd989b77e15e91.tar.bz2
gentoo-49bbbd5f445c6e1174b79b071abd989b77e15e91.zip
games-strategy/wesnoth: version bump
Package-Manager: portage-2.2.28
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wesnoth/Manifest1
-rw-r--r--games-strategy/wesnoth/wesnoth-1.12.6.ebuild118
2 files changed, 119 insertions, 0 deletions
diff --git a/games-strategy/wesnoth/Manifest b/games-strategy/wesnoth/Manifest
index 2c2c5b310ef7..21296afdedd7 100644
--- a/games-strategy/wesnoth/Manifest
+++ b/games-strategy/wesnoth/Manifest
@@ -1 +1,2 @@
DIST wesnoth-1.12.5.tar.bz2 387726941 SHA256 599aad40da4b271c5138ac5a4391d9ff9c367ee51f5c30ca138f6baf92aea81d SHA512 1a785c02389cd4bdc79b61f62c5bb98f01fde61c3923527195a5a8e8f8986349fcda3d40a4fb14248626ea8e79eba12b8232e39cce08bfea7fbdf3d9627d53b4 WHIRLPOOL 7afbbf28de36ce3a55a177bc5b6de7f635c4e18de5934378fce6ea6a1da7ab95c55ff6c35b4a3166927efc17138fb18ef600e08969b29001455e21a260c8f6b6
+DIST wesnoth-1.12.6.tar.bz2 387869758 SHA256 a50f384cead15f68f31cfa1a311e76a12098428702cb674d3521eb169eb92e4e SHA512 12ca3b5de8fd385b05cc8e76604f7aed68127a7542599d6e97cce793e10636e00bd65dcb088701e20ccc7191f41b1d67a00b291f885df880fac00d13d6fbde7a WHIRLPOOL a1ca73e86ab66cb263e288f12d005210b1b9275012a9de470f1d60a1fa8b80d81d834c9bb9002920b8a6c94b13a413f451a5703d377bd8fbadfe455a41967221
diff --git a/games-strategy/wesnoth/wesnoth-1.12.6.ebuild b/games-strategy/wesnoth/wesnoth-1.12.6.ebuild
new file mode 100644
index 000000000000..7a71ad632c91
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-1.12.6.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils eutils multilib toolchain-funcs flag-o-matic games
+
+DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org/"
+SRC_URI="mirror://sourceforge/wesnoth/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="dbus dedicated doc fribidi nls server"
+
+RDEPEND=">=media-libs/libsdl-1.2.7:0[joystick,video,X]
+ media-libs/sdl-net
+ !dedicated? (
+ >=media-libs/sdl-ttf-2.0.8
+ >=media-libs/sdl-mixer-1.2[vorbis]
+ >=media-libs/sdl-image-1.2[jpeg,png]
+ fribidi? ( dev-libs/fribidi )
+ dbus? ( sys-apps/dbus )
+ sys-libs/zlib
+ x11-libs/pango
+ dev-lang/lua:0
+ media-libs/fontconfig
+ )
+ >=dev-libs/boost-1.48:=[nls,threads]
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+src_prepare() {
+ if use dedicated || use server ; then
+ sed \
+ -e "s:GAMES_BINDIR:${GAMES_BINDIR}:" \
+ -e "s:GAMES_STATEDIR:${GAMES_STATEDIR}:" \
+ -e "s/GAMES_USER_DED/${GAMES_USER_DED}/" \
+ -e "s/GAMES_GROUP/${GAMES_GROUP}/" "${FILESDIR}"/wesnothd.rc \
+ > "${T}"/wesnothd || die
+ fi
+ if ! use doc ; then
+ sed -i \
+ -e '/manual/d' \
+ doc/CMakeLists.txt || die
+ fi
+ # bug #472994
+ mv icons/wesnoth-icon-Mac.png icons/wesnoth-icon.png || die
+ mv icons/map-editor-icon-Mac.png icons/wesnoth_editor-icon.png || die
+
+ # respect LINGUAS (bug #483316)
+ if [[ ${LINGUAS+set} ]] ; then
+ local langs
+ for lang in $(cat po/LINGUAS)
+ do
+ has $lang $LINGUAS && langs+="$lang "
+ done
+ echo "$langs" > po/LINGUAS || die
+ fi
+}
+
+src_configure() {
+ filter-flags -ftracer -fomit-frame-pointer
+ if [[ $(gcc-major-version) -eq 3 ]] ; then
+ filter-flags -fstack-protector
+ append-flags -fno-stack-protector
+ fi
+ # Work around eclass
+ append-flags -UNDEBUG
+ if use dedicated || use server ; then
+ mycmakeargs=(
+ "-DENABLE_CAMPAIGN_SERVER=TRUE"
+ "-DENABLE_SERVER=TRUE"
+ "-DSERVER_UID=${GAMES_USER_DED}"
+ "-DSERVER_GID=${GAMES_GROUP}"
+ "-DFIFO_DIR=${GAMES_STATEDIR}/run/wesnothd"
+ )
+ else
+ mycmakeargs=(
+ $(cmake-utils_use_enable fribidi FRIBIDI)
+ "-DENABLE_CAMPAIGN_SERVER=FALSE"
+ "-DENABLE_SERVER=FALSE"
+ )
+ fi
+ mycmakeargs+=(
+ $(cmake-utils_use_enable !dedicated GAME)
+ $(cmake-utils_use_enable !dedicated ENABLE_DESKTOP_ENTRY)
+ $(cmake-utils_use_enable nls NLS)
+ $(cmake-utils_use_enable dbus NOTIFICATIONS)
+ "-DCMAKE_VERBOSE_MAKEFILE=TRUE"
+ "-DENABLE_STRICT_COMPILATION=FALSE"
+ "-DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX}"
+ "-DDATAROOTDIR=${GAMES_DATADIR}"
+ "-DBINDIR=${GAMES_BINDIR}"
+ "-DICONDIR=/usr/share/pixmaps"
+ "-DDESKTOPDIR=/usr/share/applications"
+ "-DLOCALEDIR=/usr/share/locale"
+ "-DMANDIR=/usr/share/man"
+ "-DDOCDIR=/usr/share/doc/${PF}"
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ DOCS="README.md changelog players_changelog" cmake-utils_src_install
+ if use dedicated || use server; then
+ keepdir "${GAMES_STATEDIR}/run/wesnothd"
+ doinitd "${T}"/wesnothd
+ fi
+ prepgamesdirs
+}