summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-06-05 18:45:29 +0100
committerMarek Szuba <marecki@gentoo.org>2021-06-05 18:48:06 +0100
commit520793f9e323a38d14456e058d69c539735e2f9d (patch)
treee40d56fb0e43eb1d15585d48c543ba3437b2c1c6 /games-strategy
parentnet-misc/netopeer2: Bump to 1.1.76 (diff)
downloadgentoo-520793f9e323a38d14456e058d69c539735e2f9d.tar.gz
gentoo-520793f9e323a38d14456e058d69c539735e2f9d.tar.bz2
gentoo-520793f9e323a38d14456e058d69c539735e2f9d.zip
games-strategy/freeciv: migrate to lua-single.eclass
Builds and installs fine against lua5-3. Against lua5-4, src_configure dies with "configure: error: Use of included lua disabled, and no lua found from system" Note: USE=system-lua is still masked for this package, leaving it up to its maintainers to unmask it. Closes: https://bugs.gentoo.org/752711 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/freeciv/freeciv-2.6.4.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/games-strategy/freeciv/freeciv-2.6.4.ebuild b/games-strategy/freeciv/freeciv-2.6.4.ebuild
index 93312c18dcb0..93e090d0ab52 100644
--- a/games-strategy/freeciv/freeciv-2.6.4.ebuild
+++ b/games-strategy/freeciv/freeciv-2.6.4.ebuild
@@ -3,10 +3,12 @@
EAPI=7
+LUA_COMPAT=( lua5-3 )
+
MY_PV="${PV/_beta/-beta}"
MY_PV="${MY_PV/_rc/-RC}"
MY_P="${PN}-${MY_PV}"
-inherit desktop flag-o-matic qmake-utils xdg
+inherit desktop flag-o-matic lua-single qmake-utils xdg
DESCRIPTION="Multiplayer strategy game (Civilization Clone)"
HOMEPAGE="http://www.freeciv.org/"
@@ -20,6 +22,8 @@ LICENSE="GPL-2+"
SLOT="0"
IUSE="aimodules auth dedicated +gtk ipv6 mapimg modpack mysql nls qt5 readline sdl +server +sound sqlite system-lua"
+REQUIRED_USE="system-lua? ( ${LUA_REQUIRED_USE} )"
+
RDEPEND="
app-arch/bzip2
app-arch/xz-utils
@@ -56,7 +60,7 @@ RDEPEND="
)
)
readline? ( sys-libs/readline:0= )
- system-lua? ( >=dev-lang/lua-5.3:= )
+ system-lua? ( ${LUA_DEPS} )
"
DEPEND="${RDEPEND}
!dedicated? ( x11-base/xorg-proto )
@@ -74,6 +78,8 @@ pkg_setup() {
ewarn "Disabling server USE flag will make it impossible to start local"
ewarn "games, but you will still be able to join multiplayer games."
fi
+
+ use system-lua && lua-single_pkg_setup
}
src_prepare() {