summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-06 22:59:20 +0000
committerSam James <sam@gentoo.org>2021-04-06 23:00:36 +0000
commita0ca50acf3ccbc6bcea29f5366a0ef8b37dc782c (patch)
tree9f97371ee739a3016cb2cbe28b0cfb673caf286a /games-strategy
parentkde-apps/kdenetwork-meta: Fix metadata.xml (diff)
downloadgentoo-a0ca50acf3ccbc6bcea29f5366a0ef8b37dc782c.tar.gz
gentoo-a0ca50acf3ccbc6bcea29f5366a0ef8b37dc782c.tar.bz2
gentoo-a0ca50acf3ccbc6bcea29f5366a0ef8b37dc782c.zip
games-strategy/darwinia: port to EAPI 7, games.eclass--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/darwinia/darwinia-1.4.0_beta9-r2.ebuild (renamed from games-strategy/darwinia/darwinia-1.4.0_beta9-r1.ebuild)22
1 files changed, 10 insertions, 12 deletions
diff --git a/games-strategy/darwinia/darwinia-1.4.0_beta9-r1.ebuild b/games-strategy/darwinia/darwinia-1.4.0_beta9-r2.ebuild
index d1f5e9d5f83a..562267b62e43 100644
--- a/games-strategy/darwinia/darwinia-1.4.0_beta9-r1.ebuild
+++ b/games-strategy/darwinia/darwinia-1.4.0_beta9-r2.ebuild
@@ -1,19 +1,20 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
+
CDROM_OPTIONAL="yes"
-inherit eutils unpacker cdrom games
+inherit cdrom desktop unpacker wrapper
MY_PV=${PV/_beta/b}
-DESCRIPTION="the hyped indie game of the year. By the Uplink creators"
+DESCRIPTION="The hyped indie game of the year - by the Uplink creators"
HOMEPAGE="http://www.darwinia.co.uk/support/linux.html"
SRC_URI="http://www.introversion.co.uk/darwinia/downloads/${PN}-full-${MY_PV}.sh"
+S="${WORKDIR}"
LICENSE="Introversion"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
-IUSE=""
RESTRICT="bindist mirror strip"
RDEPEND="
@@ -21,11 +22,10 @@ RDEPEND="
media-libs/libsdl[abi_x86_32(-)]
media-libs/libvorbis[abi_x86_32(-)]
virtual/glu[abi_x86_32(-)]
- virtual/opengl[abi_x86_32(-)]"
-
-S=${WORKDIR}
+ virtual/opengl[abi_x86_32(-)]
+"
-dir=${GAMES_PREFIX_OPT}/${PN}
+dir=opt/${PN}
QA_PREBUILT="${dir:1}/lib/darwinia.bin.x86"
src_unpack() {
@@ -50,9 +50,8 @@ src_install() {
dodoc README
newicon darwinian.png darwinia.png
- games_make_wrapper darwinia ./darwinia "${dir}" "${dir}"
+ make_wrapper darwinia ./darwinia "${dir}" "${dir}"
make_desktop_entry darwinia "Darwinia"
- prepgamesdirs
}
pkg_postinst() {
@@ -60,5 +59,4 @@ pkg_postinst() {
ewarn "To play the game, you need to copy main.dat and sounds.dat"
ewarn "from gamefiles/ on the game CD to ${dir}/lib/."
fi
- games_pkg_postinst
}