summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristophe Lermytte <gentoo@lermytte.be>2022-12-18 22:58:31 +0100
committerSam James <sam@gentoo.org>2022-12-19 02:59:56 +0000
commitae18d0e0a580c608851e25cc1515d8bc13fb1e98 (patch)
tree74c63d0e9b58a48bd7f8d7fd5b1f6b449fcfd1b8 /games-strategy
parentmedia-gfx/sane-backends: Stabilize 1.1.1-r13 arm, #887079 (diff)
downloadgentoo-ae18d0e0a580c608851e25cc1515d8bc13fb1e98.tar.gz
gentoo-ae18d0e0a580c608851e25cc1515d8bc13fb1e98.tar.bz2
gentoo-ae18d0e0a580c608851e25cc1515d8bc13fb1e98.zip
games-strategy/wesnoth: fix build with boost-1.81
Signed-off-by: Christophe Lermytte <gentoo@lermytte.be> Closes: https://bugs.gentoo.org/886575 Closes: https://github.com/gentoo/gentoo/pull/28708 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wesnoth/files/wesnoth-1.16.6-fix-build-with-boost-1.81.patch49
-rw-r--r--games-strategy/wesnoth/wesnoth-1.16.6.ebuild2
2 files changed, 51 insertions, 0 deletions
diff --git a/games-strategy/wesnoth/files/wesnoth-1.16.6-fix-build-with-boost-1.81.patch b/games-strategy/wesnoth/files/wesnoth-1.16.6-fix-build-with-boost-1.81.patch
new file mode 100644
index 000000000000..785a5440cbbf
--- /dev/null
+++ b/games-strategy/wesnoth/files/wesnoth-1.16.6-fix-build-with-boost-1.81.patch
@@ -0,0 +1,49 @@
+https://bugs.gentoo.org/886575
+https://github.com/wesnoth/wesnoth/issues/7215
+
+From d71e90ee50a89673cf9b6748bcb2975071d15445 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
+ <congdanhqx@gmail.com>
+Date: Mon, 28 Nov 2022 23:21:38 +0700
+Subject: [PATCH] gettext: fix build with Boost.Locale 1.81
+
+See https://github.com/boostorg/locale/pull/128/
+
+(cherry picked from commit fd96415bdf0a2e3a05e1a587a1c3853847e2c2bc)
+--- a/src/gettext.cpp
++++ b/src/gettext.cpp
+@@ -26,6 +26,7 @@
+ #include <mutex>
+ #include <boost/locale.hpp>
+ #include <set>
++#include <type_traits>
+
+ #if defined(__GNUC__)
+ #pragma GCC diagnostic push
+@@ -224,8 +225,13 @@ namespace
+ }
+
+ generator_.use_ansi_encoding(false);
++#if BOOST_VERSION < 108100
+ generator_.categories(bl::message_facet | bl::information_facet | bl::collation_facet | bl::formatting_facet | bl::convert_facet);
+ generator_.characters(bl::char_facet);
++#else
++ generator_.categories(bl::category_t::message | bl::category_t::information | bl::category_t::collation | bl::category_t::formatting | bl::category_t::convert);
++ generator_.characters(bl::char_facet_t::char_f);
++#endif
+ // We cannot have current_locale_ be a non boost-generated locale since it might not supply
+ // the bl::info facet. As soon as we add message paths, update_locale_internal might fail,
+ // for example because of invalid .mo files. So make sure we call it at least once before adding paths/domains
+@@ -368,7 +374,12 @@ namespace
+ if(std::has_facet<bl::collator<char>>(current_locale_)) {
+ res << "has bl::collator<char> facet, ";
+ }
++#if BOOST_VERSION < 108100
+ res << "generator categories='" << generator_.categories() << "'";
++#else
++ res << "generator categories='" <<
++ static_cast<std::underlying_type<bl::category_t>::type>(generator_.categories()) << "'";
++#endif
+ return res.str();
+ }
+
diff --git a/games-strategy/wesnoth/wesnoth-1.16.6.ebuild b/games-strategy/wesnoth/wesnoth-1.16.6.ebuild
index 1ee6998e389d..ebb79a331120 100644
--- a/games-strategy/wesnoth/wesnoth-1.16.6.ebuild
+++ b/games-strategy/wesnoth/wesnoth-1.16.6.ebuild
@@ -43,6 +43,8 @@ BDEPEND="
virtual/pkgconfig
"
+PATCHES=( "${FILESDIR}/wesnoth-1.16.6-fix-build-with-boost-1.81.patch" )
+
src_prepare() {
cmake_src_prepare