summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenton Groombridge <me@concord.sh>2021-04-11 13:52:28 -0400
committerSam James <sam@gentoo.org>2021-04-20 13:45:07 +0000
commitbfac3277ac831f805074027c0bf5529852536a4b (patch)
treeeefe64dc53c387c0c95fc1ae3812fb3d7ba5d863 /games-strategy
parentdev-java/jackcess: sorted keywords in 4.0.0 (diff)
downloadgentoo-bfac3277ac831f805074027c0bf5529852536a4b.tar.gz
gentoo-bfac3277ac831f805074027c0bf5529852536a4b.tar.bz2
gentoo-bfac3277ac831f805074027c0bf5529852536a4b.zip
games-strategy/warzone2100: version bump to 4.0.1
Closes: https://bugs.gentoo.org/777330 Signed-off-by: Kenton Groombridge <me@concord.sh> Closes: https://github.com/gentoo/gentoo/pull/20339 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/warzone2100/Manifest1
-rw-r--r--games-strategy/warzone2100/warzone2100-4.0.1.ebuild116
2 files changed, 117 insertions, 0 deletions
diff --git a/games-strategy/warzone2100/Manifest b/games-strategy/warzone2100/Manifest
index 7422776675be..8b42460f1002 100644
--- a/games-strategy/warzone2100/Manifest
+++ b/games-strategy/warzone2100/Manifest
@@ -1,3 +1,4 @@
DIST warzone2100-3.3.0_src.tar.xz 86605304 BLAKE2B 70bad66966e31009de7f16a039525b2bc3e84a9991e7d95227f8789ceca7313a219044f41c0ceec0ce357e8368a30833d7dc1cc35e9575d9b56efa20b9e35c03 SHA512 876e36578472d9de4c00651af9b26a79bbbc85161d03c58e381aac90be710999b9091524425332e950ed42b79d872ace6848798829e7d3d7bb6ae7dae0003559
DIST warzone2100-3.4.1.tar.xz 89169752 BLAKE2B a0f379e357c315e083f8ac1542297262abb48aae1f8a3e0666898e047749a8a108924b0dea000df1731fc94ccdce9e2768bbebd3333063a730931f7fbf9192a2 SHA512 26c026400e418ed3da94d96e7bb443c765ede3e0b347785ff8a9e687a5ad87afe03012c830fd509b927634484687efac951b2ef3417e7fe027ce0e684561ca84
+DIST warzone2100-4.0.1.tar.xz 337713608 BLAKE2B 4f1bf79e71c13cd507890f2fe4131687fd70bc3b302aea68c7f17314a0d596797a34d9ab46a6736e98d823122199fb0dfcfb62b1f6b702c6d8ba99eb3c338c9e SHA512 820ab41ebc0ca3e81aff67f90eb3946f6a889776b243795c0cab8dbea44d4c5c3620c849cb70fa45c40af14b9a5667823373f9887078bb2b4feb30d2af007180
DIST warzone2100-videos-2.2.wz 571937134 BLAKE2B 60b70a71bd920e2d72ded5d519b17db2f3db4b0289edadeb58059a21aba7038b95219dc44cb807754461d1a9bdca60f0d7698be68622b8bd64a55efa949622d3 SHA512 ca1a1af51296afdaca137114821508c5783f077090e665eae0f6df895855f57c43f84434706309e819417f5f35d1c649bd14e96dc9fbbb1252d30a4f9a223cf6
diff --git a/games-strategy/warzone2100/warzone2100-4.0.1.ebuild b/games-strategy/warzone2100/warzone2100-4.0.1.ebuild
new file mode 100644
index 000000000000..d1a62cac0865
--- /dev/null
+++ b/games-strategy/warzone2100/warzone2100-4.0.1.ebuild
@@ -0,0 +1,116 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake desktop xdg
+
+MY_PV=$(ver_cut 1-2)
+VIDEOS_PV=2.2
+VIDEOS_P=${PN}-videos-${VIDEOS_PV}.wz
+DESCRIPTION="3D real-time strategy game"
+HOMEPAGE="https://wz2100.net/"
+SRC_URI="mirror://sourceforge/warzone2100/releases/${PV}/${PN}_src.tar.xz -> ${P}.tar.xz
+ videos? ( mirror://sourceforge/warzone2100/warzone2100/Videos/${VIDEOS_PV}/high-quality-en/sequences.wz -> ${VIDEOS_P} )"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0 public-domain"
+SLOT="0"
+#[[ "${PV}" == *_beta* ]] || \
+KEYWORDS="~amd64 ~x86"
+# upstream requested debug support
+IUSE="debug discord nls videos vulkan"
+
+# TODO: unbundle miniupnpc and quesoglc
+# quesoglc-0.7.2 is buggy: http://developer.wz2100.net/ticket/2828
+CDEPEND="
+ >=dev-games/physfs-2[zip]
+ >=dev-libs/libsodium-1.0.14
+ dev-libs/openssl:0=
+ media-libs/freetype:2
+ media-libs/glew:=
+ media-libs/harfbuzz
+ media-libs/libogg
+ media-libs/libpng:0
+ media-libs/libsdl2[opengl,video,X]
+ media-libs/libtheora
+ media-libs/libvorbis
+ media-libs/openal
+ sys-libs/zlib
+ virtual/glu
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXrandr
+ nls? ( virtual/libintl )
+ vulkan? ( media-libs/libsdl2:=[vulkan] )
+"
+DEPEND="
+ ${CDEPEND}
+ app-text/asciidoc
+ dev-libs/fribidi
+ media-libs/fontconfig
+"
+RDEPEND="
+ ${CDEPEND}
+ media-fonts/dejavu
+"
+BDEPEND="
+ app-arch/zip
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${P}.tar.xz
+}
+
+src_prepare() {
+ default
+
+ sed -i -e 's/#top_builddir/top_builddir/' po/Makevars || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWZ_DISTRIBUTOR="Gentoo"
+ -DWZ_ENABLE_WARNINGS_AS_ERRORS="OFF"
+ -DWZ_ENABLE_BACKEND_VULKAN="$(usex vulkan)"
+ -DWZ_PORTABLE="OFF"
+ -DBUILD_SHARED_LIBS="OFF"
+ -DENABLE_NLS="$(usex nls)"
+ -DENABLE_DISCORD="$(usex discord)"
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+
+ asciidoc -b html5 doc/quickstartguide.asciidoc || die
+}
+
+src_install() {
+ local HTML_DOCS=( doc/quickstartguide.html doc/docbook-xsl.css doc/ScriptingManual.htm )
+ local DOCS=( README.md doc/images doc/Scripting.md doc/js-globals.md )
+ default
+
+ insinto /usr/bin
+ dobin "${BUILD_DIR}"/src/${PN}
+
+ insinto /usr/share/${PN}
+ doins "${BUILD_DIR}"/data/base.wz
+ doins "${BUILD_DIR}"/data/mp.wz
+ if use videos ; then
+ newins "${DISTDIR}"/${VIDEOS_P} sequences.wz
+ fi
+ insinto /usr/share/${PN}
+ doins -r data/music
+
+ doman "${BUILD_DIR}"/doc/warzone2100.6
+
+ doicon -s 128 icons/warzone2100.png
+ domenu icons/warzone2100.desktop
+}