summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-08-25 17:21:48 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-08-25 17:21:48 +0200
commit0f917374bcbafc1e0ec7ecad84ada6331a67b8fa (patch)
tree4e50eee6c78d722324be4a30ebc9c402588fabc0 /games-util/antimicro
parentdev-db/cppdb: Drop old (diff)
downloadgentoo-0f917374bcbafc1e0ec7ecad84ada6331a67b8fa.tar.gz
gentoo-0f917374bcbafc1e0ec7ecad84ada6331a67b8fa.tar.bz2
gentoo-0f917374bcbafc1e0ec7ecad84ada6331a67b8fa.zip
games-util/antimicro: 2.23 version bump, EAPI-6
Thanks-to: Niranjan <niranjan.public@gmail.com> Thanks-to: Small_Penguin <dark.shadow@gmx.at> Closes: https://bugs.gentoo.org/603712 Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'games-util/antimicro')
-rw-r--r--games-util/antimicro/Manifest1
-rw-r--r--games-util/antimicro/antimicro-2.23.ebuild54
-rw-r--r--games-util/antimicro/files/antimicro-2.23-linking-errors.patch40
3 files changed, 95 insertions, 0 deletions
diff --git a/games-util/antimicro/Manifest b/games-util/antimicro/Manifest
index 308f0153c431..e1f6d1de1c11 100644
--- a/games-util/antimicro/Manifest
+++ b/games-util/antimicro/Manifest
@@ -1 +1,2 @@
DIST antimicro-2.20.2.tar.gz 1069469 BLAKE2B 8507c4f46e3e016c54d6cc0081ad5e90a0473bd1b99c30e6ceb74804564fdde6cd4bcb4897be5ae06272ae0aa55f36976d91ee9b1d531fce2013dad81379c1bb SHA512 09847c804b6a1d022f2990d269c9124cfdfab821e0fd1cb1ab5e27e4c6a3bd250fab5977ca614f03c46456ca6e1c7111135b9b4d8f75e54c435e0b712653e282
+DIST antimicro-2.23.tar.gz 1157299 BLAKE2B 4577588414f3145f5e6a817160214d6f2d0fc3cc3c9dda456173c42586247420f413785b7ca26b9d02397fb970e005c386675a478fd07330d5b13683094f28ab SHA512 cd58b5a9771d35fc937306a3452e8776ef754bb5a4fa44aeedb735d8366a38b318c1bf14f105bf8003e4264c35f129224becdade32d2a7b61067ec5a705a1e7e
diff --git a/games-util/antimicro/antimicro-2.23.ebuild b/games-util/antimicro/antimicro-2.23.ebuild
new file mode 100644
index 000000000000..62d39364b1de
--- /dev/null
+++ b/games-util/antimicro/antimicro-2.23.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils xdg-utils
+
+DESCRIPTION="Map keyboard and mouse buttons to gamepad buttons"
+HOMEPAGE="https://github.com/AntiMicro/antimicro"
+SRC_URI="https://github.com/AntiMicro/antimicro/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ media-libs/libsdl2[X,joystick]
+ x11-libs/libX11
+ x11-libs/libXtst
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+"
+
+PATCHES=( "${FILESDIR}/${P}-linking-errors.patch" )
+
+src_configure() {
+ # TODO: Currently does not build w/o X
+ # (!X would be: -DWITH_XTEST=OFF -DWITH_UINPUT=ON)
+ local mycmakeargs=(
+ -DUSE_QT5=ON
+ -DUSE_SDL_2=ON
+ -DWITH_X11=ON
+ -DWITH_XTEST=ON
+ -DWITH_UINPUT=OFF
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}
diff --git a/games-util/antimicro/files/antimicro-2.23-linking-errors.patch b/games-util/antimicro/files/antimicro-2.23-linking-errors.patch
new file mode 100644
index 000000000000..88d03e876704
--- /dev/null
+++ b/games-util/antimicro/files/antimicro-2.23-linking-errors.patch
@@ -0,0 +1,40 @@
+From d5cfe429edb8c5f6f039153a0f646f2198c06b16 Mon Sep 17 00:00:00 2001
+From: Raphael Kubo da Costa <rakuco@FreeBSD.org>
+Date: Mon, 29 Jan 2018 12:19:55 +0100
+Subject: [PATCH] cmake: Stop calling QT5_WRAP_CPP().
+
+The USE_QT5 code path already unconditionally sets CMAKE_AUTOMOC to on.
+
+Calling QT5_WRAP_CPP() used to be just redundant, as antimicro_HEADERS_MOC
+was never actually added as a source dependency of the antimicro target. In
+other words, CMake's own automoc infrastructure was actually being used and
+the moc invocations from QT5_WRAP_CPP() were not being made at all.
+
+Starting with Qt 5.9.4, calling QT5_WRAP_CPP() disables the AUTOMOC property
+on the macro's input files, which means neither CMake's automoc
+infrastructure not QT5_WRAP_CPP()'s code were being used and we ended up
+with several 'undefined reference to vtable' errors when linking.
+---
+ CMakeLists.txt | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 63ef851..0e47889 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -499,7 +499,6 @@ if (UNIX)
+ find_package(Qt5Network REQUIRED)
+ find_package(Qt5LinguistTools REQUIRED)
+
+- QT5_WRAP_CPP(antimicro_HEADERS_MOC ${antimicro_HEADERS})
+ QT5_WRAP_UI(antimicro_FORMS_HEADERS ${antimicro_FORMS})
+ QT5_ADD_RESOURCES(antimicro_RESOURCES_RCC ${antimicro_RESOURCES})
+ add_subdirectory("share/antimicro/translations")
+@@ -550,7 +549,6 @@ elseif(WIN32)
+ find_package(Qt5Network REQUIRED)
+ find_package(Qt5LinguistTools REQUIRED)
+
+- QT5_WRAP_CPP(antimicro_HEADERS_MOC ${antimicro_HEADERS})
+ QT5_WRAP_UI(antimicro_FORMS_HEADERS ${antimicro_FORMS})
+ QT5_ADD_RESOURCES(antimicro_RESOURCES_RCC ${antimicro_RESOURCES})
+ add_subdirectory("share/antimicro/translations")