summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-util/gtkevemon/gtkevemon-9999.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-util/gtkevemon/gtkevemon-9999.ebuild')
-rw-r--r--games-util/gtkevemon/gtkevemon-9999.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/games-util/gtkevemon/gtkevemon-9999.ebuild b/games-util/gtkevemon/gtkevemon-9999.ebuild
new file mode 100644
index 000000000000..b380ae1afe46
--- /dev/null
+++ b/games-util/gtkevemon/gtkevemon-9999.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+IUSE=""
+if [[ ${PV} == *9999* ]]; then
+ inherit mercurial
+ EHG_REPO_URI="https://bitbucket.org/BattleClinic/${PN}"
+ KEYWORDS=""
+ SRC_URI=""
+ MY_S="${WORKDIR}/${P}/gtkevemon"
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="http://gtkevemon.battleclinic.com/releases/${P}-source.tar.gz"
+fi
+
+DESCRIPTION="A standalone skill monitoring application for EVE Online"
+HOMEPAGE="http://gtkevemon.battleclinic.com"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+ dev-cpp/gtkmm:2.4
+ dev-libs/libxml2
+"
+DEPEND="${DEPEND}
+ virtual/pkgconfig
+"
+
+src_unpack()
+{
+ if [[ ${PV} == *9999* ]]; then
+ mercurial_src_unpack
+ S=${MY_S}
+ else
+ default
+ fi
+}
+
+src_prepare() {
+ sed -e 's:Categories=Game;$:Categories=Game;RolePlaying;GTK;:' \
+ -i icon/${PN}.desktop || die "sed failed"
+}
+
+src_install() {
+ # fixed QA notice
+ sed -i "/^Encoding/d" icon/${PN}.desktop
+ dobin src/${PN}
+ doicon icon/${PN}.svg
+ domenu icon/${PN}.desktop
+ dodoc CHANGES README TODO
+}