summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-01-14 10:29:44 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-01-14 10:29:44 +0100
commit81069989bd5d1313dff2639cc7efdbc0925e66cc (patch)
treee64c70945d79ad6b9b2e6a21e5da7b98c2f17780 /games-util/lutris
parentdev-util/cucumber-compatibility-kit: enable ruby33 (diff)
downloadgentoo-81069989bd5d1313dff2639cc7efdbc0925e66cc.tar.gz
gentoo-81069989bd5d1313dff2639cc7efdbc0925e66cc.tar.bz2
gentoo-81069989bd5d1313dff2639cc7efdbc0925e66cc.zip
games-util/lutris: add 0.5.15
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'games-util/lutris')
-rw-r--r--games-util/lutris/Manifest1
-rw-r--r--games-util/lutris/lutris-0.5.15.ebuild158
2 files changed, 159 insertions, 0 deletions
diff --git a/games-util/lutris/Manifest b/games-util/lutris/Manifest
index f1b7c0daf24a..24c7922df313 100644
--- a/games-util/lutris/Manifest
+++ b/games-util/lutris/Manifest
@@ -1,2 +1,3 @@
DIST lutris_0.5.13.tar.xz 1565824 BLAKE2B 5326f7d671f91cab9e2f21377b939f33383098778751d2855d319b6f84b349108dce9a92faecf804e292cb711dfe6dc40a1ede591847b13550d25d83f51a9c7f SHA512 8ca257de9647a21774c9aaa251178a5f5b4eb137985913e136e27959880a356f95bd0ba6ba75059b92f7d92fdeee7f410592a39c60d8ec72412a3106a1561a7b
DIST lutris_0.5.14.tar.xz 4394748 BLAKE2B dc1a8089219ebd3ea42be45fe0dc942a6353ac69b30527a8766c7ae54bd09fb529296e5e63a717d8a1033e70b3a9ab52daa87d5287845e34e53d765aec41191d SHA512 1292ef9dfb9bc977d6b687319060451a615e27c2e056aeafb4db21bdb20fec2b051bb31230604c528860871bdde01f2385a5320467b74c8ad3b516574ce7fb27
+DIST lutris_0.5.15.tar.xz 6298936 BLAKE2B eea666584be35b822d53d7c865fcb3c7d4ecb97f8f78f12cf745cb32e8d526244be5145a4fb584b2c921eb843f0451c03c8e99350b7c7c0b6abdcfb2cf786865 SHA512 c923f70b81ac2f79d33cea127975650652bb0496eb85406996c7a20a01b5dc40674ddc8bd4dfb1ab32db4ed1e4b00535acf343c55f9b20c6bc5b04b397c59ca9
diff --git a/games-util/lutris/lutris-0.5.15.ebuild b/games-util/lutris/lutris-0.5.15.ebuild
new file mode 100644
index 000000000000..2c3d1da23ab2
--- /dev/null
+++ b/games-util/lutris/lutris-0.5.15.ebuild
@@ -0,0 +1,158 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="sqlite,threads(+)"
+
+inherit meson python-single-r1 optfeature virtualx xdg
+
+DESCRIPTION="An open source gaming platform for GNU/Linux"
+HOMEPAGE="https://lutris.net/"
+
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/lutris/lutris.git"
+ inherit git-r3
+else
+ if [[ ${PV} == *_beta* ]] ; then
+ SRC_URI="https://github.com/lutris/lutris/archive/refs/tags/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${P/_/-}
+ else
+ SRC_URI="https://lutris.net/releases/${P/-/_}.tar.xz"
+ S="${WORKDIR}/${PN}"
+ KEYWORDS="~amd64 ~x86"
+ fi
+fi
+
+LICENSE="GPL-3+ CC0-1.0"
+SLOT="0"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ app-arch/cabextract
+ app-arch/p7zip
+ app-arch/unzip
+ $(python_gen_cond_dep '
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
+ dev-python/pypresence[${PYTHON_USEDEP}]
+ dev-python/python-evdev[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/moddb[${PYTHON_USEDEP}]
+ ')
+ media-sound/fluid-soundfont
+ || (
+ net-libs/webkit-gtk:4[introspection]
+ net-libs/webkit-gtk:4.1[introspection]
+ )
+ sys-apps/xdg-desktop-portal
+ x11-apps/mesa-progs
+ x11-apps/xgamma
+ x11-apps/xrandr
+ x11-libs/gtk+:3[introspection]
+ x11-libs/gdk-pixbuf[jpeg]
+"
+
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/pytest[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+DOCS=( AUTHORS README.rst docs/installers.rst docs/steam.rst )
+
+EPYTEST_IGNORE=(
+ # Requires a Nvidia GPU and driver
+ tests/util/graphics/test_drivers.py
+)
+
+src_test() {
+ meson_src_test
+ virtx epytest
+}
+
+src_install() {
+ meson_src_install
+ python_fix_shebang "${ED}/usr/" #740048
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "playing various games through Valve's Steam launcher (available in Steam overlay)" games-util/steam-launcher
+ optfeature "playing games through Valve's micro-compositor" gui-wm/gamescope
+ optfeature "playing games inside a nested X server" x11-base/xorg-server[xephyr]
+ optfeature "installing and playing games from Flathub" sys-apps/flatpak
+ optfeature "playing Microsoft Windows games" virtual/wine
+ optfeature "playing DirectX based games by translating DirectX to Vulkan" "media-libs/vulkan-loader dev-util/vulkan-tools app-emulation/dxvk virtual/wine"
+ optfeature "playing Vulkan based games (plus ICD for your hardware)" "media-libs/vulkan-loader dev-util/vulkan-tools"
+ optfeature "a Vulkan and OpenGL overlay for monitoring system performance (available in GURU overlay)" games-util/mangohud
+ elog
+
+ optfeature_header "${PN} supports various emulators and compatibility layers. \n${PN} can download and install these by itself, but also supports using system-wide installed versions"
+ optfeature "playing games through x86 PC emulator" app-emulation/86Box
+ # TODO: Package Adventure Game Studio runner
+ optfeature "playing Atari 800 games through an emulator" games-emulation/atari800
+ # TODO: Package Basilisk II Mac emulator
+ # TODO: Package Wii U emulator
+ optfeature "playing Nintendo 3DS games through an emulator (available in GURU overlay)" games-emulation/citra
+ # TODO: Package ColecoVision/Coleco Adam emulator
+ optfeature "playing Nintendo DS games through an emulator" games-emulation/desmume
+ optfeature "playing Sega Genesis games through an emulator" games-emulation/dgen-sdl
+ optfeature "playing GameCube and Wii games through an emulator" games-emulation/dolphin
+ optfeature "playing DOS games through an emulator" games-emulation/dosbox
+ optfeature "playing RPG Maker 2000/2003 games (available in GURU overlay)" games-engines/easyrpg-player
+ optfeature "playing Z-code based text games" games-engines/frotz
+ optfeature "playing Amiga games through an emulator" app-emulation/fs-uae
+ optfeature "playing Atari ST games through an emulator" games-emulation/hatari
+ # TODO: Package Intellivision emulator
+ optfeature "playing games through various emulators" games-emulation/libretro-info
+ optfeature "playing Arcade games through an emulator" games-emulation/advancemame
+ optfeature "playing games through various emulators" games-emulation/mednafen
+ optfeature "playing Nintendo DS games through an emulator" games-emulation/melonds
+ # TODO: Package mGBA
+ # TODO: Package MicroM8 Apple II emulator
+ # TODO: Package Mini vMac emulator
+ optfeature "playing Nintendo 64 games through an emulator" games-emulation/mupen64plus
+ # TODO: Package O2Em emulator
+ # TODO: Package Sega Master System emulator
+ optfeature "playing IBM PC games through an emulator" app-emulation/pcem
+ optfeature "playing Sony PlayStation 2 games through an emulator" games-emulation/pcsx2
+ optfeature "playing various fantasy games" dev-lang/pico8
+ optfeature "playing Sony PlayStation Portable games through an emulator" games-emulation/ppsspp
+ # TODO: Package SEGA Dreamcast emulator redream
+ # TODO: Package SEGA Dreamcast emulator reicast
+ # TODO: Package Rosalie's Mupen GUI
+ optfeature "playing Sony PlayStation 3 games through an emulator (available in GURU overlay)" games-emulation/rpcs3
+ optfeature "playing Adobe Flash Player games through an emulator" app-emulation/ruffle
+ # TODO: Package Nintendo Switch emulator
+ optfeature "playing Lucasarts adventure games" games-engines/scummvm
+ # TODO: Package PowerMacintosh emulator
+ optfeature "playing Super Nintendo (SNES) games through an emulator" games-emulation/snes9x
+ # TODO: Package Sinclair ZX Spectrum emulator
+ optfeature "playing Atari 2600 VCS games through an emulator" games-emulation/stella
+ # TODO: Package TIC-80 tiny computer
+ optfeature "playing Commodore games through an emulator" app-emulation/vice
+ # TODO: Package Atari Jaguar emulator
+ # TODO: Package runner for HTML5 web games
+ # TODO: Package Xbox emulator
+ optfeature "playing Nintendo Switch games through an emulator (available in GURU overlay)" games-emulation/yuzu
+ optfeature "playing DOOM games" games-fps/gzdoom
+
+ # Quote README.rst
+ elog
+ elog "Lutris installations are fully automated through scripts, which can"
+ elog "be written in either JSON or YAML. The scripting syntax is described"
+ elog "in ${EROOT}/usr/share/doc/${PF}/installers.rst.bz2, and is also"
+ elog "available online at lutris.net."
+}