summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-09-20 08:00:56 +0100
committerJames Le Cuirot <chewi@gentoo.org>2016-09-20 08:03:22 +0100
commit67f25cb2ee56f7c6052fa93116eb59681be0ad0c (patch)
tree94717bb85405276de1fd3fa24c78be221838f2a5 /games-util/nml
parentdev-lang/julia: version bump to 0.5.0 (diff)
downloadgentoo-67f25cb2ee56f7c6052fa93116eb59681be0ad0c.tar.gz
gentoo-67f25cb2ee56f7c6052fa93116eb59681be0ad0c.tar.bz2
gentoo-67f25cb2ee56f7c6052fa93116eb59681be0ad0c.zip
games-util/nml: Add python3_5, drop python3_4, EAPI bump to 6
dev-python/ply has python3_5 now. Package-Manager: portage-2.3.1
Diffstat (limited to 'games-util/nml')
-rw-r--r--games-util/nml/nml-0.4.4-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/games-util/nml/nml-0.4.4-r1.ebuild b/games-util/nml/nml-0.4.4-r1.ebuild
new file mode 100644
index 000000000000..8cdab7d3e94a
--- /dev/null
+++ b/games-util/nml/nml-0.4.4-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5} )
+inherit distutils-r1
+
+DESCRIPTION="Compiler of NML files into grf/nfo files"
+HOMEPAGE="http://dev.openttdcoop.org/projects/nml"
+SRC_URI="http://bundles.openttdcoop.org/nml/releases/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+
+RDEPEND="dev-python/pillow[zlib,${PYTHON_USEDEP}]
+ dev-python/ply[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( docs/{changelog,readme}.txt )
+PATCHES=( "${FILESDIR}"/${P}-pillow3.patch )
+
+src_install() {
+ distutils-r1_src_install
+ doman docs/nmlc.1
+}