summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-util/ucon64
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-util/ucon64')
-rw-r--r--games-util/ucon64/Manifest1
-rw-r--r--games-util/ucon64/files/ucon64-2.0.0-ovflfix.patch20
-rw-r--r--games-util/ucon64/files/ucon64-2.0.0-zlib.patch45
-rw-r--r--games-util/ucon64/metadata.xml8
-rw-r--r--games-util/ucon64/ucon64-2.0.0.ebuild62
5 files changed, 136 insertions, 0 deletions
diff --git a/games-util/ucon64/Manifest b/games-util/ucon64/Manifest
new file mode 100644
index 000000000000..19332b89f822
--- /dev/null
+++ b/games-util/ucon64/Manifest
@@ -0,0 +1 @@
+DIST ucon64-2.0.0-src.tar.gz 1188488 SHA256 62064324a1912387f84ac9d4c521c5d5e7b80f2567e9f61bf0ab3e1d976c0127 SHA512 d021fe6db9530405773e1e209bdfafe41a2bd997f275ca7fb387f9b3d8639f4581c2761cbdce859a1831d6eba9dab4d5df1019605698c6cb6a4695ab091b001c WHIRLPOOL 922d22e3b856df221d66bc506bae73d895fddb7e2a0577a14569c9874d5ddac33bf8e6b91c7c2ec3f8e8fea59b57159085d9be2ddf046a2b96ed31004ffd153d
diff --git a/games-util/ucon64/files/ucon64-2.0.0-ovflfix.patch b/games-util/ucon64/files/ucon64-2.0.0-ovflfix.patch
new file mode 100644
index 000000000000..0a1668f2d09f
--- /dev/null
+++ b/games-util/ucon64/files/ucon64-2.0.0-ovflfix.patch
@@ -0,0 +1,20 @@
+--- backup/lynxit.c.old 2010-11-04 09:07:18.000000000 +0100
++++ backup/lynxit.c 2010-11-04 09:08:17.000000000 +0100
+@@ -561,7 +561,7 @@
+ return FALSE;
+ }
+
+- if (strcmp (header.magic, "LYNX") != 0)
++ if (memcmp (header.magic, "LYNX", sizeof(header.magic)) != 0)
+ {
+ MESSAGE (("ERROR : %s is not a lynx image\n", filename));
+ fclose (fp);
+@@ -682,7 +682,7 @@
+ #endif
+
+ memset (&header, 0, sizeof (st_lnx_header_t));
+- strcpy (header.magic, MAGIC_STRING);
++ memcpy (header.magic, MAGIC_STRING, sizeof(header.magic));
+ strcpy (header.cartname, cartname);
+ strcpy (header.manufname, manufname);
+ header.page_size_bank0 = cart_analyse (BANK0);
diff --git a/games-util/ucon64/files/ucon64-2.0.0-zlib.patch b/games-util/ucon64/files/ucon64-2.0.0-zlib.patch
new file mode 100644
index 000000000000..7a122713d232
--- /dev/null
+++ b/games-util/ucon64/files/ucon64-2.0.0-zlib.patch
@@ -0,0 +1,45 @@
+--- misc/unzip.h.old 2011-09-23 19:53:09.708884325 +0200
++++ misc/unzip.h 2011-09-23 19:54:00.012878355 +0200
+@@ -49,6 +49,10 @@
+ #include "zlib.h"
+ #endif
+
++#ifndef OF
++#define OF(x) x
++#endif
++
+ #if defined(STRICTUNZIP) || defined(STRICTZIPUNZIP)
+ /* like the STRICT of WIN32, we define a pointer that cannot be converted
+ from (void*) without cast */
+--- libdiscmage/unzip.h.old 2011-09-23 19:59:47.319837133 +0200
++++ libdiscmage/unzip.h 2011-09-23 20:00:07.230834769 +0200
+@@ -48,6 +48,9 @@
+ #ifndef _ZLIB_H
+ #include "zlib.h"
+ #endif
++#ifndef OF
++#define OF(x) x
++#endif
+
+ #if defined(STRICTUNZIP) || defined(STRICTZIPUNZIP)
+ /* like the STRICT of WIN32, we define a pointer that cannot be converted
+--- libdiscmage/misc_z.c.old 2012-03-19 08:39:41.975022496 +0100
++++ libdiscmage/misc_z.c 2012-03-19 08:40:13.109803301 +0100
+@@ -27,6 +27,7 @@
+ #include <string.h>
+ #include <errno.h>
+ #include <sys/stat.h>
++#define Z_SOLO
+ #include <zlib.h>
+ #include "misc_z.h"
+ #include "misc.h"
+--- misc/archive.c.old 2012-03-19 08:41:06.478999810 +0100
++++ misc/archive.c 2012-03-19 08:41:24.134741668 +0100
+@@ -27,6 +27,7 @@
+ #include <string.h>
+ #include <errno.h>
+ #include <sys/stat.h>
++#define Z_SOLO
+ #include <zlib.h>
+ #ifdef HAVE_BYTESWAP_H
+ #include <byteswap.h>
diff --git a/games-util/ucon64/metadata.xml b/games-util/ucon64/metadata.xml
new file mode 100644
index 000000000000..c52bd2cff4e6
--- /dev/null
+++ b/games-util/ucon64/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">ucon64</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-util/ucon64/ucon64-2.0.0.ebuild b/games-util/ucon64/ucon64-2.0.0.ebuild
new file mode 100644
index 000000000000..b8922ca2989d
--- /dev/null
+++ b/games-util/ucon64/ucon64-2.0.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="The backup tool and wonderful emulator's Swiss Army knife program"
+HOMEPAGE="http://ucon64.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ucon64/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+S=${WORKDIR}/${P}-src/src
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ovflfix.patch \
+ "${FILESDIR}"/${P}-zlib.patch
+ sed -i \
+ -e "/^CFLAGS/s/-O3/${CFLAGS}/" \
+ -e "/^LDFLAGS/s/-s$/${LDFLAGS}/" \
+ {,libdiscmage/}Makefile.in || die
+}
+
+src_configure() {
+ local myconf
+
+ if [[ ! -e /usr/include/sys/io.h ]] ; then
+ ewarn "Disabling support for parallel port"
+ myconf="${myconf} --disable-parallel"
+ fi
+
+ econf ${myconf}
+}
+
+src_install() {
+ dobin ucon64
+ dolib.so libdiscmage/discmage.so
+ cd ..
+ dohtml -x src -r -A png,jpg *
+}
+
+pkg_postinst() {
+ echo
+ elog "In order to use ${PN}, please create the directory ~/.ucon64/dat"
+ elog "The command to do that is:"
+ elog " mkdir -p ~/.ucon64/dat"
+ elog "Then, you can copy your DAT file collection to ~/.ucon64/dat"
+ elog
+ elog "To enable Discmage support, cp /usr/lib/discmage.so to ~/.ucon64"
+ elog "The command to do that is:"
+ elog " cp /usr/lib/discmage.so ~/.ucon64/"
+ elog
+ elog "Be sure to check ~/.ucon64rc for some options after"
+ elog "you've run uCON64 for the first time"
+}