summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-02-14 01:53:09 -0600
committerTim Harder <radhermit@gentoo.org>2019-02-14 01:55:45 -0600
commit94adff2612f8b38cf08a28cdc80e7e7a5700440c (patch)
tree2cffe0a79b8d8468cb418573fa49061b29e4baed /games-util/wit/wit-3.02a.ebuild
parentmedia-gfx/feh: version bump to 3.1.2 (diff)
downloadgentoo-94adff2612f8b38cf08a28cdc80e7e7a5700440c.tar.gz
gentoo-94adff2612f8b38cf08a28cdc80e7e7a5700440c.tar.bz2
gentoo-94adff2612f8b38cf08a28cdc80e7e7a5700440c.zip
games-util/wit: version bump to 3.02a
Closes: https://bugs.gentoo.org/637920 Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'games-util/wit/wit-3.02a.ebuild')
-rw-r--r--games-util/wit/wit-3.02a.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-util/wit/wit-3.02a.ebuild b/games-util/wit/wit-3.02a.ebuild
new file mode 100644
index 000000000000..86555489abac
--- /dev/null
+++ b/games-util/wit/wit-3.02a.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_P="wiimms-iso-tools.source-${PV}"
+
+DESCRIPTION="command line tools to manipulate Wii/GameCube ISO images and WBFS containers"
+HOMEPAGE="https://wit.wiimm.de/"
+SRC_URI="https://download.wiimm.de/source/wiimms-iso-tools/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+fuse +zlib"
+
+RDEPEND="
+ app-arch/bzip2:0=
+ fuse? ( sys-fs/fuse:0= )
+ zlib? ( sys-libs/zlib:0= )
+"
+DEPEND="${RDEPEND}"
+
+DOCS="doc/*.txt"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile.patch
+ "${FILESDIR}"/${PN}-2.30a-no-exec-stack.patch
+)
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ export NO_FUSE=$(usex fuse 0 1)
+ export NO_ZLIB=$(usex zlib 0 1)
+
+ emake INSTALL_PATH="${D}"/usr CC="$(tc-getCC)"
+ emake doc
+}