summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <sudinave@gmail.com>2021-01-24 17:13:45 -0500
committerSam James <sam@gentoo.org>2021-03-16 14:50:21 +0000
commit992a35642a2f076882ba39cf10799186c35da36d (patch)
tree1b76b8c1871f77114e3ef45dc99f9cf3b73d7aa1 /games-util/xpadneo
parentnet-analyzer/tcptrace: drop 6.6.7_p4_p1, 6.6.7_p5 (diff)
downloadgentoo-992a35642a2f076882ba39cf10799186c35da36d.tar.gz
gentoo-992a35642a2f076882ba39cf10799186c35da36d.tar.bz2
gentoo-992a35642a2f076882ba39cf10799186c35da36d.zip
games-util/xpadneo: new package 0.9
Signed-off-by: Ionen Wolkens <sudinave@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/19203 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-util/xpadneo')
-rw-r--r--games-util/xpadneo/Manifest1
-rw-r--r--games-util/xpadneo/metadata.xml15
-rw-r--r--games-util/xpadneo/xpadneo-0.9.ebuild62
-rw-r--r--games-util/xpadneo/xpadneo-9999.ebuild64
4 files changed, 142 insertions, 0 deletions
diff --git a/games-util/xpadneo/Manifest b/games-util/xpadneo/Manifest
new file mode 100644
index 000000000000..4cb0f0f85a80
--- /dev/null
+++ b/games-util/xpadneo/Manifest
@@ -0,0 +1 @@
+DIST xpadneo-0.9.tar.gz 1351003 BLAKE2B dd41e687a44415c9c44d70ae4df9c858a7218eca301e61421cee4b9e80d912f9336dad15636dc38cb79128a635e33bb2b795fadebe2f53ebe42d192212364cb0 SHA512 0819af24bfa556dd330abeb1180b0a46105428b6b2c8529bb357cd5b578fe6f21e057f3f457994b21b6d5d6b207d46bdf0ff80a6415f833396595ba5e7309389
diff --git a/games-util/xpadneo/metadata.xml b/games-util/xpadneo/metadata.xml
new file mode 100644
index 000000000000..32782d0fcfbb
--- /dev/null
+++ b/games-util/xpadneo/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>sudinave@gmail.com</email>
+ <name>Ionen Wolkens</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">atar-axis/xpadneo</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-util/xpadneo/xpadneo-0.9.ebuild b/games-util/xpadneo/xpadneo-0.9.ebuild
new file mode 100644
index 000000000000..33ed81817a28
--- /dev/null
+++ b/games-util/xpadneo/xpadneo-0.9.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-mod toolchain-funcs udev
+
+DESCRIPTION="Advanced Linux Driver for Xbox One Wireless Controller"
+HOMEPAGE="https://atar-axis.github.io/xpadneo/"
+SRC_URI="https://github.com/atar-axis/xpadneo/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S+="/hid-${PN}"
+MODULE_NAMES="hid-${PN}(kernel/drivers/hid::src)"
+BUILD_PARAMS='V=1 LD="$(tc-getLD)" KERNEL_SOURCE_DIR="${KERNEL_DIR}"'
+BUILD_TARGETS="modules"
+
+CONFIG_CHECK="INPUT_FF_MEMLESS"
+
+src_prepare() {
+ default
+ sed -i "s/@DO_NOT_CHANGE@/v${PV}/" src/version.h || die
+}
+
+src_install() {
+ linux-mod_src_install
+
+ insinto /etc/modprobe.d
+ doins etc-modprobe.d/${PN}.conf
+
+ udev_dorules etc-udev-rules.d/98-${PN}.rules
+
+ dodoc -r ../docs/{[^i]*.md,descriptors,reports} ../NEWS.md
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+ udev_reload
+
+ local ertm=/sys/module/bluetooth/parameters/disable_ertm
+ if ! [[ ${REPLACING_VERSIONS} && $(<${ertm}) == Y ]]; then
+ elog "To pair the gamepad and view module options, see documentation in:"
+ elog " ${EROOT}/usr/share/doc/${PF}"
+ elog
+ elog "Be warned that bluetooth's ERTM (Enhanced ReTransmission Mode) can"
+ elog "cause the gamepad to enter a re-connection loop."
+ elog "- To disable immediately:"
+ elog " echo Y > ${ertm}"
+ elog "- To disable for next and subsequent boot:"
+ elog " echo 'options bluetooth disable_ertm=y' > ${EROOT}/etc/modprobe.d/no-ertm.conf"
+ elog "- Or, if bluetooth isn't a module, add to the kernel's command line:"
+ elog " bluetooth.disable_ertm=y"
+ fi
+}
+
+pkg_postrm() {
+ linux-mod_pkg_postrm
+ udev_reload
+}
diff --git a/games-util/xpadneo/xpadneo-9999.ebuild b/games-util/xpadneo/xpadneo-9999.ebuild
new file mode 100644
index 000000000000..a40a337a9918
--- /dev/null
+++ b/games-util/xpadneo/xpadneo-9999.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-mod toolchain-funcs udev
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/atar-axis/xpadneo.git"
+ EGIT_MIN_CLONE_TYPE="single"
+else
+ SRC_URI="https://github.com/atar-axis/xpadneo/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Advanced Linux Driver for Xbox One Wireless Controller"
+HOMEPAGE="https://atar-axis.github.io/xpadneo/"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+S+="/hid-${PN}"
+MODULE_NAMES="hid-${PN}(kernel/drivers/hid::src)"
+BUILD_PARAMS='V=1 LD="$(tc-getLD)" KERNEL_SOURCE_DIR="${KERNEL_DIR}"'
+BUILD_TARGETS="src/version.h modules"
+
+CONFIG_CHECK="INPUT_FF_MEMLESS"
+
+src_install() {
+ linux-mod_src_install
+
+ insinto /etc/modprobe.d
+ doins etc-modprobe.d/${PN}.conf
+
+ udev_dorules etc-udev-rules.d/98-${PN}.rules
+
+ dodoc -r ../docs/{[^i]*.md,descriptors,reports} ../NEWS.md
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+ udev_reload
+
+ local ertm=/sys/module/bluetooth/parameters/disable_ertm
+ if ! [[ ${REPLACING_VERSIONS} && $(<${ertm}) == Y ]]; then
+ elog "To pair the gamepad and view module options, see documentation in:"
+ elog " ${EROOT}/usr/share/doc/${PF}"
+ elog
+ elog "Be warned that bluetooth's ERTM (Enhanced ReTransmission Mode) can"
+ elog "cause the gamepad to enter a re-connection loop."
+ elog "- To disable immediately:"
+ elog " echo Y > ${ertm}"
+ elog "- To disable for next and subsequent boot:"
+ elog " echo 'options bluetooth disable_ertm=y' > ${EROOT}/etc/modprobe.d/no-ertm.conf"
+ elog "- Or, if bluetooth isn't a module, add to the kernel's command line:"
+ elog " bluetooth.disable_ertm=y"
+ fi
+}
+
+pkg_postrm() {
+ linux-mod_pkg_postrm
+ udev_reload
+}