summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Persson Forsberg <cat@catcream.org>2022-07-05 17:39:16 +0000
committerSam James <sam@gentoo.org>2022-07-15 02:44:23 +0100
commit5a73ea6f8e5b1dc3d10cbb7d34db4ec1bff161ae (patch)
treea9069d73a3b70879c8623e9e5df8e5e00eb6317c /games-util
parentnet-misc/icaclient: add missing die (diff)
downloadgentoo-5a73ea6f8e5b1dc3d10cbb7d34db4ec1bff161ae.tar.gz
gentoo-5a73ea6f8e5b1dc3d10cbb7d34db4ec1bff161ae.tar.bz2
gentoo-5a73ea6f8e5b1dc3d10cbb7d34db4ec1bff161ae.zip
games-util/gamemode: Fix build on musl
This simple patch includes signal.h in daemon/gamemode-context.c to fix building gamemode on musl libc. This has been tested Gentoo musl and Alpine (also Gentoo glibc to ensure no multiple defined symbols/other errors for glibc). > ../daemon/gamemode-context.c: In function 'game_mode_context_auto_expire': > ../daemon/gamemode-context.c:421:29: error: implicit declaration of function 'kill' [-Werror=implicit-function-declaration] > 421 | if (kill(client->pid, 0) != 0) { > | ^~~~ > ../daemon/gamemode-context.c:421:29: warning: nested extern declaration of 'kill' [-Wnested-externs] https://github.com/FeralInteractive/gamemode/pull/368 Signed-off-by: Alfred Persson Forsberg <cat@catcream.org> Closes: https://github.com/gentoo/gentoo/pull/26234 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/gamemode/files/gamemode-1.6.1-signal_h-musl.patch39
-rw-r--r--games-util/gamemode/gamemode-1.6.1.ebuild2
2 files changed, 41 insertions, 0 deletions
diff --git a/games-util/gamemode/files/gamemode-1.6.1-signal_h-musl.patch b/games-util/gamemode/files/gamemode-1.6.1-signal_h-musl.patch
new file mode 100644
index 000000000000..8689157969bc
--- /dev/null
+++ b/games-util/gamemode/files/gamemode-1.6.1-signal_h-musl.patch
@@ -0,0 +1,39 @@
+https://github.com/FeralInteractive/gamemode/pull/368
+
+From 4079d246805e9ce6c1f5ee49116013eb9f5225d7 Mon Sep 17 00:00:00 2001
+From: Alfred Persson Forsberg <cat@catcream.org>
+Date: Tue, 5 Jul 2022 17:18:19 +0000
+Subject: [PATCH] Fix build on musl libc
+
+This simple patch includes signal.h in daemon/gamemode-context.c to fix building gamemode on musl
+libc.
+
+This has been tested Gentoo musl and Alpine (also Gentoo glibc to
+ensure no multiple defined symbols/other errors for glibc).
+
+> ../daemon/gamemode-context.c: In function 'game_mode_context_auto_expire':
+> ../daemon/gamemode-context.c:421:29: error: implicit declaration of function 'kill' [-Werror=implicit-function-declaration]
+> 421 | if (kill(client->pid, 0) != 0) {
+> | ^~~~
+> ../daemon/gamemode-context.c:421:29: warning: nested extern declaration of 'kill' [-Wnested-externs]
+
+Signed-off-by: Alfred Persson Forsberg <cat@catcream.org>
+---
+ daemon/gamemode-context.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/daemon/gamemode-context.c b/daemon/gamemode-context.c
+index 3b5a61b..feba2b1 100644
+--- a/daemon/gamemode-context.c
++++ b/daemon/gamemode-context.c
+@@ -45,6 +45,7 @@ POSSIBILITY OF SUCH DAMAGE.
+ #include <assert.h>
+ #include <fcntl.h>
+ #include <pthread.h>
++#include <signal.h>
+ #include <stdatomic.h>
+ #include <stdlib.h>
+ #include <sys/time.h>
+--
+2.35.1
+
diff --git a/games-util/gamemode/gamemode-1.6.1.ebuild b/games-util/gamemode/gamemode-1.6.1.ebuild
index 1c2a2df1c374..1db1b4752c61 100644
--- a/games-util/gamemode/gamemode-1.6.1.ebuild
+++ b/games-util/gamemode/gamemode-1.6.1.ebuild
@@ -42,6 +42,8 @@ DOCS=(
example/gamemode.ini
)
+PATCHES=( "${FILESDIR}/${PN}-1.6.1-signal_h-musl.patch" )
+
pkg_pretend() {
elog
elog "GameMode needs a kernel capable of SCHED_ISO to use its soft realtime"