summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2020-12-07 22:21:03 +0000
committerJames Le Cuirot <chewi@gentoo.org>2020-12-07 22:57:45 +0000
commitbaf0cece610437ea9dd4a19168da3a2a428d2417 (patch)
tree0ab8ce3ed8988c0094623abc6168c54fb828a0f6 /games-util
parentdev-python/pyftpdlib: skip more unreliable tests (diff)
downloadgentoo-baf0cece610437ea9dd4a19168da3a2a428d2417.tar.gz
gentoo-baf0cece610437ea9dd4a19168da3a2a428d2417.tar.bz2
gentoo-baf0cece610437ea9dd4a19168da3a2a428d2417.zip
games-util/sc-controller: Version bump to 0.4.8.2
Package-Manager: Portage-3.0.12, Repoman-3.0.1 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/sc-controller/Manifest1
-rw-r--r--games-util/sc-controller/sc-controller-0.4.8.2.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/games-util/sc-controller/Manifest b/games-util/sc-controller/Manifest
index 319725439883..38b205222bdc 100644
--- a/games-util/sc-controller/Manifest
+++ b/games-util/sc-controller/Manifest
@@ -1 +1,2 @@
DIST sc-controller-0.4.8.1.tar.gz 2520167 BLAKE2B 40c8e366519ec2a6d80b31c2b342fba2664fa35f3a889e222665f8f5cd4d59dd912804f6cdf4ecd844ab94075f5f45f88a61138ac1c0cb528652c9fd9b710afa SHA512 bc57bd381c71e94c0771ecdb08f95326d0c1478e25cdf3955b71c203abe6cb78091ca977deb8a1e954b5b1b65a6df487f8b8921920b1eb672aa6f1f5554a4847
+DIST sc-controller-0.4.8.2.tar.gz 2520528 BLAKE2B 0c98e1fd49e846909ec0a78c5bbf48731de464ab79ebe3e1b0370e2a6f176e925e6f2b288c17358221b2e50be0cd783f31f05324ac585aec310967d148ce5011 SHA512 8d157e871fa519ebd3eee27dd1c0ff1afe6f79201df12578aa31f3cbc62974bd7ba47c8a097870b693a7abaacaadd1e502012c9664c0aecddbd982fa10c7f84d
diff --git a/games-util/sc-controller/sc-controller-0.4.8.2.ebuild b/games-util/sc-controller/sc-controller-0.4.8.2.ebuild
new file mode 100644
index 000000000000..fd7546b73bf5
--- /dev/null
+++ b/games-util/sc-controller/sc-controller-0.4.8.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1 xdg
+
+DESCRIPTION="User-mode driver and GTK-based GUI for Steam Controllers and others"
+HOMEPAGE="https://github.com/Ryochan7/sc-controller/"
+SRC_URI="https://github.com/Ryochan7/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-2 CC0-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+udev"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/pygobject[${PYTHON_USEDEP},cairo]
+ dev-python/pylibacl[${PYTHON_USEDEP}]
+ dev-python/python-evdev[${PYTHON_USEDEP}]
+ ')
+ gnome-base/librsvg
+ x11-libs/gtk+:3
+ udev? ( games-util/game-device-udev-rules )
+"