summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-09-08 19:49:41 +0300
committerMart Raudsepp <leio@gentoo.org>2019-09-08 19:51:12 +0300
commit06e2701ad6a511383d000b62f9faa2328800762b (patch)
treecf4ff4bb3e6a822166813abd5673f18a997d2fb8 /gnome-base/dconf
parentpackage.mask: Last rite media-video/xanim-export (diff)
downloadgentoo-06e2701ad6a511383d000b62f9faa2328800762b.tar.gz
gentoo-06e2701ad6a511383d000b62f9faa2328800762b.tar.bz2
gentoo-06e2701ad6a511383d000b62f9faa2328800762b.zip
gnome-base/dconf: add back env.d to not break conf if gconf present
Needed for the CONFIG_PROTECT_MASK at least, but also still for GSETTINGS_BACKEND setting, because gnome-base/gconf sets it to gconf in /etc/env.d/50gconf, thus until gconf still sets it, we have to set it in dconf too to override it in the higher numbered env.d entry. Package-Manager: Portage-2.3.69, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gnome-base/dconf')
-rw-r--r--gnome-base/dconf/dconf-0.32.0-r1.ebuild (renamed from gnome-base/dconf/dconf-0.32.0.ebuild)14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnome-base/dconf/dconf-0.32.0.ebuild b/gnome-base/dconf/dconf-0.32.0-r1.ebuild
index 2175d3f9748d..8e9d9a0257d7 100644
--- a/gnome-base/dconf/dconf-0.32.0.ebuild
+++ b/gnome-base/dconf/dconf-0.32.0-r1.ebuild
@@ -42,6 +42,20 @@ src_configure() {
meson_src_configure
}
+src_install() {
+ meson_src_install
+
+ # GSettings backend may be one of: memory, gconf, dconf
+ # Only dconf is really considered functional by upstream
+ # must have it enabled over gconf if both are installed
+ # This snippet can't be removed until gconf package is
+ # ensured to not install a /etc/env.d/50gconf and then
+ # still consider the CONFIG_PROTECT_MASK bit.
+ echo 'CONFIG_PROTECT_MASK="/etc/dconf"' >> 51dconf
+ echo 'GSETTINGS_BACKEND="dconf"' >> 51dconf
+ doenvd 51dconf
+}
+
src_test() {
virtx meson_src_test
}