summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-base/gnome/gnome-3.16.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-base/gnome/gnome-3.16.0.ebuild')
-rw-r--r--gnome-base/gnome/gnome-3.16.0.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/gnome-base/gnome/gnome-3.16.0.ebuild b/gnome-base/gnome/gnome-3.16.0.ebuild
new file mode 100644
index 000000000000..93fbe39c73a8
--- /dev/null
+++ b/gnome-base/gnome/gnome-3.16.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="Meta package for GNOME 3, merge this package to install"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="metapackage"
+SLOT="2.0" # Cannot be installed at the same time as gnome-2
+
+# when unmasking for an arch
+# double check none of the deps are still masked !
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
+
+IUSE="accessibility +bluetooth +classic +cdr cups +extras"
+
+S=${WORKDIR}
+
+# TODO: check accessibility completeness
+# GDM-3.0 integrates very nicely with GNOME Shell
+RDEPEND="
+ >=gnome-base/gnome-core-libs-${PV}[cups?]
+ >=gnome-base/gnome-core-apps-${PV}[cups?,bluetooth?,cdr?]
+
+ >=gnome-base/gdm-${PV}
+
+ >=x11-wm/mutter-${PV}
+ >=gnome-base/gnome-shell-${PV}[bluetooth?]
+
+ >=x11-themes/gnome-backgrounds-${PV}
+ x11-themes/sound-theme-freedesktop
+
+ accessibility? (
+ >=app-accessibility/at-spi2-atk-2.16
+ >=app-accessibility/at-spi2-core-2.16
+ >=app-accessibility/caribou-0.4.18
+ >=app-accessibility/orca-${PV}
+ >=gnome-extra/mousetweaks-3.12.0 )
+ classic? ( >=gnome-extra/gnome-shell-extensions-${PV} )
+ extras? ( >=gnome-base/gnome-extra-apps-${PV} )
+"
+
+DEPEND=""
+
+PDEPEND=">=gnome-base/gvfs-1.24[udisks]"
+
+pkg_postinst() {
+ # Remember people where to find our project information
+ elog "Please remember to look at https://wiki.gentoo.org/wiki/Project:GNOME"
+ elog "for information about the project and documentation."
+}