summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-base/gvfs/gvfs-1.22.4.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-base/gvfs/gvfs-1.22.4.ebuild')
-rw-r--r--gnome-base/gvfs/gvfs-1.22.4.ebuild124
1 files changed, 124 insertions, 0 deletions
diff --git a/gnome-base/gvfs/gvfs-1.22.4.ebuild b/gnome-base/gvfs/gvfs-1.22.4.ebuild
new file mode 100644
index 000000000000..b59111e9fb5f
--- /dev/null
+++ b/gnome-base/gvfs/gvfs-1.22.4.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools bash-completion-r1 eutils gnome2
+
+DESCRIPTION="Virtual filesystem implementation for gio"
+HOMEPAGE="https://git.gnome.org/browse/gvfs"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+
+IUSE="afp archive bluray cdda fuse gnome-online-accounts gphoto2 gtk +http ios libsecret mtp samba systemd test +udev udisks zeroconf"
+REQUIRED_USE="
+ cdda? ( udev )
+ mtp? ( udev )
+ udisks? ( udev )
+ systemd? ( udisks )
+"
+KEYWORDS="alpha amd64 arm ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+
+# Can use libgphoto-2.5.0 as well. Automagic detection.
+RDEPEND="
+ >=dev-libs/glib-2.37:2
+ sys-apps/dbus
+ dev-libs/libxml2:2
+ net-misc/openssh
+ afp? ( >=dev-libs/libgcrypt-1.2.2:0= )
+ archive? ( app-arch/libarchive:= )
+ bluray? ( media-libs/libbluray )
+ fuse? ( >=sys-fs/fuse-2.8.0 )
+ gnome-online-accounts? ( >=net-libs/gnome-online-accounts-3.7.1 )
+ gphoto2? ( >=media-libs/libgphoto2-2.4.7:= )
+ gtk? ( >=x11-libs/gtk+-3.0:3 )
+ http? ( >=net-libs/libsoup-2.42:2.4 )
+ ios? (
+ >=app-pda/libimobiledevice-1.1.5:=
+ >=app-pda/libplist-1:= )
+ libsecret? ( app-crypt/libsecret )
+ mtp? ( >=media-libs/libmtp-1.1.6 )
+ samba? ( || ( >=net-fs/samba-3.4.6[smbclient] >=net-fs/samba-4[client] ) )
+ systemd? ( sys-apps/systemd:0= )
+ udev? (
+ cdda? ( || ( dev-libs/libcdio-paranoia <dev-libs/libcdio-0.90[-minimal] ) )
+ virtual/libgudev:=
+ virtual/libudev:= )
+ udisks? ( >=sys-fs/udisks-1.97:2 )
+ zeroconf? ( >=net-dns/avahi-0.6 )
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+ dev-util/gdbus-codegen
+ dev-util/gtk-doc-am
+ test? (
+ >=dev-python/twisted-core-12.3.0
+ || (
+ net-analyzer/netcat
+ net-analyzer/netcat6 ) )
+ !udev? ( >=dev-libs/libgcrypt-1.2.2:0 )
+"
+# libgcrypt.m4, provided by libgcrypt, needed for eautoreconf, bug #399043
+# test dependencies needed per https://bugzilla.gnome.org/700162
+
+# Tests with multiple failures, this is being handled upstream at:
+# https://bugzilla.gnome.org/700162
+RESTRICT="test"
+
+src_prepare() {
+ DOCS="AUTHORS ChangeLog NEWS MAINTAINERS README TODO" # ChangeLog.pre-1.2 README.commits
+
+ if ! use udev; then
+ sed -e 's/gvfsd-burn/ /' \
+ -e 's/burn.mount.in/ /' \
+ -e 's/burn.mount/ /' \
+ -i daemon/Makefile.am || die
+
+ # Uncomment when eautoreconf stops being needed always
+ #eautoreconf
+ fi
+
+ # Fix parallel installation, bug #543812 (from 'master')
+ epatch "${FILESDIR}/${PN}-1.22.4-fix-parallel.patch"
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # --enable-documentation installs man pages
+ # --disable-obexftp, upstream bug #729945
+ gnome2_src_configure \
+ --enable-bash-completion \
+ --with-bash-completion-dir="$(get_bashcompdir)" \
+ --disable-gdu \
+ --disable-hal \
+ --disable-obexftp \
+ --with-dbus-service-dir="${EPREFIX}"/usr/share/dbus-1/services \
+ --enable-documentation \
+ $(use_enable afp) \
+ $(use_enable archive) \
+ $(use_enable bluray) \
+ $(use_enable cdda) \
+ $(use_enable fuse) \
+ $(use_enable gnome-online-accounts goa) \
+ $(use_enable gphoto2) \
+ $(use_enable gtk) \
+ $(use_enable ios afc) \
+ $(use_enable mtp libmtp) \
+ $(use_enable udev) \
+ $(use_enable udev gudev) \
+ $(use_enable http) \
+ $(use_enable libsecret keyring) \
+ $(use_enable samba) \
+ $(use_enable systemd libsystemd-login) \
+ $(use_enable udisks udisks2) \
+ $(use_enable zeroconf avahi)
+}