summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-03-03 00:51:38 +0200
committerMart Raudsepp <leio@gentoo.org>2019-03-03 01:12:37 +0200
commit7ad78f8523d53cc17e192b1e674972bd935ecb79 (patch)
tree5ae292954f714db5bb006ce85f6954694b778049 /gnome-base/gvfs
parentdev-util/meson: sync live (diff)
downloadgentoo-7ad78f8523d53cc17e192b1e674972bd935ecb79.tar.gz
gentoo-7ad78f8523d53cc17e192b1e674972bd935ecb79.tar.bz2
gentoo-7ad78f8523d53cc17e192b1e674972bd935ecb79.zip
gnome-base/gvfs: bump to 1.38.1
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gnome-base/gvfs')
-rw-r--r--gnome-base/gvfs/Manifest2
-rw-r--r--gnome-base/gvfs/gvfs-1.38.1.ebuild136
-rw-r--r--gnome-base/gvfs/metadata.xml11
3 files changed, 144 insertions, 5 deletions
diff --git a/gnome-base/gvfs/Manifest b/gnome-base/gvfs/Manifest
index bc73af668c44..61f9f27a52bb 100644
--- a/gnome-base/gvfs/Manifest
+++ b/gnome-base/gvfs/Manifest
@@ -2,3 +2,5 @@ DIST gvfs-1.32.2-patchset.tar.xz 22152 BLAKE2B 46371e4da9f3259ae1be6e7900aa9c3fa
DIST gvfs-1.32.2.tar.xz 1820100 BLAKE2B a12209f8d1f1350edfc470bb8181d68172580909764899a20b248e5dca673e5904aef0562f3244336dd8eff66cbae926d4fb2ebcccc30125328e15aeb622b481 SHA512 2fecb7103917f976528a75d317ddb6c9a71c2787cd1bd442c42a40177b74a026e37c9794117f802ebf608091d446ac58eb80d1a618df619180bb3920a98a9457
DIST gvfs-1.34.2.1-patchset.tar.xz 2608 BLAKE2B 1041815fa35e052219df561325bab4a96e9e36c5b3afac70c6bf16f21fe3d72b70edbc59fb9df4b5b266748f6fdeb7358182bffd0eb61572d86c369a57a49bb9 SHA512 1baafda67997265ae5ad0facbdaf1d274fb400fffa3059aad40a9239b20c1362bcaa58e3a751dc575b46c5e71f94e245e625e2b12c2f178acff7d3b0dbf7c3c7
DIST gvfs-1.34.2.1.tar.xz 1822700 BLAKE2B 2de1e86bf9dfe6567c59c7d1e2032f9e749daef0a1deb27963c0b5122be5925256c02a90dae5371bed9e037137400cca8e3461f415b3bed36de4310757bced62 SHA512 ff8d2ebff220e8432584d13640747d54c78c7350c0b8b9ed8544eb311fb4211897fb8473375b246cc1271df507f5ae2dd4edc6d5fd5d2061792377f3f37ebdb1
+DIST gvfs-1.38.1-patchset.tar.xz 37140 BLAKE2B 72174e97097c7ea05569a6a4f0bc29490572bc0215b12dd83014fb742e777b786d22a7da3a0a8404635c83e3094e8f187f568b6cb480ee5b14f0cdd9e6f10d50 SHA512 b14544a0be8d534d32b633cace8dc458dfddcfa2ff6e2076bfd486eda0c5fe3bb9443ddb7b2083a776eab76e93f2266c9d35b45ac0a70a0d31878b284fb3bcd2
+DIST gvfs-1.38.1.tar.xz 1203224 BLAKE2B 42c239163f5040e30c66598afa91ba995267c746792357b93077a84da760ec1242ce7091cedb991712ccf056e8950e92108142c5c4d1b18976f6756bb6100362 SHA512 69b186c9dd2129636109dd46e7b7c34767400266af53fcd701bd1332886ae0be4bb4a72d4543873e7db0dda19f325b384219dff935f749b62cec0a6b36aa3de7
diff --git a/gnome-base/gvfs/gvfs-1.38.1.ebuild b/gnome-base/gvfs/gvfs-1.38.1.ebuild
new file mode 100644
index 000000000000..b89255e7cabd
--- /dev/null
+++ b/gnome-base/gvfs/gvfs-1.38.1.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome.org gnome2-utils meson systemd xdg
+
+DESCRIPTION="Virtual filesystem implementation for GIO"
+HOMEPAGE="https://wiki.gnome.org/Projects/gvfs"
+SRC_URI+=" https://dev.gentoo.org/~leio/distfiles/${P}-patchset.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+
+IUSE="afp archive bluray cdda elogind fuse google gnome-keyring gnome-online-accounts gphoto2 +http ios mtp nfs policykit samba systemd test +udev udisks zeroconf"
+# elogind/systemd only relevant to udisks (in v1.38.1)
+REQUIRED_USE="
+ ?? ( elogind systemd )
+ cdda? ( udev )
+ google? ( gnome-online-accounts )
+ gphoto2? ( udev )
+ mtp? ( udev )
+ udisks? ( udev )
+"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+
+RDEPEND="
+ >=dev-libs/glib-2.57.2:2
+ afp? ( >=dev-libs/libgcrypt-1.2.2:0= )
+ sys-apps/dbus
+ app-crypt/gcr:=
+ policykit? (
+ >=sys-auth/polkit-0.114
+ sys-libs/libcap )
+ http? (
+ dev-libs/libxml2:2
+ >=net-libs/libsoup-2.42.0:2.4 )
+ zeroconf? ( >=net-dns/avahi-0.6 )
+ udev? ( >=virtual/libgudev-147:= )
+ fuse? ( >=sys-fs/fuse-2.8.0:0 )
+ udisks? ( >=sys-fs/udisks-1.97:2 )
+ systemd? ( >=sys-apps/systemd-206:0= )
+ elogind? ( >=sys-auth/elogind-229:0= )
+ ios? (
+ >=app-pda/libimobiledevice-1.2:=
+ >=app-pda/libplist-1:= )
+ gnome-online-accounts? ( >=net-libs/gnome-online-accounts-3.17.1:= )
+ gnome-keyring? ( app-crypt/libsecret )
+ bluray? ( media-libs/libbluray:= )
+ mtp? (
+ >=dev-libs/libusb-1.0.21
+ >=media-libs/libmtp-1.1.15 )
+ samba? ( >=net-fs/samba-4[client] )
+ archive? ( app-arch/libarchive:= )
+ cdda? (
+ dev-libs/libcdio:0=
+ >=dev-libs/libcdio-paranoia-0.78.2 )
+ google? ( >=dev-libs/libgdata-0.17.9:=[crypt,gnome-online-accounts] )
+ gphoto2? ( >=media-libs/libgphoto2-2.5.0:= )
+ nfs? ( >=net-fs/libnfs-1.9.8 )
+ net-misc/openssh
+"
+DEPEND="${RDEPEND}
+ dev-util/glib-utils
+ app-text/docbook-xsl-stylesheets
+ app-text/docbook-xml-dtd:4.2
+ dev-libs/libxslt
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+ dev-util/gdbus-codegen
+"
+
+PATCHES=(
+ "${WORKDIR}"/patches/ # origin/gnome-3-30@20190301
+)
+
+src_configure() {
+ local enable_logind="false"
+ if use systemd || use elogind; then
+ enable_logind="true"
+ fi
+
+ local enable_gcrypt="false"
+ if use afp; then # currently HAVE_GCRYPT and linkage only used with afp; check it on big bumps (grep for HAVE_GCRYPT and enable_gcrypt); adjust depends if changes
+ enable_gcrypt="true"
+ fi
+
+ local enable_libusb="false"
+ if use mtp; then # currently HAVE_LIBUSB and linkage only used with mtp; check it on big bumps (grep for HAVE_LIBUSB and enable_libusb); adjust depends if changes
+ enable_libusb="true"
+ fi
+
+ local emesonargs=(
+ -Dsystemduserunitdir="$(systemd_get_userunitdir)"
+ -Dtmpfilesdir="${EPREFIX}"/usr/lib/tmpfiles.d
+ $(meson_use policykit admin)
+ $(meson_use ios afc)
+ $(meson_use afp)
+ $(meson_use archive)
+ $(meson_use cdda)
+ $(meson_use zeroconf dnssd)
+ $(meson_use gnome-online-accounts goa)
+ $(meson_use google)
+ $(meson_use gphoto2)
+ $(meson_use http)
+ $(meson_use mtp)
+ $(meson_use nfs)
+ -Dsftp=true
+ $(meson_use samba smb)
+ $(meson_use udisks udisks2)
+ $(meson_use bluray)
+ $(meson_use fuse)
+ -Dgcr=true
+ -Dgcrypt=${enable_gcrypt}
+ $(meson_use udev gudev)
+ $(meson_use gnome-keyring keyring)
+ -Dlogind=${enable_logind}
+ -Dlibusb=${enable_libusb}
+ -Ddevel_utils=false # wouldn't install any of it as of 1.38.1; some tests need it, but they aren't automated tests in v1.38.1
+ -Dinstalled_tests=false
+ -Dman=true
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ gnome2_giomodule_cache_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+ gnome2_giomodule_cache_update
+}
diff --git a/gnome-base/gvfs/metadata.xml b/gnome-base/gvfs/metadata.xml
index d26195bc7e44..ca9b9b73c21b 100644
--- a/gnome-base/gvfs/metadata.xml
+++ b/gnome-base/gvfs/metadata.xml
@@ -6,11 +6,12 @@
<name>Gentoo GNOME Desktop</name>
</maintainer>
<longdescription lang="en">
-gvfs is a userspace virtual filesystem designed to work with the i/o
-abstractions of gio (a library availible in glib &gt;= 2.15.1). It
-installs several modules that are automatically used by applications
-using the APIs of libgio. There is also fuse support that allows
-applications not using gio to access the gvfs filesystems.
+GVfs is a userspace virtual filesystem implementation for GIO (a library
+available in GLib). GVfs comes with a set of backends, including trash
+support, SFTP, SMB, HTTP, DAV, and many others. GVfs also contains modules
+for GIO that implement volume monitors and persistent metadata storage.
+There is also FUSE support that provides limited access to the GVfs
+filesystems for applications not using GIO.
</longdescription>
<use>
<flag name="afp">Enables support for accessing AFP (Apple Filing Protocol) network shares</flag>