summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-09-14 11:47:59 +0300
committerMart Raudsepp <leio@gentoo.org>2018-09-14 11:50:42 +0300
commiteb077804c03ab227767726bfd7452d0b1c6d2d1d (patch)
tree76bc8e36400ce533993451214673ab9a5d31803e /gnome-base/libgnomekbd
parentgames-puzzle/hitori: remove wrong yelp-tools build depend (diff)
downloadgentoo-eb077804c03ab227767726bfd7452d0b1c6d2d1d.tar.gz
gentoo-eb077804c03ab227767726bfd7452d0b1c6d2d1d.tar.bz2
gentoo-eb077804c03ab227767726bfd7452d0b1c6d2d1d.zip
gnome-base/libgnomekbd: bump to 3.26.0
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'gnome-base/libgnomekbd')
-rw-r--r--gnome-base/libgnomekbd/Manifest1
-rw-r--r--gnome-base/libgnomekbd/libgnomekbd-3.26.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/gnome-base/libgnomekbd/Manifest b/gnome-base/libgnomekbd/Manifest
index 7e83ffc3a35a..ff2a45473f6e 100644
--- a/gnome-base/libgnomekbd/Manifest
+++ b/gnome-base/libgnomekbd/Manifest
@@ -1 +1,2 @@
DIST libgnomekbd-3.22.0.1.tar.xz 450572 BLAKE2B cc7c0055dfae0c0593d9456e3de27da8cb33d9814151346a4a685a317f7701658392e6a403e942ceb928ebd9c06d0ba3b38c0f7f1abd08976c807d48d0246b58 SHA512 a4d2e6feac18cb7e3a65553dcd587f284c71154d3058866b0b6285b1acca549d33d0bd0014a97f1e153eb5e2a5a16e8b18eb680ce0078edd80bdd68a51ac080e
+DIST libgnomekbd-3.26.0.tar.xz 449204 BLAKE2B 360f6da6ea7ad2850ecba062e0825cadcbc62ab9fdd432ad1fd4f38d32230e9eb6da1b7eb50116302b39be76565da7554df2c96e3a348e5130c428158bfa7792 SHA512 dc3ee91468e570d038bc91c4458ddb49dc097639c671815eecc4308efea85e29c1121cfd959e62f970a2e8112f818296802be804e99b96ee89fd5de8136645d9
diff --git a/gnome-base/libgnomekbd/libgnomekbd-3.26.0.ebuild b/gnome-base/libgnomekbd/libgnomekbd-3.26.0.ebuild
new file mode 100644
index 000000000000..847b3a6a86d4
--- /dev/null
+++ b/gnome-base/libgnomekbd/libgnomekbd-3.26.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2
+
+DESCRIPTION="Gnome keyboard configuration library"
+HOMEPAGE="https://www.gnome.org"
+
+LICENSE="LGPL-2+"
+SLOT="0/8"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="+introspection test"
+
+RDEPEND="
+ >=dev-libs/glib-2.18:2
+ >=x11-libs/gtk+-2.91.7:3[X,introspection?]
+ >=x11-libs/libxklavier-5.2[introspection?]
+
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+"
+DEPEND="${RDEPEND}
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection) \
+ $(use_enable test tests)
+}