summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-11-10 22:41:07 -0500
committerMatt Turner <mattst88@gentoo.org>2020-11-10 23:09:00 -0500
commitb9c704ae1c532129a1e143502e0e7748432b9065 (patch)
treebe19eef0a3588bfa2f3adc2c4c9d7a573526fdc3 /gnome-base
parentgnome-extra/gnome-shell-extensions: Version bump to 3.38.1 (diff)
downloadgentoo-b9c704ae1c532129a1e143502e0e7748432b9065.tar.gz
gentoo-b9c704ae1c532129a1e143502e0e7748432b9065.tar.bz2
gentoo-b9c704ae1c532129a1e143502e0e7748432b9065.zip
gnome-base/gnome-settings-daemon: Version bump to 3.38.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gnome-settings-daemon/Manifest1
-rw-r--r--gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.38.1-Allow-udev-optional-on-Linux.patch134
-rw-r--r--gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.38.1-build-Allow-NM-optional-on-Linux.patch24
-rw-r--r--gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.38.1-build-Make-colord-and-wacom-optional-and-controllabl.patch76
-rw-r--r--gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.38.1.ebuild136
5 files changed, 371 insertions, 0 deletions
diff --git a/gnome-base/gnome-settings-daemon/Manifest b/gnome-base/gnome-settings-daemon/Manifest
index ca2145d39f6e..b4a95e33023c 100644
--- a/gnome-base/gnome-settings-daemon/Manifest
+++ b/gnome-base/gnome-settings-daemon/Manifest
@@ -1,2 +1,3 @@
DIST gnome-settings-daemon-3.36.1-patchset.tar.xz 79352 BLAKE2B 6daf9528f5aa4c6597a017f25da41039dd2c09b4a1c29dca2d72f20195bb93c9003de39df89a669996e13050538553fbf6ed4f738b1c6fae29e8825ba252d26a SHA512 fea4ecaadac102b0024c365ae2ba9e632ffeebab138bfc09b3f5bb0a7794c6efc779180023a73c6c884c7b64f7e8ac1ec40f1478231a5528c03829cd9273a58e
DIST gnome-settings-daemon-3.36.1.tar.xz 1415080 BLAKE2B 4026f3443b8dcab872ef54563b5fe8e89d6932373da0513d7d8c614616d396315f1e6a8d0be022aec82351b5cfe5868cbac5caeaa782d609885029fbbd1d91e3 SHA512 f2f43d9b772589b6b4212ee2b0afe8be79d50a2e0473a960c7a7b9d379222bbe84ca548114d0a247810a094b4b3bf41e40ca91173c6cf552517dc63eb3750c88
+DIST gnome-settings-daemon-3.38.1.tar.xz 1437096 BLAKE2B dddc4672585c23f1d0f1824303b503ec30d6fc4a2a88b9633e0256d34ca2badd067fa54a404de032f8b2e8dd5b7bfa3915464bc826d8bbea5d57431b7a2ac7fe SHA512 b32c0897d1a5680747bf68e9009ea44cf1a05ef807b772ca6514a278002754d520def7bced929b9004d3aec82a6e82b52637bd2eadd3f6cd54f3d0ac5c8e8cbd
diff --git a/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.38.1-Allow-udev-optional-on-Linux.patch b/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.38.1-Allow-udev-optional-on-Linux.patch
new file mode 100644
index 000000000000..658f4a3f48ee
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.38.1-Allow-udev-optional-on-Linux.patch
@@ -0,0 +1,134 @@
+From 6a44d3a6741da48d769353023c8801d41c969663 Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Sun, 12 Jul 2020 16:30:59 +0300
+Subject: [PATCH 3/3] Allow udev optional on Linux
+
+---
+ meson.build | 4 ----
+ plugins/power/gsd-backlight.c | 14 +++++++-------
+ plugins/power/meson.build | 6 +++---
+ 3 files changed, 10 insertions(+), 14 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index 21d9341d..0a527513 100644
+--- a/meson.build
++++ b/meson.build
+@@ -138,9 +138,6 @@ if enable_gudev
+ gudev_dep = dependency('gudev-1.0')
+ endif
+ config_h.set10('HAVE_GUDEV', enable_gudev)
+-if host_is_linux
+- assert(enable_gudev, 'GUdev is not optional on Linux platforms')
+-endif
+
+ # Check for colord
+ enable_colord = get_option('colord')
+@@ -203,7 +200,6 @@ endif
+
+ # Rfkill
+ enable_rfkill = get_option('rfkill')
+-assert(enable_rfkill or not host_is_linux, 'rfkill is not optional on Linux platforms')
+ if enable_rfkill
+ assert(cc.has_header('linux/rfkill.h'), 'rfkill support requested but RFKill headers not found')
+ assert(enable_gudev, 'GUdev is required for rfkill support')
+diff --git a/plugins/power/gsd-backlight.c b/plugins/power/gsd-backlight.c
+index ca5f2723..f58f5343 100644
+--- a/plugins/power/gsd-backlight.c
++++ b/plugins/power/gsd-backlight.c
+@@ -25,7 +25,7 @@
+ #include "gsd-power-constants.h"
+ #include "gsd-power-manager.h"
+
+-#ifdef __linux__
++#if defined(__linux__) && defined(HAVE_GUDEV)
+ #include <gudev/gudev.h>
+ #endif /* __linux__ */
+
+@@ -39,7 +39,7 @@ struct _GsdBacklight
+ gint brightness_target;
+ gint brightness_step;
+
+-#ifdef __linux__
++#if defined(__linux__) && defined(HAVE_GUDEV)
+ GDBusProxy *logind_proxy;
+
+ GUdevClient *udev;
+@@ -77,7 +77,7 @@ G_DEFINE_TYPE_EXTENDED (GsdBacklight, gsd_backlight, G_TYPE_OBJECT, 0,
+ G_IMPLEMENT_INTERFACE (G_TYPE_INITABLE,
+ gsd_backlight_initable_iface_init);)
+
+-#ifdef __linux__
++#if defined(__linux__) && defined(HAVE_GUDEV)
+ static GUdevDevice*
+ gsd_backlight_udev_get_type (GList *devices, const gchar *type)
+ {
+@@ -478,7 +478,7 @@ gsd_backlight_set_brightness_val_async (GsdBacklight *backlight,
+
+ task = g_task_new (backlight, cancellable, callback, user_data);
+
+-#ifdef __linux__
++#if defined(__linux__) && defined(HAVE_GUDEV)
+ if (backlight->udev_device != NULL) {
+ BacklightHelperData *task_data;
+
+@@ -831,7 +831,7 @@ gsd_backlight_initable_init (GInitable *initable,
+ return FALSE;
+ }
+
+-#ifdef __linux__
++#if defined(__linux__) && defined(HAVE_GUDEV)
+ backlight->logind_proxy =
+ g_dbus_proxy_new_for_bus_sync (G_BUS_TYPE_SYSTEM,
+ 0,
+@@ -908,7 +908,7 @@ gsd_backlight_finalize (GObject *object)
+ {
+ GsdBacklight *backlight = GSD_BACKLIGHT (object);
+
+-#ifdef __linux__
++#if defined(__linux__) && defined(HAVE_GUDEV)
+ g_assert (backlight->active_task == NULL);
+ g_assert (g_queue_is_empty (&backlight->tasks));
+ g_clear_object (&backlight->logind_proxy);
+@@ -961,7 +961,7 @@ gsd_backlight_init (GsdBacklight *backlight)
+ backlight->brightness_val = -1;
+ backlight->brightness_step = 1;
+
+-#ifdef __linux__
++#if defined(__linux__) && defined(HAVE_GUDEV)
+ backlight->active_task = NULL;
+ g_queue_init (&backlight->tasks);
+ #endif /* __linux__ */
+diff --git a/plugins/power/meson.build b/plugins/power/meson.build
+index 69e619f2..6c6ea939 100644
+--- a/plugins/power/meson.build
++++ b/plugins/power/meson.build
+@@ -24,7 +24,7 @@ native_deps = [
+ dependency('gio-2.0', native:true)
+ ]
+
+-if host_is_linux
++if host_is_linux and enable_gudev
+ deps += gudev_dep
+ endif
+
+@@ -66,7 +66,7 @@ gsd_power_enums_update = executable(
+ native: true
+ )
+
+-if host_is_linux
++if host_is_linux and enable_gudev
+ policy = 'org.gnome.settings-daemon.plugins.power.policy'
+
+ policy_in = configure_file(
+@@ -130,7 +130,7 @@ envs.set('BUILDDIR', meson.current_build_dir())
+ envs.set('TOP_BUILDDIR', meson.build_root())
+ envs.set('LD_PRELOAD', 'libumockdev-preload.so.0')
+ envs.set('NO_AT_BRIDGE', '1')
+-envs.set('HAVE_SYSFS_BACKLIGHT', host_is_linux ? '1' : '0')
++envs.set('HAVE_SYSFS_BACKLIGHT', (host_is_linux and enable_gudev) ? '1' : '0')
+
+ if get_option('b_sanitize').split(',').contains('address')
+ # libasan needs to be loaded first; so we need to explicitly preload it
+--
+2.26.2
+
diff --git a/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.38.1-build-Allow-NM-optional-on-Linux.patch b/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.38.1-build-Allow-NM-optional-on-Linux.patch
new file mode 100644
index 000000000000..e6b22b301a0d
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.38.1-build-Allow-NM-optional-on-Linux.patch
@@ -0,0 +1,24 @@
+From b5b933cf83fc79cc9dd382ddb0ec2567330e24e8 Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Sun, 8 Sep 2019 18:07:12 +0300
+Subject: [PATCH 2/3] build: Allow NM optional on Linux
+
+---
+ meson.build | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index dce9bfa1..21d9341d 100644
+--- a/meson.build
++++ b/meson.build
+@@ -223,7 +223,6 @@ endif
+
+ # Sharing plugin
+ enable_network_manager = get_option('network_manager')
+-assert(enable_network_manager or not host_is_linux, 'NetworkManager support is not optional on Linux platforms')
+ if enable_network_manager
+ # network manager
+ libnm_dep = dependency('libnm', version: '>= 1.0')
+--
+2.26.2
+
diff --git a/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.38.1-build-Make-colord-and-wacom-optional-and-controllabl.patch b/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.38.1-build-Make-colord-and-wacom-optional-and-controllabl.patch
new file mode 100644
index 000000000000..b48007d29848
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.38.1-build-Make-colord-and-wacom-optional-and-controllabl.patch
@@ -0,0 +1,76 @@
+From 0cc1c2f5f5d12169acbb965a21b5d9f6fb4a0767 Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Thu, 14 Mar 2019 09:43:00 +0200
+Subject: [PATCH 1/3] build: Make colord and wacom optional and controllable
+ via meson_options
+
+---
+ meson.build | 10 ++++++++--
+ meson_options.txt | 2 ++
+ plugins/meson.build | 4 ++++
+ 3 files changed, 14 insertions(+), 2 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index 7dbee64b..dce9bfa1 100644
+--- a/meson.build
++++ b/meson.build
+@@ -142,6 +142,12 @@ if host_is_linux
+ assert(enable_gudev, 'GUdev is not optional on Linux platforms')
+ endif
+
++# Check for colord
++enable_colord = get_option('colord')
++if enable_colord
++ colord_dep = dependency('colord', version: '>= 1.3.5')
++endif
++
+ has_timerfd_create = cc.has_function('timerfd_create')
+ config_h.set10('HAVE_TIMERFD', has_timerfd_create)
+
+@@ -154,8 +160,8 @@ if enable_wayland
+ endif
+ config_h.set10('HAVE_WAYLAND', enable_wayland)
+
+-# wacom (disabled for s390/s390x and non Linux platforms)
+-enable_wacom = host_is_linux_not_s390
++# wacom
++enable_wacom = get_option('wacom')
+ if enable_wacom
+ assert(enable_gudev, 'GUDev support is required for wacom support.')
+ libwacom_dep = dependency('libwacom', version: '>= 0.7')
+diff --git a/meson_options.txt b/meson_options.txt
+index 3e04cf64..6f6eb2fc 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -4,11 +4,13 @@ option('systemd', type: 'boolean', value: true, description: 'Enable systemd int
+
+ option('alsa', type: 'boolean', value: true, description: 'build with ALSA support (not optional on Linux platforms)')
+ option('gudev', type: 'boolean', value: true, description: 'build with gudev device support (not optional on Linux platforms)')
++option('colord', type: 'boolean', value: true, description: 'build with colord support')
+ option('cups', type: 'boolean', value: true, description: 'build with CUPS support')
+ option('network_manager', type: 'boolean', value: true, description: 'build with NetworkManager support (not optional on Linux platforms)')
+ option('rfkill', type: 'boolean', value: true, description: 'build with rfkill support (not optional on Linux platforms)')
+ option('smartcard', type: 'boolean', value: true, description: 'build with smartcard support')
+ option('usb-protection', type: 'boolean', value: true, description: 'build with usb-protection support')
++option('wacom', type: 'boolean', value: true, description: 'build with Wacom devices support')
+ option('wayland', type: 'boolean', value: true, description: 'build with Wayland support')
+ option('wwan', type: 'boolean', value: true, description: 'build with WWAN support')
+ option('colord', type: 'boolean', value: true, description: 'build with colord support')
+diff --git a/plugins/meson.build b/plugins/meson.build
+index 83e01885..20ccb26d 100644
+--- a/plugins/meson.build
++++ b/plugins/meson.build
+@@ -20,6 +20,10 @@ all_plugins = [
+
+ disabled_plugins = []
+
++if not enable_colord
++ disabled_plugins += ['color']
++endif
++
+ if not enable_smartcard
+ disabled_plugins += ['smartcard']
+ endif
+--
+2.26.2
+
diff --git a/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.38.1.ebuild b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.38.1.ebuild
new file mode 100644
index 000000000000..ce585ea54bab
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.38.1.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit gnome.org gnome2-utils python-any-r1 meson udev virtualx xdg
+
+DESCRIPTION="Gnome Settings Daemon"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-settings-daemon"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+IUSE="+colord +cups debug elogind input_devices_wacom modemmanager networkmanager smartcard systemd test +udev wayland"
+REQUIRED_USE="
+ ^^ ( elogind systemd )
+ input_devices_wacom? ( udev )
+ wayland? ( udev )
+"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+
+DEPEND="
+ >=sci-geosciences/geocode-glib-3.10
+ >=dev-libs/glib-2.56:2
+ >=gnome-base/gnome-desktop-3.34.2:3=
+ >=gnome-base/gsettings-desktop-schemas-3.35.91
+ >=x11-libs/gtk+-3.15.3:3[X,wayland?]
+ >=dev-libs/libgweather-3.9.5:2=
+ colord? (
+ >=x11-misc/colord-1.3.5:=
+ >=media-libs/lcms-2.2:2 )
+ media-libs/libcanberra[gtk3]
+ >=app-misc/geoclue-2.3.1:2.0
+ >=x11-libs/libnotify-0.7.3
+ >=media-sound/pulseaudio-2[glib]
+ >=sys-auth/polkit-0.114
+ >=sys-power/upower-0.99.8:=
+ x11-libs/libX11
+ udev? ( dev-libs/libgudev:= )
+ wayland? ( dev-libs/wayland )
+ input_devices_wacom? ( >=dev-libs/libwacom-0.7
+ >=x11-libs/pango-1.20.0
+ x11-libs/gdk-pixbuf:2 )
+ smartcard? ( >=dev-libs/nss-3.11.2 )
+ cups? ( >=net-print/cups-1.4[dbus] )
+ modemmanager? ( >=app-crypt/gcr-3.7.5:=
+ >=net-misc/modemmanager-1.0:= )
+ networkmanager? ( >=net-misc/networkmanager-1.0 )
+ media-libs/alsa-lib
+ x11-libs/libXi
+ x11-libs/libXext
+ media-libs/fontconfig
+ systemd? ( >=sys-apps/systemd-243
+ sys-apps/dbus[user-session] )
+"
+# logind needed for power and session management, bug #464944
+# gnome-session-3.33.90/gdm-3.33.90/gnome-shell-extensions-3.34.1/gnome-flashback-3.33.1 adapt to Clipboard and Mouse component removals (moved to mutter)
+RDEPEND="${DEPEND}
+ gnome-base/dconf
+ elogind? ( sys-auth/elogind )
+ !<gnome-base/gnome-session-3.33.90
+ !<gnome-base/gdm-3.33.90
+ !<gnome-extra/gnome-shell-extensions-3.34.1
+ !<gnome-base/gnome-flashback-3.33.1
+"
+# rfkill requires linux/rfkill.h (and USE=udev), thus linux-headers dep, not os-headers. If this package wants to work on other kernels, we need to make rfkill conditional instead
+BDEPEND="
+ sys-kernel/linux-headers
+ dev-util/glib-utils
+ dev-util/gdbus-codegen
+ x11-base/xorg-proto
+ ${PYTHON_DEPS}
+ test? (
+ $(python_gen_any_dep 'dev-python/pygobject:3[${PYTHON_USEDEP}]')
+ $(python_gen_any_dep 'dev-python/dbusmock[${PYTHON_USEDEP}]')
+ gnome-base/gnome-session )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-build-Make-colord-and-wacom-optional-and-controllabl.patch
+ "${FILESDIR}"/${P}-build-Allow-NM-optional-on-Linux.patch
+ "${FILESDIR}"/${P}-Allow-udev-optional-on-Linux.patch
+)
+
+python_check_deps() {
+ if use test; then
+ has_version "dev-python/pygobject:3[${PYTHON_USEDEP}]" &&
+ has_version "dev-python/dbusmock[${PYTHON_USEDEP}]"
+ fi
+}
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ #-Dnssdb_dir # TODO: Is the default /etc/pki/nssdb path correct for our nss?
+ -Dudev_dir="$(get_udevdir)"
+ $(meson_use systemd)
+ -Dalsa=true
+ $(meson_use udev gudev)
+ $(meson_use colord)
+ $(meson_use cups)
+ $(meson_use networkmanager network_manager)
+ $(meson_use udev rfkill)
+ $(meson_use smartcard)
+ $(meson_use input_devices_wacom wacom)
+ $(meson_use wayland)
+ $(meson_use modemmanager wwan)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ # Don't auto-suspend by default on AC power
+ insinto /usr/share/glib-2.0/schemas
+ doins "${FILESDIR}"/org.gnome.settings-daemon.plugins.power.gschema.override
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}