summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKristian Fiskerstrand <k_f@gentoo.org>2016-11-22 21:39:15 +0100
committerKristian Fiskerstrand <k_f@gentoo.org>2016-11-22 21:42:04 +0100
commit6a7138b9e1147cb7a248752382b9fc1a6d1d87de (patch)
tree11e59b3dfd1224dd749a3a18220b2e9881f88313 /gnome-extra/cinnamon-menus/cinnamon-menus-3.2.0.ebuild
parentgnome-extra/cinnamon-desktop: New upstream version 3.2.0 (diff)
downloadgentoo-6a7138b9e1147cb7a248752382b9fc1a6d1d87de.tar.gz
gentoo-6a7138b9e1147cb7a248752382b9fc1a6d1d87de.tar.bz2
gentoo-6a7138b9e1147cb7a248752382b9fc1a6d1d87de.zip
gnome-extra/cinnamon-menus: New upstream version 3.2.0
Package-Manager: portage-2.3.2
Diffstat (limited to 'gnome-extra/cinnamon-menus/cinnamon-menus-3.2.0.ebuild')
-rw-r--r--gnome-extra/cinnamon-menus/cinnamon-menus-3.2.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnome-extra/cinnamon-menus/cinnamon-menus-3.2.0.ebuild b/gnome-extra/cinnamon-menus/cinnamon-menus-3.2.0.ebuild
new file mode 100644
index 000000000000..4cc55fc4bb41
--- /dev/null
+++ b/gnome-extra/cinnamon-menus/cinnamon-menus-3.2.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools gnome2
+
+DESCRIPTION="Cinnamon's library for the Desktop Menu fd.o specification"
+HOMEPAGE="http://cinnamon.linuxmint.com/"
+SRC_URI="https://github.com/linuxmint/cinnamon-menus/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.29.15:2
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+"
+DEPEND="${RDEPEND}
+ dev-libs/gobject-introspection-common
+ >=dev-util/intltool-0.40
+ gnome-base/gnome-common
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(usex debug --enable-debug=yes ' ') \
+ $(use_enable introspection) \
+ --disable-static
+}