summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-extra/eiciel
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-extra/eiciel')
-rw-r--r--gnome-extra/eiciel/Manifest2
-rw-r--r--gnome-extra/eiciel/eiciel-0.9.8.2.ebuild35
-rw-r--r--gnome-extra/eiciel/eiciel-0.9.9.ebuild35
-rw-r--r--gnome-extra/eiciel/metadata.xml5
4 files changed, 77 insertions, 0 deletions
diff --git a/gnome-extra/eiciel/Manifest b/gnome-extra/eiciel/Manifest
new file mode 100644
index 000000000000..35091e6e9204
--- /dev/null
+++ b/gnome-extra/eiciel/Manifest
@@ -0,0 +1,2 @@
+DIST eiciel-0.9.8.2.tar.bz2 648067 SHA256 fd99837a57adf83767765a4f096ae81c0af7e33f81df24c55c304b3b649c2079 SHA512 b50479f10d7516ecee2880a03d49ba0d5b13914b3c417f34f960fe7e28aefd0779650915326473180ec19d4c7b6a5998da603c9ccd90a05558521465f99aa9cb WHIRLPOOL 3cd792ca0fed6799a811a92205f32f2b208d684c4a8840cdc5baa8f4825ff55e29885999c0206fbb05ff4e02941f2b71ed2ccce959e1a9a81f7de810b928c229
+DIST eiciel-0.9.9.tar.bz2 647313 SHA256 c87635f15b381ae912d8d015badf9c0d1428c9a766383399c1351eb02e5b479b SHA512 d2031cdc479851ce207000251dcef9121501f8447b60d37fad9f0fe940bfde0e775443f6988f058e565920089cfacf007461f3c8b5a4146f779f9a22396ac7e9 WHIRLPOOL 4eebbab5a5847fd9f3ec6f937dae7a09a000b1b7d232cd366cf9dba6a7f479b16265bf0ba5ce8f5c5d6f36636007f33e3a5bef4a459523b737e83151a33a4fed
diff --git a/gnome-extra/eiciel/eiciel-0.9.8.2.ebuild b/gnome-extra/eiciel/eiciel-0.9.8.2.ebuild
new file mode 100644
index 000000000000..56c1bd7e19b7
--- /dev/null
+++ b/gnome-extra/eiciel/eiciel-0.9.8.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="ACL editor for GNOME, with Nautilus extension"
+HOMEPAGE="http://rofi.roger-ferrer.org/eiciel/"
+SRC_URI="http://rofi.roger-ferrer.org/eiciel/download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="xattr"
+
+RDEPEND="
+ >=sys-apps/acl-2.2.32
+ >=dev-cpp/gtkmm-3:3.0
+ >=gnome-base/nautilus-3
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.18.1
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --with-gnome-version=3 \
+ $(use_enable xattr user-attributes)
+}
diff --git a/gnome-extra/eiciel/eiciel-0.9.9.ebuild b/gnome-extra/eiciel/eiciel-0.9.9.ebuild
new file mode 100644
index 000000000000..56c1bd7e19b7
--- /dev/null
+++ b/gnome-extra/eiciel/eiciel-0.9.9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="ACL editor for GNOME, with Nautilus extension"
+HOMEPAGE="http://rofi.roger-ferrer.org/eiciel/"
+SRC_URI="http://rofi.roger-ferrer.org/eiciel/download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="xattr"
+
+RDEPEND="
+ >=sys-apps/acl-2.2.32
+ >=dev-cpp/gtkmm-3:3.0
+ >=gnome-base/nautilus-3
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.18.1
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --with-gnome-version=3 \
+ $(use_enable xattr user-attributes)
+}
diff --git a/gnome-extra/eiciel/metadata.xml b/gnome-extra/eiciel/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/gnome-extra/eiciel/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>