summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2019-02-23 12:54:17 +0100
committerPacho Ramos <pacho@gentoo.org>2019-02-23 12:54:47 +0100
commit766cd1d201c98a15b7ea2e0d01dd50947fcc78c3 (patch)
tree220c89dbaaa0a9e5245d20c7f1a30517e84dbf30 /gnome-extra/eiciel
parentapp-text/aiksaurus: Fix format-security, drop .la files (diff)
downloadgentoo-766cd1d201c98a15b7ea2e0d01dd50947fcc78c3.tar.gz
gentoo-766cd1d201c98a15b7ea2e0d01dd50947fcc78c3.tar.bz2
gentoo-766cd1d201c98a15b7ea2e0d01dd50947fcc78c3.zip
gnome-extra/eiciel: Multiple fixes
- nautilus extension is optional - Build system takes care of adding -std=c++11 when needed - Fix xattr header (#655744) - gvfs looks to not be directly used Closes: https://bugs.gentoo.org/655744 Closes: https://bugs.gentoo.org/565446 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra/eiciel')
-rw-r--r--gnome-extra/eiciel/eiciel-0.9.12.1-r1.ebuild40
-rw-r--r--gnome-extra/eiciel/files/eiciel-0.9.12.1-xattr-header.patch41
-rw-r--r--gnome-extra/eiciel/metadata.xml3
3 files changed, 84 insertions, 0 deletions
diff --git a/gnome-extra/eiciel/eiciel-0.9.12.1-r1.ebuild b/gnome-extra/eiciel/eiciel-0.9.12.1-r1.ebuild
new file mode 100644
index 000000000000..5949d07e8567
--- /dev/null
+++ b/gnome-extra/eiciel/eiciel-0.9.12.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_EAUTORECONF="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="ACL editor for GNOME, with Nautilus extension"
+HOMEPAGE="http://rofi.roger-ferrer.org/eiciel/"
+SRC_URI="http://rofi.roger-ferrer.org/eiciel/download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nautilus xattr"
+
+RDEPEND="
+ >=sys-apps/acl-2.2.32
+ dev-cpp/gtkmm:3.0
+ nautilus? ( >=gnome-base/nautilus-3 )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.18.1
+"
+
+PATCHES=(
+ # attr/xattr.h is deprecated. Use sys/xattr.h instead (from 'master')
+ "${FILESDIR}"/${P}-xattr-header.patch
+)
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --with-gnome-version=3 \
+ $(use_enable nautilus nautilus-extension) \
+ $(use_enable xattr user-attributes)
+}
diff --git a/gnome-extra/eiciel/files/eiciel-0.9.12.1-xattr-header.patch b/gnome-extra/eiciel/files/eiciel-0.9.12.1-xattr-header.patch
new file mode 100644
index 000000000000..1b866f4bb75f
--- /dev/null
+++ b/gnome-extra/eiciel/files/eiciel-0.9.12.1-xattr-header.patch
@@ -0,0 +1,41 @@
+From cf7e97ece39994d9c219bf3d4f3f70815e1c0867 Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Tue, 15 May 2018 13:40:37 +0200
+Subject: [PATCH] attr/xattr.h is deprecated. Use sys/xattr.h instead
+
+See also:
+http://git.savannah.nongnu.org/cgit/attr.git/commit/?id=7921157890d07858d092f4003ca4c6bae9fd2c38
+---
+ configure.ac | 2 +-
+ src/xattr_manager.hpp | 5 ++++-
+ 2 files changed, 5 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 040e88f..bc769f3 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -156,7 +156,7 @@ fi
+
+ if test x$enable_eua = xyes;
+ then
+- AC_CHECK_HEADERS([attr/xattr.h], [], AC_MSG_ERROR([This header is mandatory for extended user attributes support]), [])
++ AC_CHECK_HEADERS([sys/xattr.h], [], AC_MSG_ERROR([This header is mandatory for extended user attributes support]), [])
+ AC_DEFINE([ENABLE_USER_XATTR], [1], [Enables user extended attributes support])
+ fi
+ AM_CONDITIONAL(ENABLE_USER_XATTR, test x$enable_eua = xyes)
+diff --git a/src/xattr_manager.hpp b/src/xattr_manager.hpp
+index 5f59e17..3d41443 100644
+--- a/src/xattr_manager.hpp
++++ b/src/xattr_manager.hpp
+@@ -26,7 +26,10 @@
+ #include <sys/stat.h>
+ #include <unistd.h>
+
+-#include <attr/xattr.h>
++#include <sys/xattr.h>
++#ifndef ENOATTR
++#define ENOATTR ENODATA
++#endif
+
+ #include <string>
+ #include <cstring>
diff --git a/gnome-extra/eiciel/metadata.xml b/gnome-extra/eiciel/metadata.xml
index 39980802b1da..0038ff872823 100644
--- a/gnome-extra/eiciel/metadata.xml
+++ b/gnome-extra/eiciel/metadata.xml
@@ -5,4 +5,7 @@
<email>gnome@gentoo.org</email>
<name>Gentoo GNOME Desktop</name>
</maintainer>
+<use>
+ <flag name="nautilus">Build gnome-base/nautilus extension</flag>
+</use>
</pkgmetadata>