summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-04-18 18:20:26 -0400
committerMatt Turner <mattst88@gentoo.org>2021-04-18 18:39:38 -0400
commited0d65478065acc6500d8e61792f457f57c96db1 (patch)
treedbd4b58d59831fcffc3f7846291507aa0cb7a83c /gnome-extra/eiciel
parentdev-games/flatzebra: Drop 0.1.6, EAPI5-- (diff)
downloadgentoo-ed0d65478065acc6500d8e61792f457f57c96db1.tar.gz
gentoo-ed0d65478065acc6500d8e61792f457f57c96db1.tar.bz2
gentoo-ed0d65478065acc6500d8e61792f457f57c96db1.zip
gnome-extra/eiciel: Version bump to 0.9.13
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra/eiciel')
-rw-r--r--gnome-extra/eiciel/Manifest1
-rw-r--r--gnome-extra/eiciel/eiciel-0.9.13.ebuild42
-rw-r--r--gnome-extra/eiciel/files/eiciel_participant_target.hpp29
3 files changed, 72 insertions, 0 deletions
diff --git a/gnome-extra/eiciel/Manifest b/gnome-extra/eiciel/Manifest
index 1d44a931521e..7802f46daf13 100644
--- a/gnome-extra/eiciel/Manifest
+++ b/gnome-extra/eiciel/Manifest
@@ -1 +1,2 @@
DIST eiciel-0.9.12.1.tar.bz2 723727 BLAKE2B e32f3af9f4664610169fc718a9d274ae9d91c5d0d56a6be9872da1c105b349584300879742b753a02ad621cdc597591c52f47d705222ad52cb37b0750616a553 SHA512 f54fbb149eed7f8fd534b77ec5e2d0f579c68a39afd7417a2298d75c7e95c459b49fc8ccb66d0188956ffaadf3bcc8a3eb048425cb82fc875573eb131f4b0494
+DIST eiciel-0.9.13.tar.bz2 707838 BLAKE2B 30702b20482984885dfdb222e631f7572f3199b93509baa48762c0925b1fd78e1601a1279e7454543ddc32e813288cd01f0fdc2cb0c2eb0c5812cefcf8cac29f SHA512 7b5fde27e2d28c69f02092896bb0065372f93319d8ff8ad285b8b0e52acbe6d43b96f7dc215d7210602c6f766b48d2e2c66361dd28ea0f567ed6faf3bbcfdd14
diff --git a/gnome-extra/eiciel/eiciel-0.9.13.ebuild b/gnome-extra/eiciel/eiciel-0.9.13.ebuild
new file mode 100644
index 000000000000..d122ad8b681c
--- /dev/null
+++ b/gnome-extra/eiciel/eiciel-0.9.13.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome2
+
+DESCRIPTION="ACL editor for GNOME, with Nautilus extension"
+HOMEPAGE="https://rofi.roger-ferrer.org/eiciel/"
+SRC_URI="https://rofi.roger-ferrer.org/eiciel/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nautilus xattr"
+
+DEPEND="
+ >=sys-apps/acl-2.2.32
+ dev-cpp/gtkmm:3.0
+ >=dev-cpp/glibmm-2.50:2
+ nautilus? ( >=gnome-base/nautilus-3 )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.18.1
+"
+
+src_unpack() {
+ default
+
+ # https://github.com/rofirrim/eiciel/pull/6
+ cp "${FILESDIR}"/eiciel_participant_target.hpp "${S}"/src/
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --with-gnome-version=3 \
+ $(use_enable nautilus nautilus-extension) \
+ $(use_enable xattr user-attributes)
+}
diff --git a/gnome-extra/eiciel/files/eiciel_participant_target.hpp b/gnome-extra/eiciel/files/eiciel_participant_target.hpp
new file mode 100644
index 000000000000..a8072b642ff9
--- /dev/null
+++ b/gnome-extra/eiciel/files/eiciel_participant_target.hpp
@@ -0,0 +1,29 @@
+/*
+ Eiciel - GNOME editor of ACL file permissions.
+ Copyright (C) 2019 Roger Ferrer Ibáñez
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA
+*/
+
+#ifndef EICIEL_PARTICIPANT_TARGET_HPP
+#define EICIEL_PARTICIPANT_TARGET_HPP
+
+enum class AddParticipantTarget {
+ ADD_PARTICIPANT = 0,
+ ADD_PARTICIPANT_TO_DIRECTORY,
+ ADD_PARTICIPANT_TO_FILE,
+};
+
+#endif // EICIEL_PARTICIPANT_TARGET_HPP