summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-12-05 10:42:58 +0100
committerPacho Ramos <pacho@gentoo.org>2016-12-05 10:57:39 +0100
commita7950d34c8f0234e4221a1820f87ec2ccef3ae68 (patch)
tree1f71b2f233705fd911892767765e7778fa5e5ccf /gnome-extra/evolution-data-server
parentgnome-extra/evolution-data-server: Drop old (diff)
downloadgentoo-a7950d34c8f0234e4221a1820f87ec2ccef3ae68.tar.gz
gentoo-a7950d34c8f0234e4221a1820f87ec2ccef3ae68.tar.bz2
gentoo-a7950d34c8f0234e4221a1820f87ec2ccef3ae68.zip
gnome-extra/evolution-data-server: Version bump
Package-Manager: portage-2.3.2
Diffstat (limited to 'gnome-extra/evolution-data-server')
-rw-r--r--gnome-extra/evolution-data-server/Manifest1
-rw-r--r--gnome-extra/evolution-data-server/evolution-data-server-3.20.6.ebuild130
2 files changed, 131 insertions, 0 deletions
diff --git a/gnome-extra/evolution-data-server/Manifest b/gnome-extra/evolution-data-server/Manifest
index f66081ba0bd7..ccc77b45294f 100644
--- a/gnome-extra/evolution-data-server/Manifest
+++ b/gnome-extra/evolution-data-server/Manifest
@@ -1,2 +1,3 @@
DIST evolution-data-server-3.20.5.tar.xz 5067732 SHA256 0d1586cd326d997497a2a6fddd939a83892be07cb20f8c88fda5013f8c5bbe7e SHA512 8376331ae0ee96013d5c61b1da92393486d0eb9e0fed63199d4b6c28d92cb6d9dc45826fd65b476d894141d507742e8574168bc99b8704bebe8b39bbd297606e WHIRLPOOL 3c3417603bd2a18c7a3370e32af7f1581fc399ebe6f721d0ac678a5978d667b58df2927eb02f240b4c2f139133e06f25e13a47879b7b7a470cd1283a186bba10
+DIST evolution-data-server-3.20.6.tar.xz 5069584 SHA256 c9280149477cc0c75c20214814cfc54f0e5827c40080dadbbe4b4188479913aa SHA512 0526e64c407bd569b8fb45faeb902cdc15e46e5020c4187d76102f8e0b3173fdd0a742383cfed8de0351dd719c2ad33b39c7d4cd656312d07526ae8b85198dbc WHIRLPOOL e229d245ae79c6ecc2910bc6f110314e568d6afc546157af4e2a98be85e67ac1615f4085f3a4df2a94e658881ef6aa1c6d336b4ae3211bd0a85b2a81eef64f91
DIST evolution-data-server-3.22.2.tar.xz 5558204 SHA256 c0498e0968a60c3e42d5f72416c6e36752bced73bb530aa028dbd0008efd2167 SHA512 08ef1a0fbdca01ecbb253077443ffe04700a9443c5ace572bf7e14ad527cb27e2fe686481e4113c82d8ae0069ea8dec013650b9e948840b569bfac2e41812ed1 WHIRLPOOL f5e8c9ffe1dfc6722e1872d991f014b29cbb24a387159cbb87c588e80bd2c6e436ee2e77aefe032f5cbd5b707abeff00040ce2d383ddedab796aff68e5cd3dc9
diff --git a/gnome-extra/evolution-data-server/evolution-data-server-3.20.6.ebuild b/gnome-extra/evolution-data-server/evolution-data-server-3.20.6.ebuild
new file mode 100644
index 000000000000..67ca8473e19f
--- /dev/null
+++ b/gnome-extra/evolution-data-server/evolution-data-server-3.20.6.ebuild
@@ -0,0 +1,130 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+VALA_USE_DEPEND="vapigen"
+
+inherit db-use flag-o-matic gnome2 python-any-r1 systemd vala virtualx
+
+DESCRIPTION="Evolution groupware backend"
+HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"
+
+# Note: explicitly "|| ( LGPL-2 LGPL-3 )", not "LGPL-2+".
+LICENSE="|| ( LGPL-2 LGPL-3 ) BSD Sleepycat"
+SLOT="0/57" # subslot = libcamel-1.2 soname version
+
+IUSE="api-doc-extras berkdb +gnome-online-accounts +gtk google +introspection ipv6 ldap kerberos vala +weather"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-solaris"
+
+# sys-libs/db is only required for migrating from <3.13 versions
+# gdata-0.15.1 is required for google tasks
+# berkdb needed only for migrating old calendar data, bug #519512
+RDEPEND="
+ >=app-crypt/gcr-3.4
+ >=app-crypt/libsecret-0.5[crypt]
+ >=dev-db/sqlite-3.7.17:=
+ >=dev-libs/glib-2.40:2
+ >=dev-libs/libgdata-0.10:=
+ >=dev-libs/libical-0.43:=
+ >=dev-libs/libxml2-2
+ >=dev-libs/nspr-4.4:=
+ >=dev-libs/nss-3.9:=
+ >=net-libs/libsoup-2.42:2.4
+
+ dev-libs/icu:=
+ sys-libs/zlib:=
+ virtual/libiconv
+
+ berkdb? ( >=sys-libs/db-4:= )
+ gtk? (
+ >=app-crypt/gcr-3.4[gtk]
+ >=x11-libs/gtk+-3.10:3
+ )
+ google? (
+ >=dev-libs/json-glib-1.0.4
+ >=dev-libs/libgdata-0.15.1:=
+ >=net-libs/webkit-gtk-2.4.9:3
+ )
+ gnome-online-accounts? ( >=net-libs/gnome-online-accounts-3.8:= )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.12:= )
+ kerberos? ( virtual/krb5:= )
+ ldap? ( >=net-nds/openldap-2:= )
+ weather? ( >=dev-libs/libgweather-3.10:2= )
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ dev-util/gdbus-codegen
+ dev-util/gperf
+ >=dev-util/gtk-doc-am-1.14
+ >=dev-util/intltool-0.35.5
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+# eautoreconf needs:
+# >=gnome-base/gnome-common-2
+
+# Some tests fail due to missings locales.
+# Also, dbus tests are flacky, bugs #397975 #501834
+# It looks like a nightmare to disable those for now.
+RESTRICT="test"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # /usr/include/db.h is always db-1 on FreeBSD
+ # so include the right dir in CPPFLAGS
+ use berkdb && append-cppflags "-I$(db_includedir)"
+
+ # phonenumber does not exist in tree
+ gnome2_src_configure \
+ $(use_enable api-doc-extras gtk-doc) \
+ $(use_with api-doc-extras private-docs) \
+ $(usex berkdb --with-libdb="${EPREFIX}"/usr --with-libdb=no) \
+ $(use_enable gnome-online-accounts goa) \
+ $(use_enable gtk) \
+ $(use_enable google google-auth) \
+ $(use_enable google) \
+ $(use_enable introspection) \
+ $(use_enable ipv6) \
+ $(use_with kerberos krb5 "${EPREFIX}"/usr) \
+ $(use_with kerberos krb5-libs "${EPREFIX}"/usr/$(get_libdir)) \
+ $(use_with ldap openldap) \
+ $(use_enable vala vala-bindings) \
+ $(use_enable weather) \
+ --enable-largefile \
+ --enable-smime \
+ --with-systemduserunitdir="$(systemd_get_userunitdir)" \
+ --without-phonenumber \
+ --disable-examples \
+ --disable-uoa
+}
+
+src_test() {
+ unset ORBIT_SOCKETDIR
+ unset SESSION_MANAGER
+ virtx emake check
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use ldap; then
+ insinto /etc/openldap/schema
+ doins "${FILESDIR}"/calentry.schema
+ dosym /usr/share/${PN}/evolutionperson.schema /etc/openldap/schema/evolutionperson.schema
+ fi
+}