summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Vesely <jano.vesely@gmail.com>2020-04-05 12:40:23 -0400
committerMart Raudsepp <leio@gentoo.org>2020-04-22 19:12:49 +0300
commitb343195da6f273563253a4495a7af21fb5f39d2f (patch)
tree6d54f48bf4b377d0dd479846216a1cc101ab1115 /gnome-extra/evolution-data-server
parentdev-python/aiohttp-jinja2: Fix RedundantUriRename (diff)
downloadgentoo-b343195da6f273563253a4495a7af21fb5f39d2f.tar.gz
gentoo-b343195da6f273563253a4495a7af21fb5f39d2f.tar.bz2
gentoo-b343195da6f273563253a4495a7af21fb5f39d2f.zip
gnome-extra/evolution-data-server: Drop dependency on python
Build system dependency on python was removed back in 3.28 [0] [0] https://gitlab.gnome.org/GNOME/evolution-data-server/-/commit/a28389bae67f09a12e093998aa29956c66a7b359 Closes: https://bugs.gentoo.org/713058 Signed-off-by: Jan Vesely <jano.vesely@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/15236 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gnome-extra/evolution-data-server')
-rw-r--r--gnome-extra/evolution-data-server/evolution-data-server-3.32.5.ebuild8
-rw-r--r--gnome-extra/evolution-data-server/evolution-data-server-3.34.4.ebuild8
2 files changed, 2 insertions, 14 deletions
diff --git a/gnome-extra/evolution-data-server/evolution-data-server-3.32.5.ebuild b/gnome-extra/evolution-data-server/evolution-data-server-3.32.5.ebuild
index 1c26f9c18bec..d6a2e24c528e 100644
--- a/gnome-extra/evolution-data-server/evolution-data-server-3.32.5.ebuild
+++ b/gnome-extra/evolution-data-server/evolution-data-server-3.32.5.ebuild
@@ -2,10 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python3_6 )
VALA_USE_DEPEND="vapigen"
-inherit cmake-utils db-use flag-o-matic gnome2 python-any-r1 systemd vala virtualx
+inherit cmake-utils db-use flag-o-matic gnome2 systemd vala virtualx
DESCRIPTION="Evolution groupware backend"
HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"
@@ -58,7 +57,6 @@ RDEPEND="
weather? ( >=dev-libs/libgweather-3.10:2= )
"
DEPEND="${RDEPEND}
- ${PYTHON_DEPS}
dev-util/gdbus-codegen
dev-util/glib-utils
dev-util/gperf
@@ -75,10 +73,6 @@ DEPEND="${RDEPEND}
# It looks like a nightmare to disable those for now.
RESTRICT="test !test? ( test )"
-pkg_setup() {
- python-any-r1_pkg_setup
-}
-
# global scope PATCHES or DOCS array mustn't be used due to double default_src_prepare call
src_prepare() {
eapply "${FILESDIR}"/3.32.4-gtk-doc-fix{1,2}.patch
diff --git a/gnome-extra/evolution-data-server/evolution-data-server-3.34.4.ebuild b/gnome-extra/evolution-data-server/evolution-data-server-3.34.4.ebuild
index 83161debc3a7..5038eb72784e 100644
--- a/gnome-extra/evolution-data-server/evolution-data-server-3.34.4.ebuild
+++ b/gnome-extra/evolution-data-server/evolution-data-server-3.34.4.ebuild
@@ -2,10 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python3_6 )
VALA_USE_DEPEND="vapigen"
-inherit cmake-utils db-use flag-o-matic gnome2 python-any-r1 systemd vala virtualx
+inherit cmake-utils db-use flag-o-matic gnome2 systemd vala virtualx
DESCRIPTION="Evolution groupware backend"
HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"
@@ -58,7 +57,6 @@ RDEPEND="
weather? ( >=dev-libs/libgweather-3.10:2= )
"
DEPEND="${RDEPEND}
- ${PYTHON_DEPS}
dev-util/gdbus-codegen
dev-util/glib-utils
dev-util/gperf
@@ -78,10 +76,6 @@ DEPEND="${RDEPEND}
# It looks like a nightmare to disable those for now.
RESTRICT="test !test? ( test )"
-pkg_setup() {
- python-any-r1_pkg_setup
-}
-
# global scope PATCHES or DOCS array mustn't be used due to double default_src_prepare call
src_prepare() {
use vala && vala_src_prepare