summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-12-21 08:54:31 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2015-12-21 09:14:08 +0100
commitef5d296f1e9f606a3abf28a5cd52b058654897c8 (patch)
treed87a5777dfc562cf210bfee8ab9c4ae43ff88c61 /gnome-extra/evolution-ews/evolution-ews-3.18.3.ebuild
parentmail-client/evolution: restore ~ppc* keywords since cryptui has been keyworded (diff)
downloadgentoo-ef5d296f1e9f606a3abf28a5cd52b058654897c8.tar.gz
gentoo-ef5d296f1e9f606a3abf28a5cd52b058654897c8.tar.bz2
gentoo-ef5d296f1e9f606a3abf28a5cd52b058654897c8.zip
gnome-extra/evolution-ews: version bump to 3.18.3
Package-Manager: portage-2.2.26
Diffstat (limited to 'gnome-extra/evolution-ews/evolution-ews-3.18.3.ebuild')
-rw-r--r--gnome-extra/evolution-ews/evolution-ews-3.18.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnome-extra/evolution-ews/evolution-ews-3.18.3.ebuild b/gnome-extra/evolution-ews/evolution-ews-3.18.3.ebuild
new file mode 100644
index 000000000000..f511fc91a43c
--- /dev/null
+++ b/gnome-extra/evolution-ews/evolution-ews-3.18.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Evolution module for connecting to Microsoft Exchange Web Services"
+HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-db/sqlite:3=
+ >=dev-libs/glib-2.40:2
+ dev-libs/libical:0=
+ >=dev-libs/libxml2-2
+ >=gnome-extra/evolution-data-server-${PV}:0=
+ >=mail-client/evolution-${PV}:2.0
+ >=net-libs/libsoup-2.42:2.4
+ >=x11-libs/gtk+-3:3
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.9
+ >=dev-util/intltool-0.35.5
+ virtual/pkgconfig
+ test? ( net-libs/uhttpmock )
+"
+
+src_configure() {
+ # We don't have libmspack, needing internal lzx
+ gnome2_src_configure \
+ --with-internal-lzx \
+ $(use_enable test tests)
+}