summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-07-02 15:25:21 +0200
committerPacho Ramos <pacho@gentoo.org>2016-07-02 15:30:54 +0200
commitddb47cb7043b658b924aa41d669f5151ab829b4a (patch)
tree11495af09f192bd4edf5d4702d0ee821305e2687 /gnome-extra/evolution-ews
parentgnome-extra/evolution-ews: Drop old (diff)
downloadgentoo-ddb47cb7043b658b924aa41d669f5151ab829b4a.tar.gz
gentoo-ddb47cb7043b658b924aa41d669f5151ab829b4a.tar.bz2
gentoo-ddb47cb7043b658b924aa41d669f5151ab829b4a.zip
gnome-extra/evolution-ews: Version bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'gnome-extra/evolution-ews')
-rw-r--r--gnome-extra/evolution-ews/Manifest1
-rw-r--r--gnome-extra/evolution-ews/evolution-ews-3.20.3.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/gnome-extra/evolution-ews/Manifest b/gnome-extra/evolution-ews/Manifest
index a925f76f91bb..f17740d37619 100644
--- a/gnome-extra/evolution-ews/Manifest
+++ b/gnome-extra/evolution-ews/Manifest
@@ -1 +1,2 @@
DIST evolution-ews-3.18.5.tar.xz 702984 SHA256 7e1ed3b18161a620ba358ebf23e4c7aea85c0c5070be3c20a8a2ef012fbcfc55 SHA512 a1359803a9929391ac8b2945e411058cef6038c607706a08c1ab270c40d2b0840537e5c29416bf74bc9d5b3b6a073257f21f0c16951e6e1aa49ee8f983725c27 WHIRLPOOL 0d742407b3d293d4f70656e40dce3f1503f0e5f2ac599d2681a8cb49a34e5647aa4a8b3a85aeebd025e543fc54bc4f282c103bdb09d50d0be633c8e52fb2d4fb
+DIST evolution-ews-3.20.3.tar.xz 711996 SHA256 d1e0d1c6970f6a049ff6f41a691c2e455debd2cddf79251e4d0c127a845869b6 SHA512 dd87e83ae7e67b097199614ee4b0607882858ad5d2a3c1616147ea1eea2982486d73fd091f0ce1397d7e8571598b6d7e58ec74a87205539e2cf281b24ae5c8f3 WHIRLPOOL 3c67e79604f86a5d452e0d6e4d5749aa0c2e8bfc9b70b6fbe77517bd9335fed7fecc2827a0e97d87996d1da972a8ee5b045f9329768dc16d322893c7b1ac90c7
diff --git a/gnome-extra/evolution-ews/evolution-ews-3.20.3.ebuild b/gnome-extra/evolution-ews/evolution-ews-3.20.3.ebuild
new file mode 100644
index 000000000000..e068f9c90b5f
--- /dev/null
+++ b/gnome-extra/evolution-ews/evolution-ews-3.20.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Evolution module for connecting to Microsoft Exchange Web Services"
+HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-db/sqlite:3=
+ >=dev-libs/glib-2.40:2
+ dev-libs/libical:0=
+ >=dev-libs/libxml2-2
+ >=gnome-extra/evolution-data-server-${PV}:0=
+ >=mail-client/evolution-${PV}:2.0
+ >=net-libs/libsoup-2.42:2.4
+ >=x11-libs/gtk+-3:3
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.9
+ >=dev-util/intltool-0.35.5
+ virtual/pkgconfig
+ test? ( net-libs/uhttpmock )
+"
+
+src_configure() {
+ # We don't have libmspack, needing internal lzx
+ gnome2_src_configure \
+ --with-internal-lzx \
+ $(use_enable test tests)
+}