summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-06-06 14:17:02 -0700
committerMatt Turner <mattst88@gentoo.org>2021-06-06 14:49:10 -0700
commit685c42dde743dc62fb413949d700a39080b66f53 (patch)
tree0819f1a9c3a92007f56c17f3839ddf78c783b5be /gnome-extra/gnome-boxes
parentmail-client/evolution: Version bump to 3.40.2 (diff)
downloadgentoo-685c42dde743dc62fb413949d700a39080b66f53.tar.gz
gentoo-685c42dde743dc62fb413949d700a39080b66f53.tar.bz2
gentoo-685c42dde743dc62fb413949d700a39080b66f53.zip
gnome-extra/gnome-boxes: Version bump to 40.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-boxes')
-rw-r--r--gnome-extra/gnome-boxes/Manifest1
-rw-r--r--gnome-extra/gnome-boxes/gnome-boxes-40.2.ebuild129
2 files changed, 130 insertions, 0 deletions
diff --git a/gnome-extra/gnome-boxes/Manifest b/gnome-extra/gnome-boxes/Manifest
index ccf1228766c1..0d6822289b76 100644
--- a/gnome-extra/gnome-boxes/Manifest
+++ b/gnome-extra/gnome-boxes/Manifest
@@ -1 +1,2 @@
DIST gnome-boxes-40.1.tar.xz 1696528 BLAKE2B 7a593d535d2a6f0b0750c542a86a8210ac697fe8340f44830134c840d3a7500a6f6ecbbf901d6f37273f3354342b68cb1bdaf4cd7a5a98fc3047ee2ca5cc8b6a SHA512 a035454f3bdecc75222b27b6c1bf9807b21b9b3846300f2afafa3f30d4069b32a258e4d82f38cfeb407b21bd40d84031f57ddd63322dd6ba576c9795f355f33d
+DIST gnome-boxes-40.2.tar.xz 1697352 BLAKE2B 07f9fbad526bea4239a6eac3a3a26a53d30daab938158c4904b5ae674cf64cb2dd0fc6de073c41fc023c66df0328bc02dccf994ef09af597f117914c11bedefb SHA512 22f4a66bb60b47ae7c5ca7fb6f60eddf16a1ad209aa4541f05f732d815a2ac9f2fdac9f6d87cd5cf44d402d0f0d114466efbf129b22fea7b9b054e1b3c3ac145
diff --git a/gnome-extra/gnome-boxes/gnome-boxes-40.2.ebuild b/gnome-extra/gnome-boxes/gnome-boxes-40.2.ebuild
new file mode 100644
index 000000000000..2078408e917a
--- /dev/null
+++ b/gnome-extra/gnome-boxes/gnome-boxes-40.2.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_USE_DEPEND="vapigen"
+VALA_MIN_API_VERSION="0.40"
+
+inherit gnome.org gnome2-utils linux-info meson readme.gentoo-r1 vala xdg
+
+DESCRIPTION="Simple GNOME 3 application to access remote or virtual systems"
+HOMEPAGE="https://wiki.gnome.org/Apps/Boxes"
+
+LICENSE="LGPL-2+ CC-BY-2.0"
+SLOT="0"
+
+IUSE="rdp"
+KEYWORDS="~amd64"
+
+# FIXME: qemu probably needs to depend on spice[smartcard] directly with USE=spice
+# FIXME: Check over libvirt USE=libvirtd,qemu and the smartcard/usbredir requirements
+# Technically vala itself still ships a libsoup vapi, but that may change, and it should be better to use the .vapi from the same libsoup version
+# gtk-vnc raised due to missing vala bindings in earlier ebuilds
+DEPEND="
+ >=app-arch/libarchive-3.0.0:=
+ >=dev-libs/glib-2.52:2
+ >=x11-libs/gtk+-3.24.1:3
+ >=net-libs/gtk-vnc-0.8.0-r1[gtk3(+)]
+ x11-libs/gtksourceview:4
+ >=sys-libs/libosinfo-1.7.0
+ app-crypt/libsecret
+ >=net-libs/libsoup-2.44:2.4
+ virtual/libusb:1
+ >=app-emulation/libvirt-glib-4.0.0
+ >=dev-libs/libxml2-2.7.8:2
+ >=net-misc/spice-gtk-0.32[gtk3(+),smartcard,usbredir]
+ app-misc/tracker:3
+ >=net-libs/webkit-gtk-2.26.0:4
+ >=gui-libs/libhandy-1.0.0:1=
+
+ >=dev-libs/gobject-introspection-1.56:=
+ >=dev-libs/libgudev-165:=
+ rdp? ( >=net-misc/freerdp-2.0.0:= )
+" # gobject-introspection needed for libovf subproject (and gtk-frdp subproject with USE=rdp)
+# These are called via exec():
+# sys-fs/mtools mcopy for unattended file copying for files that libarchive doesn't support
+# app-cdr/cdrtools mkisofs is needed for unattended installer secondary disk image creation
+# app-emulation/libguestfs virt-sysprep is used for VM cloing, if not there, it logs debug and doesn't function
+# sys-apps/policycoreutils restorecon is used for checking selinux context
+# app-emulation/libvirt virsh used for various checks (and we need the library anyways)
+# sys-auth/polkit used for making all libvirt system disks readable via "pkexec chmod a+r" that aren't already readable to the user (libvirt system importer)
+# app-emulation/qemu qemu-img used to convert image to QCOW2 format during copy
+RDEPEND="${DEPEND}
+ app-cdr/cdrtools
+ app-misc/tracker-miners:3[iso]
+ app-emulation/spice[smartcard]
+ >=app-emulation/libvirt-0.9.3[libvirtd,qemu]
+ >=app-emulation/qemu-1.3.1[spice,smartcard,usbredir]
+ sys-fs/mtools
+ sys-auth/polkit
+"
+# gtk-frdp generates gir and needs gtk+ introspection for it
+# This is only needed for creating the .vapi file, but gnome-boxes needs it
+BDEPEND="
+ $(vala_depend)
+ net-libs/gtk-vnc[vala]
+ sys-libs/libosinfo[vala]
+ app-crypt/libsecret[vala]
+ net-libs/libsoup:2.4[vala]
+ app-emulation/libvirt-glib[vala]
+ net-misc/spice-gtk[vala]
+ x11-libs/vte:2.91[vala]
+ dev-libs/appstream-glib
+ rdp? ( x11-libs/gtk+:3[introspection] )
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="Before running gnome-boxes for local VMs, you will need to load the KVM modules.
+If you have an Intel Processor, run:
+# modprobe kvm-intel
+
+If you have an AMD Processor, run:
+# modprobe kvm-amd"
+
+pkg_pretend() {
+ linux-info_get_any_version
+
+ if linux_config_exists; then
+ if ! { linux_chkconfig_present KVM_AMD || \
+ linux_chkconfig_present KVM_INTEL; }; then
+ ewarn "You need KVM support in your kernel to use GNOME Boxes local VM support!"
+ fi
+ fi
+}
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Ddistributor_name=Gentoo
+ -Ddistributor_version=${PVR}
+ $(meson_use rdp)
+ -Dinstalled_tests=false
+ -Dflatpak=false
+ -Dprofile=default
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}