summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-03-06 10:58:48 +0200
committerMart Raudsepp <leio@gentoo.org>2019-03-06 13:04:32 +0200
commitc739111ed34bd55201744a996c74cdd385527ccd (patch)
treeda8f1ba3df7a920c4a30abfefe6b1d330858d467 /gnome-extra/gnome-calendar
parentmedia-gfx/gnome-photos: bump to 3.28.1 (diff)
downloadgentoo-c739111ed34bd55201744a996c74cdd385527ccd.tar.gz
gentoo-c739111ed34bd55201744a996c74cdd385527ccd.tar.bz2
gentoo-c739111ed34bd55201744a996c74cdd385527ccd.zip
gnome-extra/gnome-calendar: bump to 3.30.1
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-calendar')
-rw-r--r--gnome-extra/gnome-calendar/Manifest1
-rw-r--r--gnome-extra/gnome-calendar/gnome-calendar-3.30.1.ebuild59
-rw-r--r--gnome-extra/gnome-calendar/metadata.xml2
3 files changed, 61 insertions, 1 deletions
diff --git a/gnome-extra/gnome-calendar/Manifest b/gnome-extra/gnome-calendar/Manifest
index 34d3391254c1..6798a7ba7d46 100644
--- a/gnome-extra/gnome-calendar/Manifest
+++ b/gnome-extra/gnome-calendar/Manifest
@@ -1,2 +1,3 @@
DIST gnome-calendar-3.24.3.tar.xz 2425292 BLAKE2B cb859e229b040dd1ef34643e7aac5ddc1d0368d0bc6912effd73bd2c95ecab458294fef866f5718e108ef36f03bfc0dcb5a1140a571b3dc35128125ea8ff8e19 SHA512 979a369a5c5fc7d4621ff1ae69dfb1b53002cc014b2f1c480c0122da5bf4282c1928df9dcdb3528352e9589099184ab51f96d1a065e346be8e639aa5fc96ac67
DIST gnome-calendar-3.26.4.tar.xz 2443244 BLAKE2B a3117b4599e435959f515d4e1740adf66fb43a0138a325e38bbb2d269ed55407216e6ec8d4c1aae659cd3d0794f71d8dc7134dff786227b46405f7f9c06b1412 SHA512 6b7ee4fe409b9eeb9a84307142b4aab85e348f623a64bf66db09f9432e7c958e0bf83db7fe65c6d57efad84518cf2f859282e58ffdafefa6d8c30d863fb5007e
+DIST gnome-calendar-3.30.1.tar.xz 2443936 BLAKE2B 1826488ee03742a9350e589954723264318450d50fa7175955deee8fb3b3bbf2a29fbc6106644bccc062dd45bd9a16e7f40e2928c488bc333ba35d00f2411f25 SHA512 acb428f123fe716b41c4e828213b1106296731b5aa99607838219b8e6c802b22d3481eaa91429cfb34bc3d098344f406ea86c5e2f794f26414ba05bf0189fe29
diff --git a/gnome-extra/gnome-calendar/gnome-calendar-3.30.1.ebuild b/gnome-extra/gnome-calendar/gnome-calendar-3.30.1.ebuild
new file mode 100644
index 000000000000..b80021fd47f3
--- /dev/null
+++ b/gnome-extra/gnome-calendar/gnome-calendar-3.30.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome.org gnome2-utils meson virtualx xdg
+
+DESCRIPTION="Manage your online calendars with simple and modern interface"
+HOMEPAGE="https://wiki.gnome.org/Apps/Calendar"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk-doc"
+
+# >=libical-1.0.1 for https://bugzilla.gnome.org/show_bug.cgi?id=751244
+RDEPEND="
+ >=dev-libs/libical-1.0.1:0=
+ >=gnome-base/gsettings-desktop-schemas-3.21.2
+ >=gnome-extra/evolution-data-server-3.17.1:=
+ net-libs/libsoup:2.4
+ >=dev-libs/libdazzle-3.26.1
+ >=dev-libs/glib-2.58.0:2
+ >=x11-libs/gtk+-3.22.0:3
+ >=net-libs/gnome-online-accounts-3.2.0:=
+ >=dev-libs/libgweather-3.27.2:=
+ >=app-misc/geoclue-2.4:2.0
+ >=sci-geosciences/geocode-glib-3.23
+"
+DEPEND="${RDEPEND}
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ gtk-doc? ( dev-util/gtk-doc
+ app-text/docbook-xml-dtd:4.3 )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ meson_src_configure \
+ $(meson_use gtk-doc documentation)
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/gnome-extra/gnome-calendar/metadata.xml b/gnome-extra/gnome-calendar/metadata.xml
index a1f7e40c58af..b11b2364d3c3 100644
--- a/gnome-extra/gnome-calendar/metadata.xml
+++ b/gnome-extra/gnome-calendar/metadata.xml
@@ -7,5 +7,5 @@
</maintainer>
<longdescription lang="en">GNOME Calendar is a simple and beautiful calendar application designed to
perfectly fit the GNOME desktop. By reusing the components which the GNOME
-desktop is build on, Calendar nicely integrates with the GNOME ecosystem.</longdescription>
+desktop is built on, Calendar nicely integrates with the GNOME ecosystem.</longdescription>
</pkgmetadata>