summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-02-24 15:43:51 +0100
committerPacho Ramos <pacho@gentoo.org>2023-02-24 15:43:51 +0100
commita8a89fa5a451e46164b9feaf2d82ced03239a871 (patch)
treef2b91e0dd6b4c9fad71079d1693088df90f87cec /gnome-extra/gnome-shell-extension-bluetooth-quick-connect
parentgnome-extra/gnome-shell-extension-bing-wallpaper: stabilize 44 for ALLARCHES (diff)
downloadgentoo-a8a89fa5a451e46164b9feaf2d82ced03239a871.tar.gz
gentoo-a8a89fa5a451e46164b9feaf2d82ced03239a871.tar.bz2
gentoo-a8a89fa5a451e46164b9feaf2d82ced03239a871.zip
gnome-extra/gnome-shell-extension-bluetooth-quick-connect: add 33
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-shell-extension-bluetooth-quick-connect')
-rw-r--r--gnome-extra/gnome-shell-extension-bluetooth-quick-connect/Manifest1
-rw-r--r--gnome-extra/gnome-shell-extension-bluetooth-quick-connect/gnome-shell-extension-bluetooth-quick-connect-33.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-bluetooth-quick-connect/Manifest b/gnome-extra/gnome-shell-extension-bluetooth-quick-connect/Manifest
index 7c9a03333c9b..51067f31188f 100644
--- a/gnome-extra/gnome-shell-extension-bluetooth-quick-connect/Manifest
+++ b/gnome-extra/gnome-shell-extension-bluetooth-quick-connect/Manifest
@@ -1,2 +1,3 @@
DIST gnome-shell-extension-bluetooth-quick-connect-29.tar.gz 22626 BLAKE2B 9bc2e08b9fe04f742431a61a84846b09fea43d7735ad907bcbff0e9f5456f4068dbc999d407152965ba07dcbea609fb2c6f3bf14ab209f40beb65c2dbfc83f33 SHA512 01efe1eb9e2982da9c75119268c3748af5f25ceb21bef8aeffe322429572eae871b148fc92668a211739761f42691731815fd74eaf91870bd14e55f3ee557256
DIST gnome-shell-extension-bluetooth-quick-connect-30.tar.gz 23135 BLAKE2B e75d71980951e9e41512b83ce3ba86f91572e0c346b69bf79bbcb783bef75dbc8a76ae0a86307328bfbd5cf0f05bd98ac9272d06e38a54a591c277ae6e12e586 SHA512 15bfdc26535f997f82a428d46c808c04e619ae0f04aeaaf260c88a238e51f250ec4e66723fa58ed30992cd9a24304e056a88c3d4af3e8effee5700aa83edde98
+DIST gnome-shell-extension-bluetooth-quick-connect-33.tar.gz 26460 BLAKE2B fac17c01c0498420f6b3f35d770c5272112577be8001174b4781640e7e2e91c71e14373cb662a4c92539ebb724dda0986b96bb1fc78d4c5770a458f5898afcb2 SHA512 3642c09c9975f38b11dd8605cfce2030bb8aa5921c6cd55957cc8061cf670ff94af2f650745a891bdb491cfc768fe93da948518dc99c07d531e27e29adcece87
diff --git a/gnome-extra/gnome-shell-extension-bluetooth-quick-connect/gnome-shell-extension-bluetooth-quick-connect-33.ebuild b/gnome-extra/gnome-shell-extension-bluetooth-quick-connect/gnome-shell-extension-bluetooth-quick-connect-33.ebuild
new file mode 100644
index 000000000000..de6cf4b9945f
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-bluetooth-quick-connect/gnome-shell-extension-bluetooth-quick-connect-33.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome2-utils
+
+DESCRIPTION="Allow to connect bluetooth paired devices from gnome control panel"
+HOMEPAGE="https://github.com/bjarosze/gnome-bluetooth-quick-connect"
+SRC_URI="https://github.com/bjarosze/gnome-bluetooth-quick-connect/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE=""
+
+RDEPEND="
+ net-wireless/bluez
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-40
+"
+DEPEND="${COMMON_DEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/${P/shell-extension-}"
+extension_uuid="bluetooth-quick-connect@bjarosze.gmail.com"
+
+src_install() {
+ einstalldocs
+ insinto /usr/share/glib-2.0/schemas
+ doins schemas/*.xml
+ rm -rf README.md LICENSE Makefile schemas || die
+ insinto /usr/share/gnome-shell/extensions/"${extension_uuid}"
+ doins -r *
+ dosym ../../../../../usr/share/glib-2.0/schemas /usr/share/gnome-shell/extensions/"${extension_uuid}"/schemas
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}