summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-extra/gucharmap/gucharmap-3.0.1-r200.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-extra/gucharmap/gucharmap-3.0.1-r200.ebuild')
-rw-r--r--gnome-extra/gucharmap/gucharmap-3.0.1-r200.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/gnome-extra/gucharmap/gucharmap-3.0.1-r200.ebuild b/gnome-extra/gucharmap/gucharmap-3.0.1-r200.ebuild
new file mode 100644
index 000000000000..4c578c79d3fb
--- /dev/null
+++ b/gnome-extra/gucharmap/gucharmap-3.0.1-r200.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+GNOME_TARBALL_SUFFIX="bz2"
+
+inherit gnome2
+
+DESCRIPTION="Unicode character map viewer library"
+HOMEPAGE="https://live.gnome.org/Gucharmap"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sh sparc x86 ~x86-fbsd"
+IUSE="cjk doc +introspection"
+
+RDEPEND=">=dev-libs/glib-2.16.3:2
+ >=x11-libs/pango-1.2.1[introspection?]
+ >=x11-libs/gtk+-2.14.0:2[introspection?]
+
+ introspection? ( >=dev-libs/gobject-introspection-0.9.0 )"
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ virtual/pkgconfig
+ >=dev-util/intltool-0.40
+
+ sys-devel/gettext
+
+ doc? ( >=dev-util/gtk-doc-1.0 )"
+
+src_prepare() {
+ G2CONF="${G2CONF}
+ --disable-static
+ --with-gtk=2.0
+ --disable-charmap
+ --disable-gconf
+ $(use_enable introspection)
+ $(use_enable cjk unihan)"
+ # gconf is only needed for the gucharmap program
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+ # .desktop and schema files are only needed for the gucharmap program
+ sed -e 's:desktop_DATA\s*=.*:desktop_DATA = :' \
+ -e 's:schema_DATA\s*=.*:schema_DATA = :' \
+ -i Makefile.* || die "sed Makefile.* failed"
+
+ epatch "${FILESDIR}/${PN}-3.4.1.1-fix-doc.patch" # bug 436710, fixed in 3.6
+
+ gnome2_src_prepare
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ if ! has_version "gnome-extra/gucharmap:2.90" ; then
+ ewarn "Note: ${PF} includes only the gucharmap-2 library."
+ ewarn "If you need the gucharmap program, emerge gucharmap:2.90"
+ fi
+}