summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-11-06 17:31:33 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-11-06 19:29:35 +0100
commit312dd1dcac1834d10c2436abb58c13e7417946f3 (patch)
treebb20267ca35ac2c9c706647fd48ded4ed9311c98 /gnome-extra/gucharmap
parentwww-client/opera: bump to 72.0.3815.207 (diff)
downloadgentoo-312dd1dcac1834d10c2436abb58c13e7417946f3.tar.gz
gentoo-312dd1dcac1834d10c2436abb58c13e7417946f3.tar.bz2
gentoo-312dd1dcac1834d10c2436abb58c13e7417946f3.zip
gnome-extra/gucharmap: bump to v13.0.4
Closes: https://bugs.gentoo.org/739258 Closes: https://bugs.gentoo.org/738990 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/18155 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'gnome-extra/gucharmap')
-rw-r--r--gnome-extra/gucharmap/Manifest1
-rw-r--r--gnome-extra/gucharmap/gucharmap-13.0.4.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/gnome-extra/gucharmap/Manifest b/gnome-extra/gucharmap/Manifest
index 0e76bb6bbfe2..edb9cc1793a3 100644
--- a/gnome-extra/gucharmap/Manifest
+++ b/gnome-extra/gucharmap/Manifest
@@ -1,2 +1,3 @@
DIST gucharmap-12.0.1.tar.xz 1678524 BLAKE2B 90923dcb85f132f607007b272f56d091cd51f14d6818fc01fdedc594d736cc1047e4d3165f4ba3cede96ee2c0db4973890e1fde60c294fb848ffb3918988178f SHA512 989034350c73c3f1857167f434aa4a5c140ef7574cb799b874e421a8d0c2bf520dfcee85bc0cf8e52f439fb7d30e0db5172a25c107c80b38ce6da4e703a3ffc2
+DIST gucharmap-13.0.4.tar.gz 1900442 BLAKE2B 83925f04b23a5984e0180ae86d39842e419fe723604d3e93785241ed33ba56b80d68bfd8c99514ef542e515c78a0b64748781faa962d3a32e26746673ba4d2f0 SHA512 919f3298040962cf1b8636fe82a900e667d1f63c0f92c99b013d10cee7e7d5f074f3ffaa0ab8a8e3685b6764915a4e683e459fb680aeb65247c82c5a8a326bf9
DIST gucharmap-3.0.1.tar.bz2 3275481 BLAKE2B 80dde7791abdc72677add9c65c59f810e6c6952116b92db34059c4c40d2657246b17844c105e68f32c86294e9b4e71e9d48e6f0522855465734d7c24e8d17608 SHA512 4d8a2276b5cb1a0b0fadca2a8522755c5884985a12d5b19341b9cefcd7f749ec1286c0271419e38ec84be7edcfa1293e7f0263eb682c75387d692792de3e1fb1
diff --git a/gnome-extra/gucharmap/gucharmap-13.0.4.ebuild b/gnome-extra/gucharmap/gucharmap-13.0.4.ebuild
new file mode 100644
index 000000000000..44d0478aa587
--- /dev/null
+++ b/gnome-extra/gucharmap/gucharmap-13.0.4.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VALA_MIN_API_VERSION="0.26"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2-utils meson vala xdg
+
+DESCRIPTION="Unicode character map viewer and library"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gucharmap"
+SRC_URI="https://gitlab.gnome.org/GNOME/${PN}/-/archive/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="2.90"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+UNICODE_VERSION="13.0"
+
+IUSE="debug +introspection gtk-doc vala"
+
+BDEPEND="virtual/pkgconfig
+ >=sys-devel/gettext-0.19.8
+ gtk-doc? ( >=dev-util/gtk-doc-1 )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+ ${vala_depend}"
+
+DEPEND="=app-i18n/unicode-data-${UNICODE_VERSION}*
+ >=dev-libs/glib-2.32:2
+ media-libs/freetype:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ >=x11-libs/pango-1.42.4-r2[introspection?]"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ xdg_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Ducd_path="${EPREFIX}/usr/share/unicode-data"
+ $(meson_use debug dbg)
+ $(meson_use gtk-doc docs)
+ $(meson_use introspection gir)
+ $(meson_use vala vapi)
+ )
+
+ meson_src_configure
+}
+
+src_test() {
+ meson_src_test
+}
+
+src_install() {
+ meson_src_install
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}