summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-03-29 15:09:17 +0300
committerMart Raudsepp <leio@gentoo.org>2020-03-29 19:18:13 +0300
commit271a03e6382f3856be549610746bef3fe459a059 (patch)
tree90fb8325124cd6ca01164091be7f54eb50bfc5e0 /gnome-extra/sushi
parentsci-geosciences/gpxsee: bump to 7.26 (diff)
downloadgentoo-271a03e6382f3856be549610746bef3fe459a059.tar.gz
gentoo-271a03e6382f3856be549610746bef3fe459a059.tar.bz2
gentoo-271a03e6382f3856be549610746bef3fe459a059.zip
gnome-extra/sushi: bump to 3.34.0
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gnome-extra/sushi')
-rw-r--r--gnome-extra/sushi/Manifest2
-rw-r--r--gnome-extra/sushi/sushi-3.34.0.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/gnome-extra/sushi/Manifest b/gnome-extra/sushi/Manifest
index 033a247f9778..8ba673f0d642 100644
--- a/gnome-extra/sushi/Manifest
+++ b/gnome-extra/sushi/Manifest
@@ -1 +1,3 @@
DIST sushi-3.32.1.tar.xz 65172 BLAKE2B ad6d085e3c67527c988695195408e2dd8f82effeb0dacccb63eec9d3896c82fb1abf8d0fb92aeb6934146e67e8e203e438a900d4164d673b19cbe6af9d9a27b7 SHA512 db38b690591f7c7a5e55b7ad7a37022cd0624f48af6fe1c56ae05aa74598d767b61a1636d01ba207c399739c0cee6d266a52207a74f65f3e27216c5dfdd17909
+DIST sushi-3.34.0-patchset.tar.xz 8744 BLAKE2B 45077c7e78ebea5900ff8a1e8749f88677a6990d41cf44505437c5cbd05ce09b2ddef11de8e9078d419b1130f14d8ef4cbe7c6f15c80cee02dd72b17c4e84cfe SHA512 7c3d8e044179202a37c09436192436102a1ca223e358de1bc3857b0900c9921c72b1ab588fb08cfebe6ae440669a68786c3c1e83c1f6a3c489d4a5ce665217b3
+DIST sushi-3.34.0.tar.xz 74240 BLAKE2B 8b194be7ec831ce4f13549d465d6f1e6ba09ae4dc7ff86b1c214b79baac226654b75401d326d5d7d8fc0cc9fff28d8125aa4f5a9d3cdf54e472e5565815af75d SHA512 bde009b30106bf31199c8c3b040743de5f5c782fd540612a34055bef9a22f9a08c4ed0ae7c5fc3cbfdc67a5d12f28bc70ca5135ba227403e8d127295a1253d18
diff --git a/gnome-extra/sushi/sushi-3.34.0.ebuild b/gnome-extra/sushi/sushi-3.34.0.ebuild
new file mode 100644
index 000000000000..80116931e29a
--- /dev/null
+++ b/gnome-extra/sushi/sushi-3.34.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org meson xdg
+
+DESCRIPTION="A quick previewer for Nautilus, the GNOME file manager"
+HOMEPAGE="https://git.gnome.org/browse/sushi"
+SRC_URI+=" https://dev.gentoo.org/~leio/distfiles/${P}-patchset.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="office wayland +X"
+REQUIRED_USE="|| ( wayland X )"
+
+# Optional app-office/libreoffice support (OOo to pdf and then preview)
+COMMON_DEPEND="
+ media-libs/libepoxy
+ >=app-text/evince-3.0[introspection]
+ media-libs/freetype:2
+ >=x11-libs/gdk-pixbuf-2.23.0[introspection]
+ >=dev-libs/glib-2.29.14:2
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection]
+ >=x11-libs/gtk+-3.13.2:3[introspection,wayland?,X?]
+ >=x11-libs/gtksourceview-4.0.3:4[introspection]
+ >=media-libs/harfbuzz-0.9.9:=
+ >=dev-libs/gobject-introspection-1.54:=
+ media-libs/musicbrainz:5=
+ net-libs/webkit-gtk:4[introspection]
+ >=dev-libs/gjs-1.40
+"
+DEPEND="${RDEPEND}
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+RDEPEND="${COMMON_DEPEND}
+ >=gnome-base/nautilus-3.1.90
+ office? ( app-office/libreoffice )
+"
+
+PATCHES=(
+ # origin/master updates up to 2020-03-10, primarily for gtk[-wayland] fixes
+ "${WORKDIR}"/patches
+)
+
+src_configure() {
+ meson_src_configure \
+ $(meson_feature wayland) \
+ $(meson_feature X X11)
+}
+
+src_compile() {
+ local -x GST_PLUGIN_SYSTEM_PATH_1_0=
+ meson_src_compile
+}